summaryrefslogtreecommitdiff
path: root/meta-quanta
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2021-05-05 16:15:53 +0300
committerGeorge Hung <george.hung@quantatw.com>2021-05-06 04:35:52 +0300
commit1b315f63300a3b430f2e241c1423a9fb0601cd09 (patch)
tree8139c492b09ebefe435fd88164938a9bbd998926 /meta-quanta
parent96a7ee39b88ce3db86c65e21d3390d97b12166c6 (diff)
downloadopenbmc-1b315f63300a3b430f2e241c1423a9fb0601cd09.tar.xz
meta-quanta: gbs: update bmcweb build option
- update to use meson instead of cmake - change http request body limit size to 40MB to pass firmware update of Robot framework test for GBS - create /var/lib/bmcweb folder to satisfy the path redfish eventservice required to save config and subscriptions Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: Ic0de91547d11aad9cc6412a389d26c2da5c79644
Diffstat (limited to 'meta-quanta')
-rwxr-xr-xmeta-quanta/meta-gbs/recipes-phosphor/interfaces/bmcweb_%.bbappend9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/interfaces/bmcweb_%.bbappend b/meta-quanta/meta-gbs/recipes-phosphor/interfaces/bmcweb_%.bbappend
index 87ecf4fa3..2c19a3ead 100755
--- a/meta-quanta/meta-gbs/recipes-phosphor/interfaces/bmcweb_%.bbappend
+++ b/meta-quanta/meta-gbs/recipes-phosphor/interfaces/bmcweb_%.bbappend
@@ -1,3 +1,8 @@
-EXTRA_OECMAKE_append_gbs = " \
- -DBMCWEB_ENABLE_REDFISH_DBUS_LOG_ENTRIES=ON \
+EXTRA_OEMESON_append_gbs = " \
+ -Dredfish-dbus-log=enabled \
+ -Dhttp-body-limit=40 \
"
+
+do_install_append_gbs(){
+ install -d ${D}${localstatedir}/lib/bmcweb
+}