summaryrefslogtreecommitdiff
path: root/meta-quanta
diff options
context:
space:
mode:
authorBrandon Kim <brandonkim@google.com>2021-04-29 03:33:05 +0300
committerBrandon Kim <brandonkim@google.com>2021-04-29 04:28:22 +0300
commit7616e873053477f1200110d7f854af336af6c0c7 (patch)
tree8912738c629464a6c7c214bebc727cab7cba2ae1 /meta-quanta
parentb69c040882ccb50a87dd69c41aa0c4d1101d42c8 (diff)
downloadopenbmc-7616e873053477f1200110d7f854af336af6c0c7.tar.xz
meta-quanta: gbs: Add explicit RDEPENDS for tools
gbs-sysinit requires i2c-tools and gbs-hotswap-powercycle requires libgpiod-tools. Declare the RDEPENDS in the bitbake file. Signed-off-by: Brandon Kim <brandonkim@google.com> Change-Id: I28bdb2cc138e301faa395eb9150cc7624b93c8a3
Diffstat (limited to 'meta-quanta')
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/gbs-sysinit.bb3
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/hotswap-power-cycle/gbs-hotswap-power-cycle.bb1
2 files changed, 3 insertions, 1 deletions
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/gbs-sysinit.bb b/meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/gbs-sysinit.bb
index 68a9cf181..c9d595a3d 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/gbs-sysinit.bb
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/gbs-sysinit.bb
@@ -8,8 +8,9 @@ inherit systemd
DEPENDS += "systemd"
RDEPENDS_${PN} += "bash"
-RDEPENDS_${PN} += "libsystemd"
+RDEPENDS_${PN} += "i2c-tools"
RDEPENDS_${PN} += "jq"
+RDEPENDS_${PN} += "libsystemd"
SRC_URI = "file://gbs-sysinit.sh \
file://gbs-gpio-common.sh \
diff --git a/meta-quanta/meta-gbs/recipes-gbs/hotswap-power-cycle/gbs-hotswap-power-cycle.bb b/meta-quanta/meta-gbs/recipes-gbs/hotswap-power-cycle/gbs-hotswap-power-cycle.bb
index 6bf7bb69f..7c28dc28d 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/hotswap-power-cycle/gbs-hotswap-power-cycle.bb
+++ b/meta-quanta/meta-gbs/recipes-gbs/hotswap-power-cycle/gbs-hotswap-power-cycle.bb
@@ -8,6 +8,7 @@ inherit systemd
DEPENDS += "systemd"
RDEPENDS_${PN} += "bash"
+RDEPENDS_${PN} += "libgpiod-tools"
SRC_URI = " file://hotswap-power-cycle.service \
file://tray_powercycle.sh \