summaryrefslogtreecommitdiff
path: root/meta-quanta
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2021-04-29 06:03:27 +0300
committerGeorge Hung <george.hung@quantatw.com>2021-04-29 08:28:00 +0300
commit7ef770c8e7d4574e6bc0c35b972124ee90ab66ef (patch)
tree4880ae1a4ac2d2b1a6b5b480934e65d06702fa33 /meta-quanta
parentc4d7953f9ccb03549bbd7af2cd2fa755c0aaaf59 (diff)
downloadopenbmc-7ef770c8e7d4574e6bc0c35b972124ee90ab66ef.tar.xz
meta-quanta: gbs: remove dbus-interfaces patches for watchdog
Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: Idce541a84d476fa9c5af0fd1311eee9f9732679b
Diffstat (limited to 'meta-quanta')
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/dbus/phosphor-dbus-interfaces/0024-Add-the-pre-timeout-interrupt-defined-in-IPMI-spec.patch57
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/dbus/phosphor-dbus-interfaces/0025-Add-PreInterruptFlag-properity-in-DBUS.patch39
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend5
3 files changed, 0 insertions, 101 deletions
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/dbus/phosphor-dbus-interfaces/0024-Add-the-pre-timeout-interrupt-defined-in-IPMI-spec.patch b/meta-quanta/meta-gbs/recipes-phosphor/dbus/phosphor-dbus-interfaces/0024-Add-the-pre-timeout-interrupt-defined-in-IPMI-spec.patch
deleted file mode 100644
index 67fa59090..000000000
--- a/meta-quanta/meta-gbs/recipes-phosphor/dbus/phosphor-dbus-interfaces/0024-Add-the-pre-timeout-interrupt-defined-in-IPMI-spec.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 6e9a19c43acac7d4254910906329d98d7b59085a Mon Sep 17 00:00:00 2001
-From: Ren Yu <yux.ren@intel.com>
-Date: Fri, 24 May 2019 14:55:10 +0800
-Subject: [PATCH] Add the pre-timeout interrupt defined in IPMI spec
-
-The IPMI watchdog pre-timeout interrupt is used to set the different
-pre-timeout interrupt source. Add them as a dbus property,
-IPMI set/get watchdog commands will use it.
-
-Signed-off-by: Ren Yu <yux.ren@intel.com>
----
- xyz/openbmc_project/State/Watchdog.interface.yaml | 22 ++++++++++++++++++++++
- 1 file changed, 22 insertions(+)
-
-diff --git a/xyz/openbmc_project/State/Watchdog.interface.yaml b/xyz/openbmc_project/State/Watchdog.interface.yaml
-index 2fc47d8..6dfa9b9 100644
---- a/xyz/openbmc_project/State/Watchdog.interface.yaml
-+++ b/xyz/openbmc_project/State/Watchdog.interface.yaml
-@@ -33,6 +33,11 @@ properties:
- description: >
- The action the watchdog should perform when it expires.
- default: 'HardReset'
-+ - name: PreTimeoutInterrupt
-+ type: enum[self.PreTimeoutInterruptAction]
-+ description: >
-+ The BMC generates the selected interrupt before the timer expires.
-+ default: 'None'
- - name: Interval
- type: uint64
- description: >
-@@ -73,6 +78,23 @@ enumerations:
- description: >
- Perform a power cycle of the system.
-
-+ - name: PreTimeoutInterruptAction
-+ description: >
-+ The type of PreTimeout Interrupt.
-+ values:
-+ - name: 'None'
-+ description: >
-+ Do nothing.
-+ - name: 'SMI'
-+ description: >
-+ SMI.
-+ - name: 'NMI'
-+ description: >
-+ NMI / Diagnostic Interrupt.
-+ - name: 'MI'
-+ description: >
-+ Messaging Interrupt.
-+
- - name: TimerUse
- description: >
- The type of timer use.
---
-2.7.4
-
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/dbus/phosphor-dbus-interfaces/0025-Add-PreInterruptFlag-properity-in-DBUS.patch b/meta-quanta/meta-gbs/recipes-phosphor/dbus/phosphor-dbus-interfaces/0025-Add-PreInterruptFlag-properity-in-DBUS.patch
deleted file mode 100644
index d7e66abd2..000000000
--- a/meta-quanta/meta-gbs/recipes-phosphor/dbus/phosphor-dbus-interfaces/0025-Add-PreInterruptFlag-properity-in-DBUS.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From b7c487750c05dcc081219ccdd4ef539beef6aa30 Mon Sep 17 00:00:00 2001
-From: Ren Yu <yux.ren@intel.com>
-Date: Mon, 29 Jul 2019 10:51:12 +0800
-Subject: [PATCH] Add PreInterruptFlag properity in DBUS.
-
-PreTimeoutInterruptOccurFlag in DBUS would be set 'true'
-when watchdog pre-timeout interrupt occurred.
-
-Tested:
-Enable command(raw 0x06 0x31) that get message flag
-can set right bit about watchdog,
-need record PreTimeoutInterruptOccurFlag
-at xyz.openbmmc_project.State.Watchdog when watchdog
-pre-timeout interrupt occurred.
-
-Signed-off-by: Ren Yu <yux.ren@intel.com>
----
- xyz/openbmc_project/State/Watchdog.interface.yaml | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/xyz/openbmc_project/State/Watchdog.interface.yaml b/xyz/openbmc_project/State/Watchdog.interface.yaml
-index bf4cca0..6579368 100644
---- a/xyz/openbmc_project/State/Watchdog.interface.yaml
-+++ b/xyz/openbmc_project/State/Watchdog.interface.yaml
-@@ -59,6 +59,11 @@ properties:
- description: >
- The timer user at the time of expiration.
- default: 'Reserved'
-+ - name: PreTimeoutInterruptOccurFlag
-+ type: boolean
-+ description: >
-+ PreTimeoutInterruptOccurFlag that preTimeoutInterrupt action occurred.
-+ default: false
-
- enumerations:
- - name: Action
---
-2.7.4
-
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend b/meta-quanta/meta-gbs/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
deleted file mode 100644
index 0b5bff905..000000000
--- a/meta-quanta/meta-gbs/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
-
-SRC_URI_append_gbs = " file://0024-Add-the-pre-timeout-interrupt-defined-in-IPMI-spec.patch \
- file://0025-Add-PreInterruptFlag-properity-in-DBUS.patch \
- "