summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/README.md
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-05-15 22:19:14 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-05-21 23:43:47 +0300
commit062316f13d6e9d71a14724e293241b6258c63876 (patch)
treeaaf7deae114e1498f8b9eaabeba5e88b38938f71 /meta-raspberrypi/README.md
parent1fe918a07084c878d72cf8a7d1707f6598cc438f (diff)
downloadopenbmc-062316f13d6e9d71a14724e293241b6258c63876.tar.xz
meta-raspberrypi: subtree update:05c86e3160..6f85d3f665
Bartłomiej Burdukiewicz (1): linux-raspberrypi_5.4.bb: Update to latest Drew Moseley (1): raspberrypi3: Switch to vc4-fkms-v3d. Fabio Berton (1): rpi-u-boot-scr: Set u-boot-default-script as provider Khem Raj (20): rpio: Use python3 during build gstreamer1.0-plugins-base: Adjust for meson conversion mesa: Fix patch fuzz linux-raspberrypi: Fix building selftest/bpf oeqa: Add rpi specific kernel dmesg parser linux-raspberrypi: Get PMU fixes on top of 4.19.108 qtbase: Append userland to rdeps iff vc4graphics is not enabled qtbase: Drop xkb packageconfig userland: Update to 20200316 snapshot userland: Fix build with gcc10 rpi-base: Drop old dtbo names linux-raspberrypi: Add recipes for kernel 5.4 linux-raspberrypi_5.4.bb: Update to latest and fix build with binutils 2.34 linux-raspberrypi_5.4.bb: Enable powersave options in kconfig linux-raspberrypi_5.4.bb: Backport the patch to use CHECK macro instead of RET_IF linux-raspberrypi_5.4.bb: Update to latest linux-firmware-rpidistro: Upgrade to 20190114-1+rpt6 psplash: Do not define ALTERNATIVE_PRIORITY for non-existing provider linux-raspberrypi_5.4.bb: Update to latest linux-raspberrypi_5.4.bb: Update to 5.4.35 Leon Anavi (3): docs/extra-build-config.md: Auto-load I2C modules rpi-base.inc: Add kernel modules to all images rpi-base.inc: Include modules if I2C is enaled Madhavan Krishnan (1): gstreamer: Fix the compilation issue in meta multimedia image Martin Jansa (7): userland: add pkg-config for openmaxil and add virtual/libomxil to PROVIDES gstreamer1.0-plugins-base: adapt to gstreamer1.0 now using meson gstreamer1.0-omx: let virtual/libomxil dependency to pull userland omxplayer: respect virtual/libomxil packagegroup-rpi-test: include bigbuckbunny in RRECOMMENDS_${PN} only with meta-multimedia packagegroup-rpi-test: use MACHINE_ARCH linux-raspberrypi: fix perf build with latest binutils Orne Brocaar (1): rpi-base.conf: add disable-bt.dtbo and miniuart-bt.dtbo overlays. Pierre-Jean Texier (17): kas-poky-rpi: add kas file rpi-base.inc: use wic.bz2 for all rpi machines by default linux-raspberrypi: bump to Linux version 4.19.97 raspberrypi-firmware: bump to version 20200205 linux-raspberrypi: bump to Linux version 4.19.102 linux-raspberrypi: bump to Linux version 4.19.105 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.108 raspberrypi-firmware: update to current HEAD layer.conf: add dunfell to compat layer raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.113 README.md: add status badge for raspberrypi4 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.115 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.120 rkhan467 (1): mesa: querying dma_buf modifiers for specific formats Change-Id: I956a7aedff5028fa3af56b101ecaad17b3ff64e0 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-raspberrypi/README.md')
-rw-r--r--meta-raspberrypi/README.md23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-raspberrypi/README.md b/meta-raspberrypi/README.md
index 212576793..6c4e1e44e 100644
--- a/meta-raspberrypi/README.md
+++ b/meta-raspberrypi/README.md
@@ -5,6 +5,7 @@ Yocto BSP layer for the Raspberry Pi boards - <http://www.raspberrypi.org/>.
[![Build Status](https://yocto-ci.resin.io/job/meta-raspberrypi1/badge/icon)](https://yocto-ci.resin.io/job/meta-raspberrypi1)
[![Build Status](https://yocto-ci.resin.io/job/meta-raspberrypi2/badge/icon)](https://yocto-ci.resin.io/job/meta-raspberrypi2)
[![Build Status](https://yocto-ci.resin.io/job/meta-raspberrypi3/badge/icon)](https://yocto-ci.resin.io/job/meta-raspberrypi3)
+[![Build Status](https://yocto-ci.resin.io/job/meta-raspberrypi4/badge/icon)](https://yocto-ci.resin.io/job/meta-raspberrypi4)
[![Documentation Status](https://readthedocs.org/projects/meta-raspberrypi/badge/?version=latest)](https://meta-raspberrypi.readthedocs.io/en/latest/?badge=latest)
[![Matrix](https://img.shields.io/matrix/meta-raspberrypi:cub.icu.svg?server_fqdn=matrix.cub.icu)](https://matrix.to/#/#meta-raspberrypi:cub.icu)
@@ -52,6 +53,28 @@ This layer depends on:
5. dd to a SD card the generated sdimg file (use xzcat if rpi-sdimg.xz is used)
6. Boot your RPI.
+## Quick Start with kas
+
+1. Install kas build tool from PyPi (sudo pip3 install kas)
+2. kas build meta-raspberrypi/kas-poky-rpi.yml
+3. dd to a SD card the generated sdimg file (use xzcat if rpi-sdimg.xz is used)
+4. Boot your RPI.
+
+To adjust the build configuration with specific options (I2C, SPI, ...), simply add
+a section as follows:
+
+```
+local_conf_header:
+ rpi-specific: |
+ ENABLE_I2C = "1"
+ RPI_EXTRA_CONFIG = "dtoverlay=pi3-disable-bt"
+```
+
+To configure the machine, you have to update the `machine` variable.
+And the same for the `distro`.
+
+For further information, you can read more at <https://kas.readthedocs.io/en/1.0/index.html>
+
## Maintainers
* Andrei Gherzan `<andrei at gherzan.ro>`