summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-09 21:56:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-09 21:57:26 +0300
commitf0578c1dfb63be4c5366e537b33caf10e96b3aa9 (patch)
tree1759b4854323b34ab3bffbabe09744dd71a71802 /meta-raspberrypi/recipes-bsp
parent1fdf4aa48a5446689546be41e10dd0e8832605d6 (diff)
downloadopenbmc-f0578c1dfb63be4c5366e537b33caf10e96b3aa9.tar.xz
meta-raspberrypi: subtree update:e811912fae..866ccc829f
Andrei Gherzan (1): linux-raspberrypi: Update 4.19 recipe to 4.19.71 Khem Raj (2): layer.conf: Add zeus to compatible layers eglinfo: Drop bbappend Martin Jansa (1): u-boot-fw-utils: apply the same rpi4 patches as for u-boot recipe Change-Id: I96685a22f825681c6739af38f44c0bda4eaacd1d Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-raspberrypi/recipes-bsp')
-rw-r--r--meta-raspberrypi/recipes-bsp/u-boot/u-boot-fw-utils_2019.07.bbappend2
-rw-r--r--meta-raspberrypi/recipes-bsp/u-boot/u-boot-rpi4-2019.07.inc12
-rw-r--r--meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend14
3 files changed, 16 insertions, 12 deletions
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/u-boot-fw-utils_2019.07.bbappend b/meta-raspberrypi/recipes-bsp/u-boot/u-boot-fw-utils_2019.07.bbappend
new file mode 100644
index 000000000..3daf157d7
--- /dev/null
+++ b/meta-raspberrypi/recipes-bsp/u-boot/u-boot-fw-utils_2019.07.bbappend
@@ -0,0 +1,2 @@
+# Apply the same patches for rpi4 as u-boot recipe
+require u-boot-rpi4-${PV}.inc
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/u-boot-rpi4-2019.07.inc b/meta-raspberrypi/recipes-bsp/u-boot/u-boot-rpi4-2019.07.inc
new file mode 100644
index 000000000..2ce55a2b1
--- /dev/null
+++ b/meta-raspberrypi/recipes-bsp/u-boot/u-boot-rpi4-2019.07.inc
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend_raspberrypi4 := "${THISDIR}/u-boot-2019.07:"
+UBOOT_RPI4_SUPPORT_PATCHES = " \
+ file://0001-configs-rpi4-Add-defconfigs-for-rpi4-32-64.patch \
+ file://0002-ARM-bcm283x-Add-BCM283x_BASE-define.patch \
+ file://0003-arm-mach-bcm283x-Define-configs-for-RaspberryPi-4.patch \
+ file://0004-rpi-Add-entry-for-Raspberry-Pi-4-model-B.patch \
+ file://0005-arm-bcm283x-Include-definition-for-additional-emmc-c.patch \
+ file://0006-mmc-bcm2835_sdhci-Add-support-for-bcm2711-device.patch \
+ file://0007-rpi-Add-memory-map-for-bcm2838.patch \
+"
+
+SRC_URI_append_raspberrypi4 = "${UBOOT_RPI4_SUPPORT_PATCHES}"
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend b/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend
index 7cd8d66c3..3daf157d7 100644
--- a/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend
+++ b/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend
@@ -1,12 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
-UBOOT_RPI4_SUPPORT_PATCHES = " \
- file://0001-configs-rpi4-Add-defconfigs-for-rpi4-32-64.patch \
- file://0002-ARM-bcm283x-Add-BCM283x_BASE-define.patch \
- file://0003-arm-mach-bcm283x-Define-configs-for-RaspberryPi-4.patch \
- file://0004-rpi-Add-entry-for-Raspberry-Pi-4-model-B.patch \
- file://0005-arm-bcm283x-Include-definition-for-additional-emmc-c.patch \
- file://0006-mmc-bcm2835_sdhci-Add-support-for-bcm2711-device.patch \
- file://0007-rpi-Add-memory-map-for-bcm2838.patch \
-"
-
-SRC_URI_append_raspberrypi4 = "${UBOOT_RPI4_SUPPORT_PATCHES}"
+# Apply the same patches for rpi4 as u-boot recipe
+require u-boot-rpi4-${PV}.inc