summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-connectivity
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-06-25 22:23:27 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-06-28 15:35:59 +0300
commita4353c83a2d230d0992feedbf462cc243ab37126 (patch)
tree1424e8661f114308fab76e36aa3485377eb3d830 /meta-raspberrypi/recipes-connectivity
parentfec94c7b8f7adb79e6d63db1a7e88b54eecc1749 (diff)
downloadopenbmc-a4353c83a2d230d0992feedbf462cc243ab37126.tar.xz
meta-raspberrypi: subtree update:ffc402ef5e..17b56ab075
Andreas Müller (1): pi-bluetooth: upgrade 0.1.12 -> 0.1.17 Devendra Tewari (1): Add WM8960 soundcard support Paul Barker (1): rpi-cmdline: Package is machine-specific Pierre-Jean Texier (1): kas: remove 'image-mklibs' from USER_CLASSES list Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I08366a667f191efd45b717be5bd530ae1af782b5
Diffstat (limited to 'meta-raspberrypi/recipes-connectivity')
-rw-r--r--meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth/0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch33
-rw-r--r--meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb (renamed from meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.12.bb)2
2 files changed, 24 insertions, 11 deletions
diff --git a/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth/0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth/0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch
index 45b43c725..079377e0e 100644
--- a/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth/0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch
+++ b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth/0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch
@@ -8,20 +8,33 @@ Signed-off-by: Peter A. Bigot <pab@pabigot.com>
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
---
- usr/bin/bthelper | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
+ usr/bin/bthelper | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/usr/bin/bthelper b/usr/bin/bthelper
-index af597e5..5de84f6 100755
+index 2133fbc..1fc9245 100755
--- a/usr/bin/bthelper
+++ b/usr/bin/bthelper
-@@ -10,7 +10,7 @@ fi
+@@ -12,8 +12,8 @@ fi
+ dev=$1
- dev="$1"
# Need to bring hci up before looking at MAC as it can be all zeros during init
--/bin/hciconfig "$dev" up
--/bin/hciconfig "$dev" | grep -qE "BD Address: (B8:27:EB|DC:A6:32):" || exit 0
-+/usr/bin/hciconfig "$dev" up
-+/usr/bin/hciconfig "$dev" | grep -qE "BD Address: (B8:27:EB|DC:A6:32):" || exit 0
- /usr/bin/hcitool -i "$dev" cmd 0x3f 0x1c 0x01 0x02 0x00 0x01 0x01 > /dev/null
+-/bin/hciconfig $dev up
+-if ! /bin/hciconfig $dev | grep -q "Bus: UART"; then
++/usr/bin/hciconfig $dev up
++if ! /usr/bin/hciconfig $dev | grep -q "Bus: UART"; then
+ echo Not a UART-attached BT Modem
+ exit 0
+ fi
+@@ -26,7 +26,7 @@ if ( /usr/bin/hcitool -i $dev dev | grep -q -E '\s43:4[35]:' ); then
+ BDADDR=`printf '0x%02x 0x%02x 0x%02x 0xeb 0x27 0xb8' $((0x$B3 ^ 0xaa)) $((0x$B2 ^ 0xaa)) $((0x$B1 ^ 0xaa))`
+ /usr/bin/hcitool -i $dev cmd 0x3f 0x001 $BDADDR
+- /bin/hciconfig $dev reset
++ /usr/bin/hciconfig $dev reset
+ else
+ echo Raspberry Pi BDADDR already set
+ fi
+--
+2.31.1
+
diff --git a/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.12.bb b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb
index ccf714baf..a1eb97fe8 100644
--- a/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.12.bb
+++ b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb
@@ -10,7 +10,7 @@ SRC_URI = "\
git://github.com/RPi-Distro/pi-bluetooth \
file://0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch \
"
-SRCREV = "cbdbcb66bcc5b9af05f1a9fffe2254c872bb0ace"
+SRCREV = "fd4775bf90e037551532fc214a958074830bb80d"
S = "${WORKDIR}/git"