summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-graphics/mesa
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
commitd73e39703a0260c8911cb439b579e1c2bada4b20 (patch)
tree4fa9f965ae954c587ab773ecaced6b8f8e18d359 /meta-raspberrypi/recipes-graphics/mesa
parent6f106a0a4ce15fe0678d4ffefd572e6978c72597 (diff)
parent6d8c5d2c6204714ca6b7a43f04348162b683cdbc (diff)
downloadopenbmc-d73e39703a0260c8911cb439b579e1c2bada4b20.tar.xz
Merge tag '0.75' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-raspberrypi/recipes-graphics/mesa')
-rw-r--r--meta-raspberrypi/recipes-graphics/mesa/libglu_%.bbappend2
-rw-r--r--meta-raspberrypi/recipes-graphics/mesa/mesa-demos_%.bbappend2
-rw-r--r--meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend8
-rw-r--r--meta-raspberrypi/recipes-graphics/mesa/mesa_%.bbappend4
4 files changed, 8 insertions, 8 deletions
diff --git a/meta-raspberrypi/recipes-graphics/mesa/libglu_%.bbappend b/meta-raspberrypi/recipes-graphics/mesa/libglu_%.bbappend
index 56ff4213a..ebfc519f1 100644
--- a/meta-raspberrypi/recipes-graphics/mesa/libglu_%.bbappend
+++ b/meta-raspberrypi/recipes-graphics/mesa/libglu_%.bbappend
@@ -1,3 +1,3 @@
# when using userland graphic KHR/khrplatform.h is provided by userland but virtual/libgl is provided by mesa-gl where
# we explicitly delete KHR/khrplatform.h since its already coming from userland package
-DEPENDS_append_rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'userland', d)}"
+DEPENDS:append:rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'userland', d)}"
diff --git a/meta-raspberrypi/recipes-graphics/mesa/mesa-demos_%.bbappend b/meta-raspberrypi/recipes-graphics/mesa/mesa-demos_%.bbappend
index c187ab9c1..abb11ec8f 100644
--- a/meta-raspberrypi/recipes-graphics/mesa/mesa-demos_%.bbappend
+++ b/meta-raspberrypi/recipes-graphics/mesa/mesa-demos_%.bbappend
@@ -1,2 +1,2 @@
# mesa-demos need libgles1 and userland driver does not have it
-COMPATIBLE_HOST_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '(.*)', 'null', d)}"
+COMPATIBLE_HOST:rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '(.*)', 'null', d)}"
diff --git a/meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend b/meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend
index e561a1b02..edb75f59b 100644
--- a/meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend
+++ b/meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend
@@ -1,8 +1,8 @@
-PACKAGECONFIG_append_rpi = " gbm"
-PROVIDES_append_rpi = " virtual/libgbm"
+PACKAGECONFIG:append:rpi = " gbm"
+PROVIDES:append:rpi = " virtual/libgbm"
-GALLIUMDRIVERS_append_rpi = ",swrast"
+GALLIUMDRIVERS:append:rpi = ",swrast"
-do_install_append_rpi() {
+do_install:append:rpi() {
rm -rf ${D}${includedir}/KHR/khrplatform.h
}
diff --git a/meta-raspberrypi/recipes-graphics/mesa/mesa_%.bbappend b/meta-raspberrypi/recipes-graphics/mesa/mesa_%.bbappend
index eaa46f27b..09c8db7a7 100644
--- a/meta-raspberrypi/recipes-graphics/mesa/mesa_%.bbappend
+++ b/meta-raspberrypi/recipes-graphics/mesa/mesa_%.bbappend
@@ -2,5 +2,5 @@
# With oe-core commit 8509e2e1a87578882b71948ccef3b50ccf1228b3 dri3 is set
# as default. To state out clearly that Raspi needs dri3 and to avoid surprises
# in case oe-core changes this default, we set dri3 explicitly.
-PACKAGECONFIG_append_rpi = " gallium vc4 v3d kmsro ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11 dri3', '', d)}"
-DRIDRIVERS_class-target_rpi = ""
+PACKAGECONFIG:append:rpi = " gallium vc4 v3d kmsro ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11 dri3', '', d)}"
+DRIDRIVERS:class-target:rpi = ""