summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-kernel
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-02-13 00:30:38 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-02-25 23:15:06 +0300
commit1110521700bbfe9ffd32338fed19492114e8bbd4 (patch)
tree221c6e94762edafee7d048ee338048f1b72cbf61 /meta-raspberrypi/recipes-kernel
parentaaf90cd0e100b42993db670cf30b21cfa48be72a (diff)
downloadopenbmc-1110521700bbfe9ffd32338fed19492114e8bbd4.tar.xz
meta-raspberrypi: subtree update:a7cc636d4e..f5fe02c30c
Aaron Shaw (5): overlays: reorder in alphabetical order overlays: add justboom overlays overlays: add overlay to allow 64 bit usage with CM3 overlays: add overlays for pi 400 and cm4 overlays: add missing device overlays Aurelian Zanoschi (2): rpi-config: Add support for CM4 host USB [documentation]Add USB host support in documentation Bartłomiej Burdukiewicz (1): rpi-cmdline: remove unnecessary spaces from cmdline.txt Christopher Clark (1): machine: use weak default for kernel and KERNEL_DEVICETREE settings Jonas Vautherin (1): linux-raspberrypi: Superfluous 'inherit kernel' Martin Jansa (6): rpi-config: fix do_deploy rpi-config: use CONFIG shell variable linux-raspberrypi: add recipe for 5.10 version linux-raspberrypi: update LIC_FILES_CHKSUM in .inc file and drop from 5.10 and dev recipe rpi-default-versions: Switch default kernel to 5.10 raspberrypi-firmware.inc: upgrade to latest for 5.10.13 kernel Matt Spencer (1): linux-raspberrypi: Enable use of 'RPI_EXTRA_CONFIG += ...' in local.conf Ovidiu Panait (1): linux-raspberrypi: pass dtc flags via KERNEL_DTC_FLAGS Paul Barker (5): conf: Use unified u-boot config for 64-bit targets raspberrypi4-64: No need to force arm_64bit=1 linux-raspberrypi: Uprev to v5.4.83 linux-raspberrypi: Uprev yocto-kernel-cache kas-poky-rpi.yml: Make git ignore layers cloned by kas SCVready (1): rpi-config: Relocated "start_x=1" in config.txt Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: Ie1a8cd049694b5f3158b63cedc30c9df24f82120
Diffstat (limited to 'meta-raspberrypi/recipes-kernel')
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb4
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc4
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.10.bb18
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb8
4 files changed, 25 insertions, 9 deletions
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
index 9b2b6f322..ff8ce7993 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
@@ -22,9 +22,7 @@ SRC_URI = " \
require linux-raspberrypi.inc
-LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
-
-KERNEL_EXTRA_ARGS += "DTC_FLAGS='-@ -H epapr'"
+KERNEL_DTC_FLAGS += "-@ -H epapr"
# Disable version check so that we don't have to edit this recipe every time
# upstream bumps the version
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
index db1dbdb85..5ad9b781b 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
@@ -1,14 +1,14 @@
DESCRIPTION = "Linux Kernel for Raspberry Pi"
SECTION = "kernel"
LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
COMPATIBLE_MACHINE = "^rpi$"
PE = "1"
PV = "${LINUX_VERSION}+git${SRCPV}"
-inherit kernel siteinfo
+inherit siteinfo
require recipes-kernel/linux/linux-yocto.inc
SRC_URI += " \
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.10.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.10.bb
new file mode 100644
index 000000000..6af434e07
--- /dev/null
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.10.bb
@@ -0,0 +1,18 @@
+LINUX_VERSION ?= "5.10.13"
+LINUX_RPI_BRANCH ?= "rpi-5.10.y"
+
+SRCREV_machine = "34263dc81a12862c66e2593bb26c09d5fd20f46d"
+SRCREV_meta = "5833ca701711d487c9094bd1efc671e8ef7d001e"
+
+KMETA = "kernel-meta"
+
+SRC_URI = " \
+ git://github.com/raspberrypi/linux.git;name=machine;branch=${LINUX_RPI_BRANCH} \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.10;destsuffix=${KMETA} \
+ file://powersave.cfg \
+ file://android-drivers.cfg \
+ "
+
+require linux-raspberrypi.inc
+
+KERNEL_DTC_FLAGS += "-@ -H epapr"
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
index 1d04c2fa7..ba97ed56e 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
@@ -1,8 +1,8 @@
-LINUX_VERSION ?= "5.4.79"
+LINUX_VERSION ?= "5.4.83"
LINUX_RPI_BRANCH ?= "rpi-5.4.y"
-SRCREV_machine = "9797f1a4938c20139b00a25de93cc99efb5c291b"
-SRCREV_meta = "5d52d9eea95fa09d404053360c2351b2b91b323b"
+SRCREV_machine = "08ae2dd9e7dc89c20bff823a3ef045de09bfd090"
+SRCREV_meta = "d676bf5ff7b7071e14f44498d2482c0a596f14cd"
KMETA = "kernel-meta"
@@ -19,4 +19,4 @@ require linux-raspberrypi.inc
LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
-KERNEL_EXTRA_ARGS += "DTC_FLAGS='-@ -H epapr'"
+KERNEL_DTC_FLAGS += "-@ -H epapr"