summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-kernel
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-09-18 21:33:52 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-09-18 21:33:55 +0300
commit19b4e6c6daefcbe72afe57874d2e48c43c418321 (patch)
treec28547b423cc216d1e511aa900c607a8b326a369 /meta-raspberrypi/recipes-kernel
parent214089240f2991c47237e9381f0078594998e744 (diff)
downloadopenbmc-19b4e6c6daefcbe72afe57874d2e48c43c418321.tar.xz
meta-raspberrypi: subtree update:cc6074c660..0e9c32c816
Andrzej Bednarski (1): docs: Correct minor spelling issues Khem Raj (6): linux-raspberrypi: Update to 5.4.59 raspberrypi-firmware: Upgrade to 20200819 xserver-xorg: Depend on userland when vc4graphics is disabled libsdl2: Add userland dependency when not using vc4graphics linux-raspberrypi_5.4.bb: Build ashmem and binder drivers README: Mention Yoe distro in supported distro list Luis Alfredo da Silva (1): Revert "mesa: querying dma_buf modifiers for specific formats" Martin Jansa (5): linux-raspberrypi-5.4: backport a fix for perf build with -fno-common from gcc-10 rpi-gpio: add -fcommon temporarily linux-raspberrypi-5.4: revert 1 commit from upstream to fix lttng-modules build raspberrypi-{firmware,tools}: set downloadfilename Revert "linux-raspberrypi-5.4: revert 1 commit from upstream to fix lttng-modules build" Pierre-Jean Texier (2): raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 5.4.64 Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I5acc97c6612dd01922b1577537e555220f3b77e6
Diffstat (limited to 'meta-raspberrypi/recipes-kernel')
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/files/0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch68
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/files/android-drivers.cfg8
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb6
3 files changed, 80 insertions, 2 deletions
diff --git a/meta-raspberrypi/recipes-kernel/linux/files/0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch b/meta-raspberrypi/recipes-kernel/linux/files/0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch
new file mode 100644
index 000000000..0d86947ee
--- /dev/null
+++ b/meta-raspberrypi/recipes-kernel/linux/files/0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch
@@ -0,0 +1,68 @@
+From 168200b6d6ea0cb5765943ec5da5b8149701f36a Mon Sep 17 00:00:00 2001
+From: Leo Yan <leo.yan@linaro.org>
+Date: Tue, 5 May 2020 21:36:42 +0800
+Subject: [PATCH] perf cs-etm: Move definition of 'traceid_list' global
+ variable from header file
+
+The variable 'traceid_list' is defined in the header file cs-etm.h,
+if multiple C files include cs-etm.h the compiler might complaint for
+multiple definition of 'traceid_list'.
+
+To fix multiple definition error, move the definition of 'traceid_list'
+into cs-etm.c.
+
+Upstream-Status: Backport [v5.8-rc1]
+
+Fixes: cd8bfd8c973e ("perf tools: Add processing of coresight metadata")
+Reported-by: Thomas Backlund <tmb@mageia.org>
+Signed-off-by: Leo Yan <leo.yan@linaro.org>
+Reviewed-by: Mathieu Poirier <mathieu.poirier@linaro.org>
+Reviewed-by: Mike Leach <mike.leach@linaro.org>
+Tested-by: Mike Leach <mike.leach@linaro.org>
+Tested-by: Thomas Backlund <tmb@mageia.org>
+Cc: Alexander Shishkin <alexander.shishkin@linux.intel.com>
+Cc: Jiri Olsa <jolsa@redhat.com>
+Cc: Mark Rutland <mark.rutland@arm.com>
+Cc: Namhyung Kim <namhyung@kernel.org>
+Cc: Peter Zijlstra <peterz@infradead.org>
+Cc: Suzuki Poulouse <suzuki.poulose@arm.com>
+Cc: Tor Jeremiassen <tor@ti.com>
+Cc: linux-arm-kernel@lists.infradead.org
+Link: http://lore.kernel.org/lkml/20200505133642.4756-1-leo.yan@linaro.org
+Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
+---
+ tools/perf/util/cs-etm.c | 3 +++
+ tools/perf/util/cs-etm.h | 3 ---
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/tools/perf/util/cs-etm.c b/tools/perf/util/cs-etm.c
+index 3c802fde4954..c283223fb31f 100644
+--- a/tools/perf/util/cs-etm.c
++++ b/tools/perf/util/cs-etm.c
+@@ -94,6 +94,9 @@ struct cs_etm_queue {
+ struct cs_etm_traceid_queue **traceid_queues;
+ };
+
++/* RB tree for quick conversion between traceID and metadata pointers */
++static struct intlist *traceid_list;
++
+ static int cs_etm__update_queues(struct cs_etm_auxtrace *etm);
+ static int cs_etm__process_queues(struct cs_etm_auxtrace *etm);
+ static int cs_etm__process_timeless_queues(struct cs_etm_auxtrace *etm,
+diff --git a/tools/perf/util/cs-etm.h b/tools/perf/util/cs-etm.h
+index 650ecc2a6349..4ad925d6d799 100644
+--- a/tools/perf/util/cs-etm.h
++++ b/tools/perf/util/cs-etm.h
+@@ -114,9 +114,6 @@ enum cs_etm_isa {
+ CS_ETM_ISA_T32,
+ };
+
+-/* RB tree for quick conversion between traceID and metadata pointers */
+-struct intlist *traceid_list;
+-
+ struct cs_etm_queue;
+
+ struct cs_etm_packet {
+--
+2.25.1
+
diff --git a/meta-raspberrypi/recipes-kernel/linux/files/android-drivers.cfg b/meta-raspberrypi/recipes-kernel/linux/files/android-drivers.cfg
new file mode 100644
index 000000000..f74ac0e1c
--- /dev/null
+++ b/meta-raspberrypi/recipes-kernel/linux/files/android-drivers.cfg
@@ -0,0 +1,8 @@
+CONFIG_ANDROID=y
+
+#CONFIG_ANDROID_BINDERFS is not set
+CONFIG_ANDROID_BINDER_IPC=y
+CONFIG_ANDROID_BINDER_DEVICES="binder"
+
+CONFIG_ASHMEM=y
+
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
index 7fea9dd55..594694cba 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
@@ -1,11 +1,13 @@
-LINUX_VERSION ?= "5.4.58"
+LINUX_VERSION ?= "5.4.64"
LINUX_RPI_BRANCH ?= "rpi-5.4.y"
-SRCREV = "4592a094787fa6a2ac1e95e96abfe4d7124dbb3a"
+SRCREV = "65caf603f3b1c43f4c92939f7fbb7149e054f486"
require linux-raspberrypi_5.4.inc
SRC_URI += "file://0001-Revert-selftests-bpf-Skip-perf-hw-events-test-if-the.patch \
file://0002-Revert-selftests-bpf-Fix-perf_buffer-test-on-systems.patch \
+ file://0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch \
file://powersave.cfg \
+ file://android-drivers.cfg \
"