summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-multimedia
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-05-15 22:19:14 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-05-21 23:43:47 +0300
commit062316f13d6e9d71a14724e293241b6258c63876 (patch)
treeaaf7deae114e1498f8b9eaabeba5e88b38938f71 /meta-raspberrypi/recipes-multimedia
parent1fe918a07084c878d72cf8a7d1707f6598cc438f (diff)
downloadopenbmc-062316f13d6e9d71a14724e293241b6258c63876.tar.xz
meta-raspberrypi: subtree update:05c86e3160..6f85d3f665
Bartłomiej Burdukiewicz (1): linux-raspberrypi_5.4.bb: Update to latest Drew Moseley (1): raspberrypi3: Switch to vc4-fkms-v3d. Fabio Berton (1): rpi-u-boot-scr: Set u-boot-default-script as provider Khem Raj (20): rpio: Use python3 during build gstreamer1.0-plugins-base: Adjust for meson conversion mesa: Fix patch fuzz linux-raspberrypi: Fix building selftest/bpf oeqa: Add rpi specific kernel dmesg parser linux-raspberrypi: Get PMU fixes on top of 4.19.108 qtbase: Append userland to rdeps iff vc4graphics is not enabled qtbase: Drop xkb packageconfig userland: Update to 20200316 snapshot userland: Fix build with gcc10 rpi-base: Drop old dtbo names linux-raspberrypi: Add recipes for kernel 5.4 linux-raspberrypi_5.4.bb: Update to latest and fix build with binutils 2.34 linux-raspberrypi_5.4.bb: Enable powersave options in kconfig linux-raspberrypi_5.4.bb: Backport the patch to use CHECK macro instead of RET_IF linux-raspberrypi_5.4.bb: Update to latest linux-firmware-rpidistro: Upgrade to 20190114-1+rpt6 psplash: Do not define ALTERNATIVE_PRIORITY for non-existing provider linux-raspberrypi_5.4.bb: Update to latest linux-raspberrypi_5.4.bb: Update to 5.4.35 Leon Anavi (3): docs/extra-build-config.md: Auto-load I2C modules rpi-base.inc: Add kernel modules to all images rpi-base.inc: Include modules if I2C is enaled Madhavan Krishnan (1): gstreamer: Fix the compilation issue in meta multimedia image Martin Jansa (7): userland: add pkg-config for openmaxil and add virtual/libomxil to PROVIDES gstreamer1.0-plugins-base: adapt to gstreamer1.0 now using meson gstreamer1.0-omx: let virtual/libomxil dependency to pull userland omxplayer: respect virtual/libomxil packagegroup-rpi-test: include bigbuckbunny in RRECOMMENDS_${PN} only with meta-multimedia packagegroup-rpi-test: use MACHINE_ARCH linux-raspberrypi: fix perf build with latest binutils Orne Brocaar (1): rpi-base.conf: add disable-bt.dtbo and miniuart-bt.dtbo overlays. Pierre-Jean Texier (17): kas-poky-rpi: add kas file rpi-base.inc: use wic.bz2 for all rpi machines by default linux-raspberrypi: bump to Linux version 4.19.97 raspberrypi-firmware: bump to version 20200205 linux-raspberrypi: bump to Linux version 4.19.102 linux-raspberrypi: bump to Linux version 4.19.105 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.108 raspberrypi-firmware: update to current HEAD layer.conf: add dunfell to compat layer raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.113 README.md: add status badge for raspberrypi4 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.115 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.120 rkhan467 (1): mesa: querying dma_buf modifiers for specific formats Change-Id: I956a7aedff5028fa3af56b101ecaad17b3ff64e0 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-raspberrypi/recipes-multimedia')
-rw-r--r--meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend13
-rw-r--r--meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend3
-rw-r--r--meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend4
-rw-r--r--meta-raspberrypi/recipes-multimedia/omxplayer/omxplayer_git.bb2
4 files changed, 10 insertions, 12 deletions
diff --git a/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend b/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
index f892c66ec..a7aa8d9c3 100644
--- a/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
+++ b/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
@@ -1,9 +1,8 @@
-DEPENDS_append_rpi = " userland"
GSTREAMER_1_0_OMX_TARGET_rpi = "rpi"
GSTREAMER_1_0_OMX_CORE_NAME_rpi = "${libdir}/libopenmaxil.so"
-# How to make this RPI specific?
-EXTRA_OECONF_append_rpi = " CFLAGS="$CFLAGS -I${STAGING_DIR_TARGET}/usr/include/IL -I${STAGING_DIR_TARGET}/usr/include/interface/vcos/pthreads -I${STAGING_DIR_TARGET}/usr/include/interface/vmcs_host/linux""
-#examples only build with GL but not GLES, so disable it for RPI
-EXTRA_OECONF_append_rpi = " --disable-examples"
-
-RDEPENDS_${PN}_append_rpi = " userland"
+EXTRA_OEMESON_append_rpi = " -Dheader_path=${STAGING_DIR_TARGET}/usr/include"
+CFLAGS_append_rpi = " \
+ -I${STAGING_DIR_TARGET}/usr/include/IL \
+ -I${STAGING_DIR_TARGET}/usr/include/interface/vcos/pthreads \
+ -I${STAGING_DIR_TARGET}/usr/include/interface/vmcs_host/linux \
+"
diff --git a/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
index 899a2d400..8ab1510d8 100644
--- a/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
+++ b/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -1 +1,2 @@
-PACKAGECONFIG_append_rpi = " hls libmms faad"
+PACKAGECONFIG_append_rpi = " hls libmms \
+ ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'faad', '', d)}"
diff --git a/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend b/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
index 29fcb0e03..bfbce49f1 100644
--- a/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
+++ b/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
@@ -2,10 +2,8 @@ EXTRA_OECONF_append_rpi = " CPPFLAGS='-I${STAGING_INCDIR}/interface/vcos/pthread
-I${STAGING_INCDIR}/interface/vmcs_host/linux'"
# if using bcm driver enable dispmanx not when using VC4 driver
-
PACKAGECONFIG_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' dispmanx', d)}"
+DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
PACKAGECONFIG_GL_VC4GRAPHICS = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
PACKAGECONFIG_GL_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '${PACKAGECONFIG_GL_VC4GRAPHICS}', 'egl gles2', d)}"
-
-PACKAGECONFIG[dispmanx] = "--enable-dispmanx,--disable-dispmanx,userland"
diff --git a/meta-raspberrypi/recipes-multimedia/omxplayer/omxplayer_git.bb b/meta-raspberrypi/recipes-multimedia/omxplayer/omxplayer_git.bb
index 3cc03213d..55e5a1c8c 100644
--- a/meta-raspberrypi/recipes-multimedia/omxplayer/omxplayer_git.bb
+++ b/meta-raspberrypi/recipes-multimedia/omxplayer/omxplayer_git.bb
@@ -7,7 +7,7 @@ SECTION = "console/utils"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=00a27da7ac0f9bcd17320ec29ef4bbf6"
-DEPENDS = "libpcre libav virtual/egl boost freetype dbus openssl libssh libomxil coreutils-native curl-native userland"
+DEPENDS = "libpcre libav virtual/egl boost freetype dbus openssl libssh virtual/libomxil coreutils-native curl-native userland"
PR = "r5"