summaryrefslogtreecommitdiff
path: root/meta-raspberrypi
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-10-16 18:13:56 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-10-16 18:13:58 +0300
commit5c4154ffa5fc7b63c57a909685a06a90a5b9c82c (patch)
tree158744d30b9970af4a50ecd384e511a8af77fb1c /meta-raspberrypi
parenta9ff2b33c004367b3dbded5d54d7a272ed76f68f (diff)
downloadopenbmc-5c4154ffa5fc7b63c57a909685a06a90a5b9c82c.tar.xz
meta-raspberrypi: subtree update:0e9c32c816..6f85611576
Alex Gonzalez (1): linux-raspberrypi: Only deploy cmdline.txt for the main kernel Khem Raj (7): linux-firmware-rpidistro: Update to 20190114-1+rpt8 linux-raspberrypi_5.4.bb: Update to 5.4.69 raspberrypi-firmware: Update to 20201002 snapshot raspberrypi-tools: Update to latest snapshot as of 20200803 oeqa: Add 5.4 specific error messages to ignore list rpi-default-settings: Replace default parselogs with parselogs_rpi layer.conf: Add gatesgarth to LAYERSERIES_COMPAT Madhavan Krishnan (1): libcamera: Define packageconfig to enable rpi pipeline Martin Jansa (2): linux-raspberrypi-5.4: bump SRCREV to fix raspberrypi3-64 builds python3-rtimu: don't use trailing slash in S Murat Kilivan (1): linux-raspberrypi_5.4.bb: Add kernel-cache source Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I906081b851f3733a52c1899fe2b4e835021f6419
Diffstat (limited to 'meta-raspberrypi')
-rw-r--r--meta-raspberrypi/conf/layer.conf4
-rw-r--r--meta-raspberrypi/conf/machine/include/rpi-default-settings.inc6
-rw-r--r--meta-raspberrypi/dynamic-layers/multimedia-layer/recipes-multimedia/libcamera/libcamera.bbappend2
-rw-r--r--meta-raspberrypi/lib/oeqa/runtime/cases/parselogs_rpi.py3
-rw-r--r--meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc6
-rw-r--r--meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc8
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb2
-rw-r--r--meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb9
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc14
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb5
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc5
11 files changed, 44 insertions, 20 deletions
diff --git a/meta-raspberrypi/conf/layer.conf b/meta-raspberrypi/conf/layer.conf
index 4ed79591f..98cd6f460 100644
--- a/meta-raspberrypi/conf/layer.conf
+++ b/meta-raspberrypi/conf/layer.conf
@@ -9,7 +9,7 @@ BBFILE_COLLECTIONS += "raspberrypi"
BBFILE_PATTERN_raspberrypi := "^${LAYERDIR}/"
BBFILE_PRIORITY_raspberrypi = "9"
-LAYERSERIES_COMPAT_raspberrypi = "sumo thud warrior zeus dunfell"
+LAYERSERIES_COMPAT_raspberrypi = "sumo thud warrior zeus dunfell gatesgarth"
# Additional license directories.
LICENSE_PATH += "${LAYERDIR}/files/custom-licenses"
@@ -31,6 +31,8 @@ BBFILES_DYNAMIC += " \
networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bbappend \
qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bb \
qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bbappend \
+ multimedia-layer:${LAYERDIR}/dynamic-layers/multimedia-layer/*/*/*.bb \
+ multimedia-layer:${LAYERDIR}/dynamic-layers/multimedia-layer/*/*/*.bbappend \
"
DEFAULT_TEST_SUITES_remove_rpi = "parselogs"
diff --git a/meta-raspberrypi/conf/machine/include/rpi-default-settings.inc b/meta-raspberrypi/conf/machine/include/rpi-default-settings.inc
index 716a8bbb7..bb18496c9 100644
--- a/meta-raspberrypi/conf/machine/include/rpi-default-settings.inc
+++ b/meta-raspberrypi/conf/machine/include/rpi-default-settings.inc
@@ -1,3 +1,9 @@
# RaspberryPi BSP default settings
IMAGE_CLASSES += "sdcard_image-rpi"
+
+# RPI kernel has errors of its own which should be filtered
+# therefore use parselogs_rpi test instead of parselogs from oe-core
+#
+DEFAULT_TEST_SUITES_append_rpi = " parselogs_rpi"
+DEFAULT_TEST_SUITES_remove_rpi = " parselogs"
diff --git a/meta-raspberrypi/dynamic-layers/multimedia-layer/recipes-multimedia/libcamera/libcamera.bbappend b/meta-raspberrypi/dynamic-layers/multimedia-layer/recipes-multimedia/libcamera/libcamera.bbappend
new file mode 100644
index 000000000..8076ac79e
--- /dev/null
+++ b/meta-raspberrypi/dynamic-layers/multimedia-layer/recipes-multimedia/libcamera/libcamera.bbappend
@@ -0,0 +1,2 @@
+PACKAGECONFIG[raspberrypi] = "-Dpipelines=raspberrypi"
+PACKAGECONFIG_append_rpi = " raspberrypi"
diff --git a/meta-raspberrypi/lib/oeqa/runtime/cases/parselogs_rpi.py b/meta-raspberrypi/lib/oeqa/runtime/cases/parselogs_rpi.py
index 5cf9af17c..4a9431034 100644
--- a/meta-raspberrypi/lib/oeqa/runtime/cases/parselogs_rpi.py
+++ b/meta-raspberrypi/lib/oeqa/runtime/cases/parselogs_rpi.py
@@ -4,6 +4,9 @@ rpi_errors = [
'bcmgenet fd580000.genet: failed to get enet-eee clock',
'bcmgenet fd580000.genet: failed to get enet-wol clock',
'bcmgenet fd580000.genet: failed to get enet clock',
+ 'bcmgenet fd580000.ethernet: failed to get enet-eee clock',
+ 'bcmgenet fd580000.ethernet: failed to get enet-wol clock',
+ 'bcmgenet fd580000.ethernet: failed to get enet clock',
]
ignore_errors['raspberrypi4'] = rpi_errors + common_errors
diff --git a/meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc b/meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc
index 3b54d1898..32cc4807d 100644
--- a/meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc
+++ b/meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc
@@ -1,9 +1,9 @@
-RPIFW_DATE ?= "20200911"
-SRCREV ?= "a490197f0672d948860b2b807884ae65eabc4d4f"
+RPIFW_DATE ?= "20201002"
+SRCREV ?= "11e3c314bc2b64f7d862bac00ff3d9f42f3c5a50"
RPIFW_SRC_URI ?= "https://github.com/raspberrypi/firmware/archive/${SRCREV}.tar.gz;downloadfilename=raspberrypi-firmware-${SRCREV}.tar.gz"
RPIFW_S ?= "${WORKDIR}/firmware-${SRCREV}"
SRC_URI = "${RPIFW_SRC_URI}"
-SRC_URI[sha256sum] = "be06015688f415fa1b87850d51a4188a766f2a618001f70e7c69b07cbdf9d6ab"
+SRC_URI[sha256sum] = "b8c9f5a3e987f418f11526cbf59f6a6c8103e8f5e94bccffb9ef3fd7ae834f98"
PV = "${RPIFW_DATE}"
diff --git a/meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc b/meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc
index 1588264ac..93f9d7ac9 100644
--- a/meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc
+++ b/meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc
@@ -1,9 +1,9 @@
-SRCREV ?= "b0c869bc929587a7e1d20a98e2dc828a24ca396a"
+RPITOOLS_DATE ?= "20200803"
+SRCREV ?= "0c39cb5b5ac9851312a38c54f5aea770d976de7a"
RPITOOLS_SRC_URI ?= "https://github.com/raspberrypi/tools/archive/${SRCREV}.tar.gz;downloadfilename=raspberrypi-tools-${SRCREV}.tar.gz"
RPITOOLS_S ?= "${WORKDIR}/tools-${SRCREV}"
SRC_URI = "${RPITOOLS_SRC_URI}"
-SRC_URI[md5sum] = "fd999aad4424088b5e8746a9d946bb56"
-SRC_URI[sha256sum] = "a0a8aff308d9302318442e6bcd2df14cbbb3b633f12ca6b9c43c4ab69bf45bb1"
+SRC_URI[sha256sum] = "ef56a891eef387d2278e6f9d20b462021faace14aceeb2048b5e5973069c25c0"
-PV = "0.0+git${SRCREV}"
+PV = "${RPITOOLS_DATE}"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb b/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
index c0cb31100..4f13a38bb 100644
--- a/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
@@ -10,6 +10,6 @@ SRC_URI = "git://github.com/RPi-Distro/RTIMULib.git;protocol=http;branch=master
"
SRCREV = "b949681af69b45f0f7f4bb53b6770037b5b02178"
-S = "${WORKDIR}/git/Linux/python/"
+S = "${WORKDIR}/git/Linux/python"
inherit setuptools3
diff --git a/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb b/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
index 833f8f68a..99afde848 100644
--- a/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
+++ b/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
@@ -35,8 +35,8 @@ NO_GENERIC_LICENSE[WHENCE] = "WHENCE"
SRC_URI = "git://github.com/RPi-Distro/firmware-nonfree"
-SRCREV = "616fc2dd4df421e3974179d9e46d45e7006aeb28"
-PV = "20190114-1+rpt6"
+SRCREV = "98e815735e2c805d65994ccc608f399595b74438"
+PV = "20190114-1+rpt8"
S = "${WORKDIR}/git"
@@ -59,6 +59,11 @@ do_install() {
for fw in brcmfmac43430-sdio brcmfmac43455-sdio ; do
install -m 0644 brcm/${fw}.* ${D}${nonarch_base_libdir}/firmware/brcm/
done
+ # add compat links. Fixes errors like
+ # brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt failed with error -2
+ ln -s brcmfmac43455-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt
+ ln -s brcmfmac43455-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt
+ ln -s brcmfmac43430-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43430-sdio.raspberrypi,3-model-b.txt
}
PACKAGES = "\
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
index f7dee7700..3219a231f 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
@@ -130,11 +130,13 @@ do_compile_append() {
}
do_deploy_append() {
- # Deploy cmdline.txt
- install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}
- PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
- if [ ${PITFT} = "1" ]; then
- PITFT_PARAMS="fbcon=map:10 fbcon=font:VGA8x8"
+ # Deploy cmdline.txt only for the main kernel package
+ if [ ${KERNEL_PACKAGE_NAME} = "kernel" ]; then
+ install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}
+ PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
+ if [ ${PITFT} = "1" ]; then
+ PITFT_PARAMS="fbcon=map:10 fbcon=font:VGA8x8"
+ fi
+ echo "${CMDLINE}${PITFT_PARAMS}" > ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/cmdline.txt
fi
- echo "${CMDLINE}${PITFT_PARAMS}" > ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/cmdline.txt
}
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
index 594694cba..e057c3a74 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
@@ -1,7 +1,8 @@
-LINUX_VERSION ?= "5.4.64"
+LINUX_VERSION ?= "5.4.69"
LINUX_RPI_BRANCH ?= "rpi-5.4.y"
-SRCREV = "65caf603f3b1c43f4c92939f7fbb7149e054f486"
+SRCREV_machine = "31d364af258ff9754a1a9c7d8ea532da962797bd"
+SRCREV_meta = "5d52d9eea95fa09d404053360c2351b2b91b323b"
require linux-raspberrypi_5.4.inc
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc
index 232f8a97d..9e8934a70 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc
@@ -1,7 +1,10 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:"
+KMETA = "kernel-meta"
+
SRC_URI = " \
- git://github.com/raspberrypi/linux.git;branch=${LINUX_RPI_BRANCH} \
+ git://github.com/raspberrypi/linux.git;name=machine;branch=${LINUX_RPI_BRANCH} \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.4;destsuffix=${KMETA} \
"
SRC_URI_remove = "file://rpi-kernel-misc.cfg"