summaryrefslogtreecommitdiff
path: root/meta-raspberrypi
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-06 17:44:45 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-06 17:44:46 +0300
commit870eb53cd2dd418fcd6e26356392b6366e51cae5 (patch)
tree715b0c8ffada95025ba25b8fd386d4ebab35b0b3 /meta-raspberrypi
parente378b1990eb7d1e122b9119bfa006bfc8c52fda3 (diff)
downloadopenbmc-870eb53cd2dd418fcd6e26356392b6366e51cae5.tar.xz
meta-raspberrypi: subtree update:3ae288aa38..a953fc0f9b
Andrei Gherzan (2): raspberrypi-firmware: Update to current HEAD linux-raspberrypi: Bump to 4.19 recipe to 4.19.88 Leon Anavi (1): pi-bluetooth: Runtime depends on udev-rules-rpi Michael Baisch (1): linux-raspberrypi.inc: no longer set CONFIG_LOCALVERSION to empty string Pierre-Jean Texier (3): linux-raspberrypi-rt: bump to revision e2e9cec rpi-gpio: bump to version 0.7.0 raspi-gpio: bump to revision 4edfde1 Change-Id: Ibd557330128fe2b6afbefd2234e411b45f265aeb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-raspberrypi')
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb2
-rw-r--r--meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc8
-rw-r--r--meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.12.bb4
-rw-r--r--meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch33
-rw-r--r--meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb (renamed from meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.6.3.bb)8
-rw-r--r--meta-raspberrypi/recipes-devtools/raspi-gpio/raspi-gpio_git.bb2
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-rt_4.19.bb2
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc5
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.19.bb4
9 files changed, 21 insertions, 47 deletions
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb b/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
index 848a29af7..d20312c14 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Closed source binary files to help boot the ARM on the BCM2835."
LICENSE = "Broadcom-RPi"
-LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=4a4d169737c0786fb9482bb6d30401d1"
+LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=c403841ff2837657b2ed8e5bb474ac8d"
inherit deploy nopackages
diff --git a/meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc b/meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc
index a535cce98..869ea3a5c 100644
--- a/meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc
+++ b/meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc
@@ -1,10 +1,10 @@
-RPIFW_DATE ?= "20191107"
-SRCREV ?= "d737daa826adaab8679f83018c3cdc8783d49b59"
+RPIFW_DATE ?= "20191210"
+SRCREV ?= "9d6be5b07e81bdfb9c4b9a560e90fbc7477fdc6e"
RPIFW_SRC_URI ?= "https://github.com/raspberrypi/firmware/archive/${SRCREV}.tar.gz"
RPIFW_S ?= "${WORKDIR}/firmware-${SRCREV}"
SRC_URI = "${RPIFW_SRC_URI}"
-SRC_URI[md5sum] = "002b6544826ce8f0d1176dd2e958022c"
-SRC_URI[sha256sum] = "48817e60ca15098ff46d7942914fcbdc44e74c97aa3d58889e59a90901b8fc1a"
+SRC_URI[md5sum] = "645e812765c8b4ca05d6cb47a1f67ab0"
+SRC_URI[sha256sum] = "484d52caed909fcafbf593cc3e726ea44a9218db7f0aeec843b825797eb9b0fc"
PV = "${RPIFW_DATE}"
diff --git a/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.12.bb b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.12.bb
index e16ed17b1..2597e4bae 100644
--- a/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.12.bb
+++ b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.12.bb
@@ -43,3 +43,7 @@ FILES_${PN} = "\
${sysconfdir} \
${systemd_unitdir}/system \
"
+
+RDEPENDS_${PN} += " \
+ udev-rules-rpi \
+"
diff --git a/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch b/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch
index bd971793a..5c94bc24f 100644
--- a/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch
+++ b/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-Remove-nested-functions.patch
@@ -30,6 +30,8 @@ silence this warning
uint32_t peri_base;
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+[Pierre-Jean: update for version 0.7.0]
+Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
---
Upstream-Status: Submitted
@@ -37,37 +39,6 @@ Upstream-Status: Submitted
source/py_gpio.c | 135 ++++++++++++++++++++++++++++---------------------------
2 files changed, 71 insertions(+), 70 deletions(-)
-diff --git a/source/c_gpio.c b/source/c_gpio.c
-index c96a2b0..b69880f 100644
---- a/source/c_gpio.c
-+++ b/source/c_gpio.c
-@@ -61,7 +61,7 @@ int setup(void)
- {
- int mem_fd;
- uint8_t *gpio_mem;
-- uint32_t peri_base;
-+ uint32_t peri_base = 0;
- uint32_t gpio_base;
- unsigned char buf[4];
- FILE *fp;
-@@ -73,7 +73,7 @@ int setup(void)
- if ((mem_fd = open("/dev/gpiomem", O_RDWR|O_SYNC)) > 0)
- {
- gpio_map = (uint32_t *)mmap(NULL, BLOCK_SIZE, PROT_READ|PROT_WRITE, MAP_SHARED, mem_fd, 0);
-- if ((uint32_t)gpio_map < 0) {
-+ if (gpio_map == MAP_FAILED) {
- return SETUP_MMAP_FAIL;
- } else {
- return SETUP_OK;
-@@ -127,7 +127,7 @@ int setup(void)
-
- gpio_map = (uint32_t *)mmap( (void *)gpio_mem, BLOCK_SIZE, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_FIXED, mem_fd, gpio_base);
-
-- if ((uint32_t)gpio_map < 0)
-+ if (gpio_map == MAP_FAILED)
- return SETUP_MMAP_FAIL;
-
- return SETUP_OK;
diff --git a/source/py_gpio.c b/source/py_gpio.c
index d54cc7f..007bad5 100644
--- a/source/py_gpio.c
diff --git a/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.6.3.bb b/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
index d0ff00af7..fcce88f83 100644
--- a/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.6.3.bb
+++ b/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
@@ -1,14 +1,14 @@
DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
-HOMEPAGE = "http://code.google.com/p/raspberry-gpio-python/"
+HOMEPAGE = "https://sourceforge.net/projects/raspberry-gpio-python/"
SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=9b95630a648966b142f1a0dcea001cb7"
PYPI_PACKAGE = "RPi.GPIO"
-inherit pypi distutils
+inherit pypi distutils3
SRC_URI += "file://0001-Remove-nested-functions.patch"
-SRC_URI[md5sum] = "e4abe1cfb5eacebe53078032256eb837"
-SRC_URI[sha256sum] = "a5fc0eb5e401963b6c0a03650da6b42c4005f02d962b81241d96c98d0a578516"
+SRC_URI[md5sum] = "777617f9dea9a1680f9af43db0cf150e"
+SRC_URI[sha256sum] = "7424bc6c205466764f30f666c18187a0824077daf20b295c42f08aea2cb87d3f"
COMPATIBLE_MACHINE = "^rpi$"
diff --git a/meta-raspberrypi/recipes-devtools/raspi-gpio/raspi-gpio_git.bb b/meta-raspberrypi/recipes-devtools/raspi-gpio/raspi-gpio_git.bb
index c2d7f59fb..02a3f5585 100644
--- a/meta-raspberrypi/recipes-devtools/raspi-gpio/raspi-gpio_git.bb
+++ b/meta-raspberrypi/recipes-devtools/raspi-gpio/raspi-gpio_git.bb
@@ -8,7 +8,7 @@ COMPATIBLE_MACHINE = "^rpi$"
inherit autotools
-SRCREV = "2eaa8b8755a550e34d07c898b90b0d9b3d66fd81"
+SRCREV = "4edfde183ff3ac9ed66cdc015ae25e45f3a5502d"
SRC_URI = "git://github.com/RPi-Distro/raspi-gpio.git;protocol=https;branch=master \
"
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-rt_4.19.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-rt_4.19.bb
index 7a9f083af..2d9363f5f 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-rt_4.19.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-rt_4.19.bb
@@ -1,6 +1,6 @@
LINUX_VERSION ?= "4.19.71"
LINUX_RPI_BRANCH ?= "rpi-4.19.y-rt"
-SRCREV = "1532ea50263c8fd70f769b55e60fbc6a0c5778a0"
+SRCREV = "e2e9cec6fb061ba58304fd391ef76747f2963557"
require linux-raspberrypi_4.19.inc
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
index ea7f77837..f6e577484 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
@@ -22,6 +22,8 @@ KBUILD_DEFCONFIG_raspberrypi3-64 ?= "bcmrpi3_defconfig"
KBUILD_DEFCONFIG_raspberrypi4 ?= "bcm2711_defconfig"
KBUILD_DEFCONFIG_raspberrypi4-64 ?= "bcm2711_defconfig"
+LINUX_VERSION_EXTENSION ?= ""
+
# CMDLINE for raspberrypi
SERIAL = "${@oe.utils.conditional("ENABLE_UART", "1", "console=serial0,115200", "", d)}"
CMDLINE ?= "dwc_otg.lpm_enable=0 ${SERIAL} root=/dev/mmcblk0p2 rootfstype=ext4 rootwait"
@@ -98,9 +100,6 @@ do_configure_prepend() {
mv -f ${B}/.config ${B}/.config.patched
CONF_SED_SCRIPT=""
- # Localversion
- kernel_configure_variable LOCALVERSION "\"\""
-
if [ "${INITRAMFS_IMAGE_BUNDLE}" = "1" ]; then
kernel_configure_variable OVERLAY_FS y
kernel_configure_variable SQUASHFS y
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.19.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.19.bb
index 45a122d1f..b891a4277 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.19.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.19.bb
@@ -1,6 +1,6 @@
-LINUX_VERSION ?= "4.19.81"
+LINUX_VERSION ?= "4.19.88"
LINUX_RPI_BRANCH ?= "rpi-4.19.y"
-SRCREV = "eef78b714c3fbc635642332a2ce7d66e51f514d9"
+SRCREV = "988cc7beacc150756c3fbe40646afcf8438b741b"
require linux-raspberrypi_4.19.inc