summaryrefslogtreecommitdiff
path: root/meta-raspberrypi
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-07-10 23:52:35 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-10 23:52:40 +0300
commita16b0ff11065083684154184934b636fa364525d (patch)
tree2b5d620cbad6e6b799ca3f551c73a41c62b3cb52 /meta-raspberrypi
parentc1ae9a2bbd217d462d3ca4b1f815c2d7faac2a27 (diff)
downloadopenbmc-a16b0ff11065083684154184934b636fa364525d.tar.xz
meta-raspberrypi: subtree update:a6f1233d52..0d398a3b71
Christopher Clark (1): linux-raspberrypi: bump to 5.4.50 since upstream was force-pushed Leon Anavi (2): rpi-u-boot-scr: Create uboot.env via boot.cmd.in libubootenv_%.bbappend: Add fw_env.config Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I8994cad6a13e2ae6f74c7a0a34061a9c4700a124
Diffstat (limited to 'meta-raspberrypi')
-rw-r--r--meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.in1
-rw-r--r--meta-raspberrypi/recipes-bsp/u-boot/files/fw_env.config1
-rw-r--r--meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend12
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb4
4 files changed, 16 insertions, 2 deletions
diff --git a/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.in b/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.in
index ad54cd067..627d18156 100644
--- a/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.in
+++ b/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.in
@@ -1,3 +1,4 @@
fdt addr ${fdt_addr} && fdt get value bootargs /chosen bootargs
fatload mmc 0:1 ${kernel_addr_r} @@KERNEL_IMAGETYPE@@
+if test ! -e mmc 0:1 uboot.env; then saveenv; fi;
@@KERNEL_BOOTCMD@@ ${kernel_addr_r} - ${fdt_addr}
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/files/fw_env.config b/meta-raspberrypi/recipes-bsp/u-boot/files/fw_env.config
new file mode 100644
index 000000000..d00df0cb3
--- /dev/null
+++ b/meta-raspberrypi/recipes-bsp/u-boot/files/fw_env.config
@@ -0,0 +1 @@
+/boot/uboot.env 0x0000 0x4000
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend b/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
new file mode 100644
index 000000000..22d1bdc4a
--- /dev/null
+++ b/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append_rpi = " \
+ file://fw_env.config \
+"
+
+DEPENDS_append_rpi = " rpi-u-boot-scr"
+
+do_install_append_rpi () {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
index aaf228e0a..153f14e04 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
@@ -1,7 +1,7 @@
-LINUX_VERSION ?= "5.4.47"
+LINUX_VERSION ?= "5.4.50"
LINUX_RPI_BRANCH ?= "rpi-5.4.y"
-SRCREV = "dec0ddc506ab5d93a7de4b8a7c8dc98e0a96f85c"
+SRCREV = "856e83151cf3f802c495585ac176bb135a08030f"
require linux-raspberrypi_5.4.inc