summaryrefslogtreecommitdiff
path: root/meta-security/meta-tpm/recipes-tpm/swtpm/swtpm_0.2.0.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-13 13:30:46 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-13 13:30:47 +0300
commita3b01f438c5e34f66db9e93e1701ad07cfa079d0 (patch)
tree82a8befea53ace78e2418f6e13b0b1dc3e9c6661 /meta-security/meta-tpm/recipes-tpm/swtpm/swtpm_0.2.0.bb
parenta891d150c6a7455ddbb797bdc472f45fd5f36008 (diff)
downloadopenbmc-a3b01f438c5e34f66db9e93e1701ad07cfa079d0.tar.xz
meta-security: subtree update:d75dc96fa3..76d3625bcf
Armin Kuster (8): libtpm: update to 0.7.0 swtpm: update to 0.2.0 tpm2-abrmd: update to 2.2.0 tpm2-tss: update to 2.3.0 tpm2-tss-engine: update to 1.0.1 tpm2-totp: update to 0.1.2 tpm2-tcti-uefi: update to tip tpm2-pkcs11: update to tip Change-Id: If24aa89766a3c49d34bca6f104d9310d05d72181 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-security/meta-tpm/recipes-tpm/swtpm/swtpm_0.2.0.bb')
-rw-r--r--meta-security/meta-tpm/recipes-tpm/swtpm/swtpm_0.2.0.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-security/meta-tpm/recipes-tpm/swtpm/swtpm_0.2.0.bb b/meta-security/meta-tpm/recipes-tpm/swtpm/swtpm_0.2.0.bb
new file mode 100644
index 000000000..f3a53dd9b
--- /dev/null
+++ b/meta-security/meta-tpm/recipes-tpm/swtpm/swtpm_0.2.0.bb
@@ -0,0 +1,51 @@
+SUMMARY = "SWTPM - Software TPM Emulator"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fe8092c832b71ef20dfe4c6d3decb3a8"
+SECTION = "apps"
+
+DEPENDS = "libtasn1 expect socat glib-2.0 net-tools-native libtpm libtpm-native"
+
+# configure checks for the tools already during compilation and
+# then swtpm_setup needs them at runtime
+DEPENDS += "tpm-tools-native expect-native socat-native"
+
+SRCREV = "39673a0139b0ee14a0109aba50a0635592c672c4"
+SRC_URI = "git://github.com/stefanberger/swtpm.git;branch=stable-${PV} \
+ file://fix_fcntl_h.patch \
+ file://ioctl_h.patch \
+ "
+PE = "1"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+PARALLEL_MAKE = ""
+
+TSS_USER="tss"
+TSS_GROUP="tss"
+
+PACKAGECONFIG ?= "openssl"
+PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
+PACKAGECONFIG += "${@bb.utils.contains('BBFILE_COLLECTIONS', 'filesystems-layer', 'cuse', '', d)}"
+PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl"
+PACKAGECONFIG[gnutls] = "--with-gnutls, --without-gnutls, gnutls"
+PACKAGECONFIG[selinux] = "--with-selinux, --without-selinux, libselinux"
+PACKAGECONFIG[cuse] = "--with-cuse, --without-cuse, fuse"
+
+EXTRA_OECONF += "--with-tss-user=${TSS_USER} --with-tss-group=${TSS_GROUP}"
+
+export SEARCH_DIR = "${STAGING_LIBDIR_NATIVE}"
+
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN} = "--system ${TSS_USER}"
+USERADD_PARAM_${PN} = "--system -g ${TSS_GROUP} --home-dir \
+ --no-create-home --shell /bin/false ${BPN}"
+
+PACKAGE_BEFORE_PN = "${PN}-cuse"
+FILES_${PN}-cuse = "${bindir}/swtpm_cuse"
+
+INSANE_SKIP_${PN} += "dev-so"
+
+RDEPENDS_${PN} = "libtpm expect socat bash tpm-tools"
+
+BBCLASSEXTEND = "native nativesdk"