summaryrefslogtreecommitdiff
path: root/meta-supermicro/meta-x11spi/recipes-phosphor
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@intel.com>2022-01-06 23:59:39 +0300
committerJason M. Bills <jason.m.bills@intel.com>2022-01-06 23:59:39 +0300
commit32777eec25d2c527a62e5ffab90a3dfef35855aa (patch)
tree588a90a6fe9fb0b35c7ce23ea3bd79fa5151ccde /meta-supermicro/meta-x11spi/recipes-phosphor
parent61f1ca1b31a9a1108e9e7f71e47fdc19beb0490b (diff)
parent5cc2f81c5b66da00cad24e18b0d23442af060c3f (diff)
downloadopenbmc-32777eec25d2c527a62e5ffab90a3dfef35855aa.tar.xz
Merge tag '0.86' of firmware.bmc.openbmc.yocto.openbmc into update
Diffstat (limited to 'meta-supermicro/meta-x11spi/recipes-phosphor')
-rw-r--r--meta-supermicro/meta-x11spi/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json42
-rw-r--r--meta-supermicro/meta-x11spi/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend1
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-supermicro/meta-x11spi/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-supermicro/meta-x11spi/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
new file mode 100644
index 000000000..de7352bcf
--- /dev/null
+++ b/meta-supermicro/meta-x11spi/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -0,0 +1,42 @@
+{
+ "gpio_configs": {
+
+ "power_config": {
+ "power_good_in": "PGOOD",
+ "power_up_outs": [
+ {"name": "POWER_UP_PIN", "polarity": true}
+ ],
+ "reset_outs": [
+ {"name": "RESET_OUT", "polarity": false}
+ ]
+ }
+ },
+
+ "gpio_definitions": [
+ {
+ "name": "PGOOD",
+ "pin": "AA0",
+ "direction": "in"
+ },
+ {
+ "name": "POWER_BUTTON",
+ "pin": "AA1",
+ "direction": "both"
+ },
+ {
+ "name": "POWER_UP_PIN",
+ "pin": "E2",
+ "direction": "out"
+ },
+ {
+ "name": "RESET_OUT",
+ "pin": "E3",
+ "direction": "out"
+ },
+ {
+ "name": "ID_BUTTON",
+ "pin": "AA5",
+ "direction": "both"
+ }
+ ]
+}
diff --git a/meta-supermicro/meta-x11spi/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend b/meta-supermicro/meta-x11spi/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
new file mode 100644
index 000000000..18a631470
--- /dev/null
+++ b/meta-supermicro/meta-x11spi/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS:prepend:x11spi := "${THISDIR}/${PN}:"