summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-xilinx-bsp/classes/kernel-simpleimage.bbclass
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-20 16:16:20 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-20 16:16:25 +0300
commit754b8faf0be432fcdcacb340fe95117cac890e40 (patch)
tree18b232b2b4835f94564d81d48c8f2578198480e4 /meta-xilinx/meta-xilinx-bsp/classes/kernel-simpleimage.bbclass
parent90ca747aa04f375af7ff86462a52028245b174b9 (diff)
downloadopenbmc-754b8faf0be432fcdcacb340fe95117cac890e40.tar.xz
subtree updates
meta-raspberrypi: b112816e95..2634621374: Vincenzo Pacella (1): linux-raspberrypi: add linux-raspberrypi-rt 4.19 meta-xilinx: f3c8b1c9a8..68eacd5636: Alejandro Enedino Hernandez Samaniego (4): machine-xilinx-default.inc: Disable PIE (ASLR) for Microblaze meta-xilinx-bsp: Update layer compatibility to warrior release meta-xilinx-contrib: Update layer compatibility to warrior release meta-xilinx-standalone: Update layer compatibility to warrior release Jaewon Lee (2): microblaze-kc705-Convert-microblaze-generic-to-k.patch:update patch Update recipes for Xilinx v2019.1 release Manjukumar Matha (7): microblaze: Update to v11.0 u-boot-xlnx.inc: Add bison-native dependency for 2019.01 u-boot-zynq-scr.bb: Recipe to create u-boot.scr for Xilinx devices microblazeel*.conf: Add microblaze generic machines -generic.conf: Add generic machines for Zynq and ZU+ layer.conf: Add warning for dangling bbappends conf/machine/*-zynq7.conf: Fix UBOOT_ELF for upstream u-boot version Michael Monaghan (1): kernel-simpleimage.bbclass: Fix do_prep_simpleimage `[[: not found` Swagath Gadde (1): zcu1285-zynqmp.conf: Add support for zcu1285 board Change-Id: I0e3c5e57b0316f438d3f1fd80bd047dcbbac384e Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-xilinx/meta-xilinx-bsp/classes/kernel-simpleimage.bbclass')
-rw-r--r--meta-xilinx/meta-xilinx-bsp/classes/kernel-simpleimage.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-xilinx/meta-xilinx-bsp/classes/kernel-simpleimage.bbclass b/meta-xilinx/meta-xilinx-bsp/classes/kernel-simpleimage.bbclass
index 348d0a733..6da28f36f 100644
--- a/meta-xilinx/meta-xilinx-bsp/classes/kernel-simpleimage.bbclass
+++ b/meta-xilinx/meta-xilinx-bsp/classes/kernel-simpleimage.bbclass
@@ -13,7 +13,7 @@ do_prep_simpleimage[dirs] += "${B}"
do_prep_simpleimage () {
install -d ${B}/arch/${ARCH}/boot/dts
for type in ${KERNEL_IMAGETYPES} ; do
- if [[ "${type}" =~ "simpleImage" ]] && [ ${ARCH} = "microblaze" ]; then
+ if [ -z "${type##*simpleImage*}" ] && [ ${ARCH} = "microblaze" ]; then
ext="${type##*.}"
# Microblaze simpleImage only works with dts file
cp ${RECIPE_SYSROOT}/boot/devicetree/${ext}.dts ${B}/arch/${ARCH}/boot/dts/
@@ -23,7 +23,7 @@ do_prep_simpleimage () {
do_deploy_append () {
for type in ${KERNEL_IMAGETYPES} ; do
- if [[ "${type}" =~ "simpleImage" ]] && [ ${ARCH} = "microblaze" ]; then
+ if [ -z "${type##*simpleImage*}" ] && [ ${ARCH} = "microblaze" ]; then
base_name=${imageType}-${KERNEL_IMAGE_NAME}
install -m 0644 ${KERNEL_OUTPUT_DIR}/${type}.strip $deployDir/${base_name}.strip
install -m 0644 ${KERNEL_OUTPUT_DIR}/${type}.unstrip $deployDir/${base_name}.unstrip