summaryrefslogtreecommitdiff
path: root/meta-yadro/recipes-phosphor
diff options
context:
space:
mode:
authorArtem Senichev <a.senichev@yadro.com>2020-08-03 19:51:15 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-05 02:40:41 +0300
commita183f1eb028a2a6918fd37a5a61bae3781f3a23d (patch)
tree1194fe1ca67f589707db204960b6fec8e4c18cfd /meta-yadro/recipes-phosphor
parentf0b93369b3b7cef568c0c66ce27057f858754928 (diff)
downloadopenbmc-a183f1eb028a2a6918fd37a5a61bae3781f3a23d.tar.xz
obmc-yadro-cli: srcrev bump 406688be90..5408881b37
Artem Senichev (3): sel: Show event list by default user: Using primary group as role nmi: Use D-Bus instead of direct pdbg call (From meta-yadro rev: 3434293378d7ce0ac9d0db440ec5dabc6b016fb6) Signed-off-by: Artem Senichev <a.senichev@yadro.com> Change-Id: Ic78d82a344c94e207cd9b80cbae1cbaf730a4025 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-yadro/recipes-phosphor')
-rw-r--r--meta-yadro/recipes-phosphor/cli/obmc-yadro-cli_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-yadro/recipes-phosphor/cli/obmc-yadro-cli_git.bb b/meta-yadro/recipes-phosphor/cli/obmc-yadro-cli_git.bb
new file mode 100644
index 000000000..09fa126fe
--- /dev/null
+++ b/meta-yadro/recipes-phosphor/cli/obmc-yadro-cli_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Command-line interface"
+DESCRIPTION = "YADRO OpenBMC Command Line Interface for end users"
+HOMEPAGE = "https://github.com/YADRO-KNS/obmc-yadro-cli"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+# License info
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+# Dependencies
+DEPENDS = "phosphor-user-manager"
+RDEPENDS_${PN} = "sudo bash"
+
+# Besides executable file we also have shared help
+FILES_${PN} += "${datadir}/cli.help"
+
+# Custom installation procedure
+do_install() {
+ ${B}/install.sh \
+ --dir ${D} \
+ --machine ${MACHINE} \
+ --admin priv-admin \
+ --operator priv-operator \
+ --user priv-user
+}
+
+# Source code repository
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-cli"
+SRCREV = "5408881b37890968b0a4ada8b35e81454df91321"