summaryrefslogtreecommitdiff
path: root/meta-yadro/recipes-yadro/cli
diff options
context:
space:
mode:
authorAndrei Kartashev <a.kartashev@yadro.com>2021-08-17 22:04:52 +0300
committerAndrei Kartashev <a.kartashev@yadro.com>2021-08-23 10:54:09 +0300
commit7d637776938c77d69752a72a09edc90ebde93164 (patch)
treec785af32fdb7b84f25c5d8c78a1a4e95eaac51c9 /meta-yadro/recipes-yadro/cli
parent0f66db40306e31c3adf152f47d2537109720ead5 (diff)
downloadopenbmc-7d637776938c77d69752a72a09edc90ebde93164.tar.xz
meta-yadro: move Yadro CLI recipes to own directory
Yadro have set of CLI utilities for user interaction. This recipes actually not a part of phosphor so should be moved to own category. Signed-off-by: Andrei Kartashev <a.kartashev@yadro.com> Change-Id: I0abbbf147d069b630af76ba93d792689b87261e8
Diffstat (limited to 'meta-yadro/recipes-yadro/cli')
-rw-r--r--meta-yadro/recipes-yadro/cli/obmc-yadro-backup_git.bb16
-rw-r--r--meta-yadro/recipes-yadro/cli/obmc-yadro-cli_git.bb45
-rw-r--r--meta-yadro/recipes-yadro/cli/obmc-yadro-fwupdate_git.bb26
-rw-r--r--meta-yadro/recipes-yadro/cli/obmc-yadro-lsinventory_git.bb22
-rw-r--r--meta-yadro/recipes-yadro/cli/obmc-yadro-lssensors_git.bb16
-rw-r--r--meta-yadro/recipes-yadro/cli/obmc-yadro-netconfig_git.bb19
6 files changed, 144 insertions, 0 deletions
diff --git a/meta-yadro/recipes-yadro/cli/obmc-yadro-backup_git.bb b/meta-yadro/recipes-yadro/cli/obmc-yadro-backup_git.bb
new file mode 100644
index 000000000..ae167e3bf
--- /dev/null
+++ b/meta-yadro/recipes-yadro/cli/obmc-yadro-backup_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Command line tool for backup configuration"
+DESCRIPTION = "YADRO OpenBMC command line tool for backup and restore configuration"
+HOMEPAGE = "https://github.com/YADRO-KNS/obmc-yadro-backup"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit meson
+
+# License info
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+# Source code repository
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-backup.git"
+SRCREV = "1cb990bb16708ad488980d907387bd3e4d37eb3a"
diff --git a/meta-yadro/recipes-yadro/cli/obmc-yadro-cli_git.bb b/meta-yadro/recipes-yadro/cli/obmc-yadro-cli_git.bb
new file mode 100644
index 000000000..2564ce38e
--- /dev/null
+++ b/meta-yadro/recipes-yadro/cli/obmc-yadro-cli_git.bb
@@ -0,0 +1,45 @@
+SUMMARY = "Command-line interface"
+DESCRIPTION = "YADRO OpenBMC Command Line Interface for end users"
+HOMEPAGE = "https://github.com/YADRO-KNS/obmc-yadro-cli"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+# License info
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+# Dependencies
+DEPENDS = "phosphor-user-manager"
+RDEPENDS:${PN} = " \
+ ${VIRTUAL-RUNTIME_base-utils} \
+ bash \
+ obmc-yadro-fwupdate \
+ obmc-yadro-lssensors \
+ obmc-yadro-netconfig \
+ phosphor-debug-collector-dreport \
+ phosphor-debug-collector-scripts \
+ sudo \
+ systemd \
+"
+# Some platforms also require some additional packages like
+# ipmitool, obmc-yadro-lsinventory, obmc-yadro-backup ...
+# They should be appended by bbappend file in their layers
+
+# Directory with command handlers
+FILES:${PN} += "${datadir}/cli"
+
+MACHINE_NAME ?= "${MACHINE}"
+# Custom installation procedure
+do_install() {
+ ${B}/install.sh \
+ --dir ${D} \
+ --machine ${@'${MACHINE_NAME}'.split('-')[0]} \
+ --admin priv-admin \
+ --operator priv-operator \
+ --user priv-user
+}
+
+# Source code repository
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-cli"
+SRCREV = "76743c3706516bae6b2bb8749706b4ea673e9358"
diff --git a/meta-yadro/recipes-yadro/cli/obmc-yadro-fwupdate_git.bb b/meta-yadro/recipes-yadro/cli/obmc-yadro-fwupdate_git.bb
new file mode 100644
index 000000000..95eef8fc0
--- /dev/null
+++ b/meta-yadro/recipes-yadro/cli/obmc-yadro-fwupdate_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "YADRO Firmware update tool"
+DESCRIPTION = "Command line tool for update firmware"
+HOMEPAGE = "https://github.com/YADRO-KNS/obmc-yadro-fwupdate"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit meson
+
+DEPENDS += " \
+ sdbusplus \
+ openssl \
+"
+
+PACKAGECONFIG[obmc-phosphor-image] = "-Dbmc-image-type=obmc-phosphor-image,,,,,intel-platforms"
+PACKAGECONFIG[intel-platforms] = "-Dbmc-image-type=intel-platforms,,,,,obmc-phosphor-image"
+PACKAGECONFIG[reboot-guard-support] = "-Dreboot-guard-support=true,-Dreboot-guard-support=false"
+PACKAGECONFIG[openpower-support] = "-Dopenpower-support=true,-Dopenpower-support=false"
+
+PACKAGECONFIG ??= " obmc-phosphor-image reboot-guard-support "
+PACKAGECONFIG:append_df-openpower = "openpower-support"
+
+SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-fwupdate"
+SRCREV = "0e3c0714f344a2f7f289c851434955360e6f075b"
+S = "${WORKDIR}/git"
diff --git a/meta-yadro/recipes-yadro/cli/obmc-yadro-lsinventory_git.bb b/meta-yadro/recipes-yadro/cli/obmc-yadro-lsinventory_git.bb
new file mode 100644
index 000000000..89ceb1ee1
--- /dev/null
+++ b/meta-yadro/recipes-yadro/cli/obmc-yadro-lsinventory_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Command line tool for printing inventory"
+DESCRIPTION = "YADRO OpenBMC command line tool for printing inventory list"
+HOMEPAGE = "https://github.com/YADRO-KNS/obmc-yadro-lsinventory"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit meson
+
+# License info
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+# Dependencies
+DEPENDS += " \
+ json-c \
+ sdbusplus \
+ "
+
+# Source code repository
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-lsinventory.git"
+SRCREV = "d0bdf0ddd192b9d41c5c5d4af9385122b08c7608"
diff --git a/meta-yadro/recipes-yadro/cli/obmc-yadro-lssensors_git.bb b/meta-yadro/recipes-yadro/cli/obmc-yadro-lssensors_git.bb
new file mode 100644
index 000000000..5a08c7a3e
--- /dev/null
+++ b/meta-yadro/recipes-yadro/cli/obmc-yadro-lssensors_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "OpenBMC YADRO list sensors tool"
+DESCRIPTION = "The command line tool to show detailed information about \
+ all available sensors"
+HOMEPAGE = "https://github.com/YADRO-KNS/obmc-yadro-lssensors"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit meson
+
+DEPENDS += "sdbusplus"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-lssensors.git"
+SRCREV = "39c37655bb777f1876cdddc4b624b38d75105b8e"
diff --git a/meta-yadro/recipes-yadro/cli/obmc-yadro-netconfig_git.bb b/meta-yadro/recipes-yadro/cli/obmc-yadro-netconfig_git.bb
new file mode 100644
index 000000000..7ec34edfa
--- /dev/null
+++ b/meta-yadro/recipes-yadro/cli/obmc-yadro-netconfig_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Command line tool for configuring network"
+DESCRIPTION = "YADRO OpenBMC command line tool for configuring network"
+HOMEPAGE = "https://github.com/YADRO-KNS/obmc-yadro-netconfig"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit meson
+
+# License info
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+# Dependencies
+DEPENDS = "sdbusplus"
+
+# Source code repository
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-netconfig.git"
+SRCREV = "1d991868023b80a9361a7a46c6e6b8058b482f01"