summaryrefslogtreecommitdiff
path: root/meta-yadro
diff options
context:
space:
mode:
authorAlexander Filippov <a.filippov@yadro.com>2021-07-21 11:40:06 +0300
committerAlexander Amelkin <a.amelkin@yadro.com>2021-07-28 16:44:28 +0300
commit069dc595d16dcfa89e4b6b706480ad4bd2ffc004 (patch)
treea43610e411ab34081f8c93dc946adcfc95192e37 /meta-yadro
parent9f9747835f40e60af63c66a44be765b3bfa0edcc (diff)
downloadopenbmc-069dc595d16dcfa89e4b6b706480ad4bd2ffc004.tar.xz
obmc-yadro-cli: srcrev bump 29768c2fb7..76743c3706
Alexander Amelkin (27): install: Beautify the output Move group-to-role conversion functions to clicmd clicmd: Hide restricted functions by role install: Prohibit sudo by default, no lecture Update command permissions user: Add `set mypassword`, fix `user create` Add copyright banners bmc info version: Refactor bmc: Fix help for ifconfig and datetime ntpconfig help: Restrict top-level commands Update permissions per design document vegman: power: Add `reboot`, fix `off` health logs show: Add help bmc: Refix f2ff3222ada5f627a322e920e616c978 bmc datetime show: Fix help message bmc syslog reset: Fix typo in help message Fix error handling in local variable assignments Fix assignments from external commands Add a basic github workflow for shellcheck bmc datetime set: Fix format checking Fix issues found by shellcheck clicmd: Add a generic exec_tool function bmc datetime set: Add range sanity checks bmc ifconfig help: Fix command name display clicmd: Fix autocomplete for path arguments host: virtualmedia mount: Fix help formatting bmc: config syslog: Specify TCP proto in help Alexander Filippov (16): bmc/datetime/ntpconfig: add interface support bmc/syslog: add implementation user: multiple deletion support health: logs: Use dreport instead of journalctl health: logs: export: remove obsolete bundles health: logs: fix error on show hostlogger Fix misspelling Fix 2-level subcommands execution vegman: bmc datetime set: fix execution vegman: bmc power: use hostpwrctl Improve health logs clear command vegman: led: fix ID LED state determination vegman: datetime: Remove manual settings time vegman: datetime: Masquerade manual sync method health: log: journalcopy dreport plugin support health: logs: clean: fix cleaning order Andrei Kartashev (1): show error when no groups match regexp Igor Kononenko (6): vegman: Support virtual media and NBD client remotemedia: Add the NBD export name flag bmc: remoteimage: Remove CLI command host: Update the 'virtualmedia' command host: virtualmedia: Support the HTTP protocol bmc info version: Only show active versions Ivan Mikhaylov (1): vegman: add audit logs for user actions v.mitrofanov (3): host: Add 'config default' command Refactor help formatting host: Add 'nmi' command Change-Id: Ic2dee1c43c1662c2355ad3bdd9b96451f3a9f212 Signed-off-by: Alexander Filippov <a.filippov@yadro.com>
Diffstat (limited to 'meta-yadro')
-rw-r--r--meta-yadro/recipes-phosphor/cli/obmc-yadro-cli_git.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-yadro/recipes-phosphor/cli/obmc-yadro-cli_git.bb b/meta-yadro/recipes-phosphor/cli/obmc-yadro-cli_git.bb
index 558c7612c..5cdf3164d 100644
--- a/meta-yadro/recipes-phosphor/cli/obmc-yadro-cli_git.bb
+++ b/meta-yadro/recipes-phosphor/cli/obmc-yadro-cli_git.bb
@@ -13,10 +13,11 @@ DEPENDS = "phosphor-user-manager"
RDEPENDS_${PN} = " \
${VIRTUAL-RUNTIME_base-utils} \
bash \
- obmc-console \
obmc-yadro-fwupdate \
obmc-yadro-lssensors \
obmc-yadro-netconfig \
+ phosphor-debug-collector-dreport \
+ phosphor-debug-collector-scripts \
sudo \
systemd \
"
@@ -27,11 +28,12 @@ RDEPENDS_${PN} = " \
# Directory with command handlers
FILES_${PN} += "${datadir}/cli"
+MACHINE_NAME ?= "${MACHINE}"
# Custom installation procedure
do_install() {
${B}/install.sh \
--dir ${D} \
- --machine ${@'${MACHINE}'.split('-')[0]} \
+ --machine ${@'${MACHINE_NAME}'.split('-')[0]} \
--admin priv-admin \
--operator priv-operator \
--user priv-user
@@ -40,4 +42,4 @@ do_install() {
# Source code repository
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-cli"
-SRCREV = "29768c2fb743318d459a40281e328ee8e8944a75"
+SRCREV = "76743c3706516bae6b2bb8749706b4ea673e9358"