summaryrefslogtreecommitdiff
path: root/meta-yadro
diff options
context:
space:
mode:
authorArtem Senichev <a.senichev@yadro.com>2020-10-07 16:31:35 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-10-09 16:25:02 +0300
commit236375344650d11c3db2eab9cbc94fa38e7ac9f4 (patch)
treeab9d43adacde80bd97912a7b737762759d9ebfef /meta-yadro
parentf50f7be8b0e80c9e384ef3f77b6f3882225f86f3 (diff)
downloadopenbmc-236375344650d11c3db2eab9cbc94fa38e7ac9f4.tar.xz
meta-nicole: Configure admin account
Disables setting the primary group for admin account and removes its memberships from group 'operator' and 'user'. Sudo membership is not necessary anymore. Made for compatibility with User Management service. (From meta-yadro rev: 8435f349732c6a2460aa1b05f74cb65717c120b3) Signed-off-by: Artem Senichev <a.senichev@yadro.com> Change-Id: Ib4a7b94c352a15e8ad5487ed3cdefb35d976d0fb Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-yadro')
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/users/admin-account.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/users/admin-account.bb b/meta-yadro/meta-nicole/recipes-phosphor/users/admin-account.bb
index d94952e1f..c6be7e067 100644
--- a/meta-yadro/meta-nicole/recipes-phosphor/users/admin-account.bb
+++ b/meta-yadro/meta-nicole/recipes-phosphor/users/admin-account.bb
@@ -18,14 +18,12 @@ GROUP_ADMIN = "priv-admin"
GROUP_OPERATOR = "priv-operator"
GROUP_USER = "priv-user"
GROUP_IPMI = "ipmi"
-GROUP_SUDO = "sudo"
# Default administrative account (login: admin, password: admin)
ADMIN_LOGIN = "admin"
ADMIN_PASSW = "\$1\$Fze0kFe8\$sylEANC01t.osF8OewyB/1"
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--gid ${GROUP_ADMIN} \
- --groups ${GROUP_ADMIN},${GROUP_OPERATOR},${GROUP_USER},${GROUP_IPMI},${GROUP_SUDO} \
+USERADD_PARAM_${PN} = "--groups ${GROUP_ADMIN},${GROUP_IPMI} \
--password '${ADMIN_PASSW}' \
${ADMIN_LOGIN}"