summaryrefslogtreecommitdiff
path: root/meta-yadro
diff options
context:
space:
mode:
authorAlexander Filippov <a.filippov@yadro.com>2020-06-30 19:00:17 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-03 00:13:26 +0300
commit8fb4768fe3e9a3beeb0ade0883e2d67792f4d814 (patch)
tree88243dcdb2d4db7d1ab259e72ee2aec75a2cda8a /meta-yadro
parentfbde5944c7d78e1988cbb52858c259e93f642965 (diff)
downloadopenbmc-8fb4768fe3e9a3beeb0ade0883e2d67792f4d814.tar.xz
meta-nicole: phosphor-network: use sync mac option
The phosphor-network now has the sync-mac feature. It does the same thing as the first-boot-set-mac without any additional services. This commit enables this new feature in phosphor-network and removes obsolete first-boot-set-mac service. (From meta-yadro rev: fea7a8d7a57accd658aa60248cb203afc735c73b) Change-Id: I31e530850b2550de70f72091c683153ecb6968a7 Signed-off-by: Alexander Filippov <a.filippov@yadro.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-yadro')
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/images/obmc-phosphor-image.bbappend1
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/network/first-boot-set-mac_%.bbappend1
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/network/phosphor-network/config.json3
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/network/phosphor-network_%.bbappend11
4 files changed, 14 insertions, 2 deletions
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-yadro/meta-nicole/recipes-phosphor/images/obmc-phosphor-image.bbappend
index 8f69024d1..b538c5fb6 100644
--- a/meta-yadro/meta-nicole/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-yadro/meta-nicole/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -1,7 +1,6 @@
OBMC_IMAGE_EXTRA_INSTALL_append = " \
admin-account \
first-boot-set-hostname \
- first-boot-set-mac \
mboxd \
obmc-yadro-cli \
openpower-fru-vpd \
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/network/first-boot-set-mac_%.bbappend b/meta-yadro/meta-nicole/recipes-phosphor/network/first-boot-set-mac_%.bbappend
deleted file mode 100644
index 29d23c8c4..000000000
--- a/meta-yadro/meta-nicole/recipes-phosphor/network/first-boot-set-mac_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-SYSTEMD_SERVICE_${PN} += "first-boot-set-mac@eth0.service"
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/network/phosphor-network/config.json b/meta-yadro/meta-nicole/recipes-phosphor/network/phosphor-network/config.json
new file mode 100644
index 000000000..52280a4e6
--- /dev/null
+++ b/meta-yadro/meta-nicole/recipes-phosphor/network/phosphor-network/config.json
@@ -0,0 +1,3 @@
+{
+ "eth0":"ethernet"
+}
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/network/phosphor-network_%.bbappend b/meta-yadro/meta-nicole/recipes-phosphor/network/phosphor-network_%.bbappend
index 99d30312c..20ed5af41 100644
--- a/meta-yadro/meta-nicole/recipes-phosphor/network/phosphor-network_%.bbappend
+++ b/meta-yadro/meta-nicole/recipes-phosphor/network/phosphor-network_%.bbappend
@@ -1 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
RDEPENDS_${PN}_append = " vlan-4004"
+
+EXTRA_OECONF_append = " --enable-sync-mac "
+SRC_URI_append = " file://config.json "
+FILES_${PN} += "${datadir}/network/*.json"
+
+do_install_append() {
+ install -d ${D}${datadir}/network/
+ install -m 0644 ${WORKDIR}/config.json ${D}${datadir}/network/
+}