summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-07-10 00:15:49 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-07-10 00:15:49 +0300
commitf24c1e9afc47a421831278b57377951e71494d92 (patch)
treef01c5b14beb4bf31905f769569ed647884491cea /poky/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
parent057594a8bb8d062d72244196170c2d78947d318a (diff)
parent31e5d79893f21786cb0635ab3640d50ff6202f6a (diff)
downloadopenbmc-f24c1e9afc47a421831278b57377951e71494d92.tar.xz
Merge tag 'wht-0.66' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'poky/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb')
-rw-r--r--poky/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/poky/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb b/poky/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
index a20e316a3..07e240254 100644
--- a/poky/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
+++ b/poky/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
@@ -36,5 +36,8 @@ FILES_${PN} = "${datadir}/opkg/keyrings"
RDEPENDS_${PN} = "opkg"
pkg_postinst_ontarget_${PN} () {
-opkg-key populate
+ if test -x ${bindir}/opkg-key
+ then
+ ${bindir}/opkg-key populate
+ fi
}