summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-extended/mdadm/mdadm_4.1.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-20 19:24:11 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-20 19:24:36 +0300
commit393846f19370b4407e24b907dbb48b1b16d78fcd (patch)
treef5810f62cbf574a301ac11f7338815008ed744aa /poky/meta/recipes-extended/mdadm/mdadm_4.1.bb
parentd851626f8b40842d5d8ba1cd30e74ab472ab3d2e (diff)
downloadopenbmc-393846f19370b4407e24b907dbb48b1b16d78fcd.tar.xz
poky: subtree update:a015ed7704..797916f93a
Adrian Bunk (4): poky-tiny.conf: Remove the removed irda feature from a comment musl: Add TEMP_FAILURE_RETRY from glibc systemd: Disable idn properly for musl instead of NI_IDN workarounds ofono: upgrade 1.25 -> 1.29 Alexander Kanavin (2): packagegroup-cross-canadian: repackage when TUNE_ARCH changes qemux86: use a Core 2 Duo CPU instead of the original circa-1993 Pentium Fabio Berton (1): mesa: Convert recipe to use meson build system Haiqing Bai (1): sysstat: Add PACKAGECONFIG[cron] for '--enable-install-cron' option Khem Raj (2): mmc-utils: Fix build with clang epiphany: Do not bypass initialization of variable with __attribute__((cleanup)) Liwei Song (1): mdadm: install the systemd service through Makefile Marco Felsch (1): mesa: fix imx gallium driver PACKAGECONFIG option Mark Hatle (1): bitbake: gitsm: Fix a bug where the wrong path was used for the submodule init Martin Jansa (2): grub-efi-cfg, systemd-boot-cfg: use MACHINE_ARCH tcmode-default.inc: use the same TUNE_PKGARCH variable as PN set in go-cross Ming Liu (2): kernel.bbclass: adjust a condition checking dhcp: fix a NSUPDATE compiling issue Richard Purdie (2): gettext/flex/m4/bzip2/gzip/parted/slang/attr: Add make to -ptest packages apr/apr-util: Add ptest dependency on libgcc Ross Burton (1): glib-2.0: add missing libgcc dependency to glib-2.0-ptest Tim Orling (1): libtest-needs-perl: upgrade 0.002005 -> 0.002006 Zang Ruochen (1): libinput: Upgrade 1.13.1 -> 1.13.2 Change-Id: Ic565210b5ca776c937445934910f602f424ecce1 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'poky/meta/recipes-extended/mdadm/mdadm_4.1.bb')
-rw-r--r--poky/meta/recipes-extended/mdadm/mdadm_4.1.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/poky/meta/recipes-extended/mdadm/mdadm_4.1.bb b/poky/meta/recipes-extended/mdadm/mdadm_4.1.bb
index ef5ddf55d..597faf787 100644
--- a/poky/meta/recipes-extended/mdadm/mdadm_4.1.bb
+++ b/poky/meta/recipes-extended/mdadm/mdadm_4.1.bb
@@ -57,13 +57,15 @@ do_install() {
do_install_append() {
install -d ${D}/${sysconfdir}/
install -m 644 ${S}/mdadm.conf-example ${D}${sysconfdir}/mdadm.conf
- install -d ${D}/${systemd_unitdir}/system
- install -m 644 ${WORKDIR}/mdmonitor.service ${D}/${systemd_unitdir}/system
- install -m 644 ${S}/systemd/mdmon@.service ${D}/${systemd_unitdir}/system
install -d ${D}/${sysconfdir}/init.d
install -m 755 ${WORKDIR}/mdadm.init ${D}${sysconfdir}/init.d/mdmonitor
}
+do_install_append() {
+ oe_runmake install-systemd DESTDIR=${D}
+}
+
+
do_compile_ptest() {
oe_runmake test
}
@@ -90,3 +92,5 @@ RRECOMMENDS_${PN}-ptest += " \
kernel-module-raid10 \
kernel-module-raid456 \
"
+
+FILES_${PN} += "/lib/systemd/*"