summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-support/boost/bjam-native_1.71.0.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2019-10-22 23:54:16 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2019-10-22 23:54:16 +0300
commit9722c6ee87766a45a337c094d1293de81cdcb106 (patch)
tree08b57716ae3c02fef2bc870b634019e692fd70e6 /poky/meta/recipes-support/boost/bjam-native_1.71.0.bb
parent35e295e2a161fcf146ea031de53431b2888521fa (diff)
parent5b6cc97bf138293b6af12d5d3003bb66c700c48a (diff)
downloadopenbmc-9722c6ee87766a45a337c094d1293de81cdcb106.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into HEAD
Diffstat (limited to 'poky/meta/recipes-support/boost/bjam-native_1.71.0.bb')
-rw-r--r--poky/meta/recipes-support/boost/bjam-native_1.71.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/poky/meta/recipes-support/boost/bjam-native_1.71.0.bb b/poky/meta/recipes-support/boost/bjam-native_1.71.0.bb
new file mode 100644
index 000000000..d843eb038
--- /dev/null
+++ b/poky/meta/recipes-support/boost/bjam-native_1.71.0.bb
@@ -0,0 +1,20 @@
+require boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://0001-Build-debug-version-of-bjam.patch \
+ file://0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch \
+ "
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 b2 ${D}${bindir}/bjam
+}