summaryrefslogtreecommitdiff
path: root/import-layers/meta-openembedded/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/meta-openembedded/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch')
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch79
1 files changed, 46 insertions, 33 deletions
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch b/import-layers/meta-openembedded/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch
index 8b98707cd..976e0380e 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch
+++ b/import-layers/meta-openembedded/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch
@@ -1,11 +1,21 @@
+From 81c1ba940415595584a837ab1078c64855072f0c Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Mon, 21 Nov 2011 12:00:54 +0100
+Subject: [PATCH] t1lib: add 5.1.2
#
# Patch managed by http://www.holgerschurig.de/patcher.html
#
---- t1lib-5.0.2/configure.in~configure.patch
-+++ t1lib-5.0.2/configure.in
-@@ -75,9 +75,9 @@
+---
+ configure.in | 95 ++++++++++++++++++++++++------------------------------------
+ 1 file changed, 38 insertions(+), 57 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index eade4c0..e649ea9 100644
+--- a/configure.in
++++ b/configure.in
+@@ -74,9 +74,9 @@ T1LIB_PATCHLEVEL=builtin(eval, MACRO_T1LIB_LT_REVISION)
T1LIB_VERSIONSTRING=\"MACRO_T1LIB_IDENTIFIER\"
@@ -18,7 +28,7 @@
dnl We want these before the checks, so the checks can modify their values.
test -z "$LDLIBS" && LDLIBS=-lm AC_SUBST(LDLIBS)
-@@ -161,6 +161,7 @@
+@@ -162,6 +162,7 @@ fi
dnl **** Check for underscore on external symbols ****
@@ -26,21 +36,12 @@
AC_CACHE_CHECK("whether external symbols need an underscore prefix",
ac_cv_c_extern_prefix,
[saved_libs=$LIBS
-@@ -178,68 +179,48 @@
+@@ -179,68 +180,48 @@ then
AC_DEFINE(NEED_UNDERSCORE_PREFIX)
fi
-dnl **** Check which ANSI integer type is 16 bit
-+dnl **** Check which ANSI integer type is 16 bit
-+T1_AA_TYPE16=""
-+for type in short int; do
-+ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x2"; then
-+ T1_AA_TYPE16="-DT1_AA_TYPE16=$type"
-+ T1_INT16="$type"
-+ break
-+ fi
-+done
-
+-
-AC_CACHE_CHECK( "which ANSI integer type is 16 bit", ac_16bit_type,
- AC_TRY_RUN([
-int main(void) {
@@ -58,21 +59,23 @@
-else
- T1_AA_TYPE16="-DT1_AA_TYPE16=int"
- T1_INT16="int"
++dnl **** Check which ANSI integer type is 16 bit
++T1_AA_TYPE16=""
++for type in short int; do
++ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x2"; then
++ T1_AA_TYPE16="-DT1_AA_TYPE16=$type"
++ T1_INT16="$type"
++ break
++ fi
++done
++
+if test x"$T1_AA_TYPE16" = "x"; then
+ AC_MSG_ERROR("Unable to determine which integer type is 16 bit.")
fi
-
dnl **** Check which ANSI integer type is 32 bit
-+T1_AA_TYPE32=""
-+for type in int long; do
-+ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x4"; then
-+ T1_AA_TYPE32="-DT1_AA_TYPE32=$type"
-+ T1_INT32="$type"
-+ break
-+ fi
-+done
-
+-
-AC_CACHE_CHECK( "which ANSI integer type is 32 bit", ac_32bit_type,
- AC_TRY_RUN([
-int main(void) {
@@ -90,21 +93,22 @@
-else
- T1_AA_TYPE32="-DT1_AA_TYPE32=long"
- T1_INT32="long"
++T1_AA_TYPE32=""
++for type in int long; do
++ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x4"; then
++ T1_AA_TYPE32="-DT1_AA_TYPE32=$type"
++ T1_INT32="$type"
++ break
++ fi
++done
++
+if test x"$T1_AA_TYPE32" = "x"; then
+ AC_MSG_ERROR("Unable to determine which integer type is 32 bit.")
fi
-
dnl **** Check which ANSI integer type is 64 bit
-+T1_AA_TYPE64=""
-+for type in long long_long; do
-+ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x8"; then
-+ AC_MSG_WARN("$type is 64 bit")
-+ T1_AA_TYPE64="-DT1_AA_TYPE64=\"`echo $type|tr '_' ' '`\""
-+ break
-+ fi
-+done
-
+-
-AC_CACHE_CHECK( "which ANSI integer type is 64 bit", ac_64bit_type,
- AC_TRY_RUN([
-int main(void) {
@@ -118,6 +122,15 @@
- T1_AA_TYPE64="-DT1_AA_TYPE64=long"
-else
- T1_AA_TYPE64=
++T1_AA_TYPE64=""
++for type in long long_long; do
++ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x8"; then
++ AC_MSG_WARN("$type is 64 bit")
++ T1_AA_TYPE64="-DT1_AA_TYPE64=\"`echo $type|tr '_' ' '`\""
++ break
++ fi
++done
++
+if test x"$T1_AA_TYPE64" = "x"; then
+ AC_MSG_ERROR("Unable to determine which integer type is 64 bit.")
fi