summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-common/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ampere/meta-common/recipes-phosphor')
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb17
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml16
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend9
3 files changed, 42 insertions, 0 deletions
diff --git a/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb b/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb
new file mode 100644
index 000000000..1b5a119b1
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Copy the inventory cleanup yaml for inventory manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+inherit phosphor-inventory-manager
+
+S = "${WORKDIR}"
+
+SRC_URI = "file://inventory-cleanup.yaml"
+
+do_install() {
+ install -D inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
+}
+
+FILES:${PN} += "${base_datadir}/events.d/inventory-cleanup.yaml"
diff --git a/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml b/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml
new file mode 100644
index 000000000..23f54e331
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml
@@ -0,0 +1,16 @@
+description: >
+ Ampere inventory fixups
+
+events:
+ - name: Add Chassis interface
+ description: >
+ Add the chassis interface on the chassis inventory path
+ type: startup
+ actions:
+ - name: createObjects
+ objs:
+ /system/chassis:
+ xyz.openbmc_project.Inventory.Item.Chassis:
+ Type:
+ value: "xyz.openbmc_project.Inventory.Item.Chassis.ChassisType.RackMount"
+ type: string
diff --git a/meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend b/meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
new file mode 100644
index 000000000..75177dce1
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+inherit obmc-phosphor-systemd
+
+HOSTIPMI_PROVIDER_LIBRARY:remove = "libstrgfnhandler.so"
+
+do_install:append () {
+ rm -rf ${D}${libdir}/ipmid-providers
+}