summaryrefslogtreecommitdiff
path: root/meta-aspeed/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-aspeed/conf')
-rw-r--r--meta-aspeed/conf/bblayers.conf.sample7
-rw-r--r--meta-aspeed/conf/layer.conf2
-rw-r--r--meta-aspeed/conf/local.conf.sample5
-rw-r--r--meta-aspeed/conf/machine/evb-ast2500.conf4
-rw-r--r--meta-aspeed/conf/machine/evb-ast2600.conf4
-rw-r--r--meta-aspeed/conf/machine/include/aspeed.inc5
-rw-r--r--meta-aspeed/conf/machine/include/ast2600.inc7
7 files changed, 33 insertions, 1 deletions
diff --git a/meta-aspeed/conf/bblayers.conf.sample b/meta-aspeed/conf/bblayers.conf.sample
new file mode 100644
index 000000000..e52e6beac
--- /dev/null
+++ b/meta-aspeed/conf/bblayers.conf.sample
@@ -0,0 +1,7 @@
+BBPATH = "${TOPDIR}"
+BBFILES ?= ""
+
+BBLAYERS ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-aspeed \
+ "
diff --git a/meta-aspeed/conf/layer.conf b/meta-aspeed/conf/layer.conf
index b990839bd..8c0d502cf 100644
--- a/meta-aspeed/conf/layer.conf
+++ b/meta-aspeed/conf/layer.conf
@@ -7,6 +7,6 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "aspeed-layer"
BBFILE_PATTERN_aspeed-layer := "^${LAYERDIR}/"
LAYERVERSION_aspeed-layer = "1"
-LAYERSERIES_COMPAT_aspeed-layer = "thud warrior"
+LAYERSERIES_COMPAT_aspeed-layer = "warrior"
ASPEEDBASE = '${@os.path.normpath("${LAYERDIR}/")}'
diff --git a/meta-aspeed/conf/local.conf.sample b/meta-aspeed/conf/local.conf.sample
new file mode 100644
index 000000000..9cce69288
--- /dev/null
+++ b/meta-aspeed/conf/local.conf.sample
@@ -0,0 +1,5 @@
+#MACHINE ?= "evb-ast2500"
+MACHINE ??= "evb-ast2600"
+
+# Allow logging in if the user does not set the root password.
+EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
diff --git a/meta-aspeed/conf/machine/evb-ast2500.conf b/meta-aspeed/conf/machine/evb-ast2500.conf
new file mode 100644
index 000000000..2689d3796
--- /dev/null
+++ b/meta-aspeed/conf/machine/evb-ast2500.conf
@@ -0,0 +1,4 @@
+KERNEL_DEVICETREE = "aspeed-ast2500-evb.dtb"
+UBOOT_MACHINE = "ast_g5_phy_config"
+
+require conf/machine/include/ast2500.inc
diff --git a/meta-aspeed/conf/machine/evb-ast2600.conf b/meta-aspeed/conf/machine/evb-ast2600.conf
new file mode 100644
index 000000000..fd72baa17
--- /dev/null
+++ b/meta-aspeed/conf/machine/evb-ast2600.conf
@@ -0,0 +1,4 @@
+KERNEL_DEVICETREE = "aspeed-ast2600-evb.dtb"
+UBOOT_MACHINE = "evb-ast2600_defconfig"
+
+require conf/machine/include/ast2600.inc
diff --git a/meta-aspeed/conf/machine/include/aspeed.inc b/meta-aspeed/conf/machine/include/aspeed.inc
index 36153cf5e..e62af13b8 100644
--- a/meta-aspeed/conf/machine/include/aspeed.inc
+++ b/meta-aspeed/conf/machine/include/aspeed.inc
@@ -3,4 +3,9 @@ PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-aspeed"
PREFERRED_PROVIDER_u-boot ?= "u-boot-aspeed"
PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-fw-utils-aspeed"
+PREFERRED_PROVIDER_virtual/kernel_aspeed-g6 ?= "linux-aspeed-sdk"
+PREFERRED_PROVIDER_virtual/bootloader_aspeed-g6 ?= "u-boot-aspeed-sdk"
+PREFERRED_PROVIDER_u-boot_aspeed-g6 ?= "u-boot-aspeed-sdk"
+PREFERRED_PROVIDER_u-boot-fw-utils_aspeed-g6 ?= "u-boot-fw-utils-aspeed-sdk"
+
MACHINEOVERRIDES =. "aspeed:"
diff --git a/meta-aspeed/conf/machine/include/ast2600.inc b/meta-aspeed/conf/machine/include/ast2600.inc
new file mode 100644
index 000000000..2dcaaf613
--- /dev/null
+++ b/meta-aspeed/conf/machine/include/ast2600.inc
@@ -0,0 +1,7 @@
+SOC_FAMILY = "aspeed-g6"
+include conf/machine/include/soc-family.inc
+require conf/machine/include/aspeed.inc
+require conf/machine/include/tune-cortexa7.inc
+
+UBOOT_ENTRYPOINT = "0x80001000"
+UBOOT_LOADADDRESS = "0x80001000"