summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-bletchley/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-facebook/meta-bletchley/recipes-phosphor')
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/configuration/bletchley-yaml-config.bb23
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/configuration/bletchley-yaml-config/bletchley-ipmi-fru.yaml38
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/images/fb-bletchley-phosphor-image.inc5
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/ipmi/phosphor-ipmi-fru/obmc/eeproms/system/chassis/bmc2
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend26
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend5
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config-native.bb18
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config/led.yaml89
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/network/phosphor-network/config.json3
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/network/phosphor-network_%.bbappend12
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme/nvme_config.json36
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend8
12 files changed, 265 insertions, 0 deletions
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/configuration/bletchley-yaml-config.bb b/meta-facebook/meta-bletchley/recipes-phosphor/configuration/bletchley-yaml-config.bb
new file mode 100644
index 000000000..7a8f8471c
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/configuration/bletchley-yaml-config.bb
@@ -0,0 +1,23 @@
+SUMMARY = "YAML configuration for bletchley"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+
+SRC_URI = " \
+ file://bletchley-ipmi-fru.yaml \
+ "
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -m 0644 -D bletchley-ipmi-fru.yaml \
+ ${D}${datadir}/${BPN}/ipmi-fru-read.yaml
+}
+
+FILES:${PN}-dev = " \
+ ${datadir}/${BPN}/ipmi-fru-read.yaml \
+ "
+
+ALLOW_EMPTY:${PN} = "1"
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/configuration/bletchley-yaml-config/bletchley-ipmi-fru.yaml b/meta-facebook/meta-bletchley/recipes-phosphor/configuration/bletchley-yaml-config/bletchley-ipmi-fru.yaml
new file mode 100644
index 000000000..8c53a2a7c
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/configuration/bletchley-yaml-config/bletchley-ipmi-fru.yaml
@@ -0,0 +1,38 @@
+0:
+ /system/chassis/bmc:
+ entityID: 7
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Decorator.Revision:
+ Version:
+ IPMIFruProperty: FRU File ID
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item.Board:
+ xyz.openbmc_project.Inventory.Item.Bmc:
+
+ /system/chassis/bmc/ethernet:
+ entityID: 7
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Inventory.Item.NetworkInterface:
+ MACAddress:
+ IPMIFruProperty: Custom Field 3
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item.Ethernet: \ No newline at end of file
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/images/fb-bletchley-phosphor-image.inc b/meta-facebook/meta-bletchley/recipes-phosphor/images/fb-bletchley-phosphor-image.inc
new file mode 100644
index 000000000..6636f5090
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/images/fb-bletchley-phosphor-image.inc
@@ -0,0 +1,5 @@
+OBMC_IMAGE_EXTRA_INSTALL:append = " \
+ phosphor-nvme \
+ plat-svc \
+ motor-ctrl \
+"
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/ipmi/phosphor-ipmi-fru/obmc/eeproms/system/chassis/bmc b/meta-facebook/meta-bletchley/recipes-phosphor/ipmi/phosphor-ipmi-fru/obmc/eeproms/system/chassis/bmc
new file mode 100644
index 000000000..b1bd018a6
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/ipmi/phosphor-ipmi-fru/obmc/eeproms/system/chassis/bmc
@@ -0,0 +1,2 @@
+SYSFS_PATH=/sys/bus/i2c/devices/7-0054/eeprom
+FRUID=0 \ No newline at end of file
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend b/meta-facebook/meta-bletchley/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
new file mode 100644
index 000000000..0c78a8f52
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
@@ -0,0 +1,26 @@
+inherit obmc-phosphor-systemd
+
+FILESEXTRAPATHS:prepend:bletchley := "${THISDIR}/${PN}:"
+
+DEPENDS:append:bletchley = " bletchley-yaml-config"
+
+EXTRA_OECONF:bletchley = " \
+ YAML_GEN=${STAGING_DIR_HOST}${datadir}/bletchley-yaml-config/ipmi-fru-read.yaml \
+ "
+
+EEPROM_NAMES = "bmc"
+
+EEPROMFMT = "system/chassis/{0}"
+EEPROM_ESCAPEDFMT = "system-chassis-{0}"
+EEPROMS = "${@compose_list(d, 'EEPROMFMT', 'EEPROM_NAMES')}"
+EEPROMS_ESCAPED = "${@compose_list(d, 'EEPROM_ESCAPEDFMT', 'EEPROM_NAMES')}"
+
+ENVFMT = "obmc/eeproms/{0}"
+SYSTEMD_ENVIRONMENT_FILE:${PN}:append:bletchley := " ${@compose_list(d, 'ENVFMT', 'EEPROMS')}"
+
+TMPL = "obmc-read-eeprom@.service"
+TGT = "${SYSTEMD_DEFAULT_TARGET}"
+INSTFMT = "obmc-read-eeprom@{0}.service"
+FMT = "../${TMPL}:${TGT}.wants/${INSTFMT}"
+
+SYSTEMD_LINK:${PN}:append:bletchley := " ${@compose_list(d, 'FMT', 'EEPROMS_ESCAPED')}"
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-facebook/meta-bletchley/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
new file mode 100644
index 000000000..fd303a04b
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -0,0 +1,5 @@
+DEPENDS:append:bletchley = " bletchley-yaml-config"
+
+EXTRA_OECONF:bletchley = " \
+ FRU_YAML_GEN=${STAGING_DIR_HOST}${datadir}/bletchley-yaml-config/ipmi-fru-read.yaml \
+ "
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config-native.bb b/meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config-native.bb
new file mode 100644
index 000000000..d06ec861e
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Phosphor LED Group Management for Bletchley"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Copies example led layout yaml file
+do_install() {
+ SRC=${S}
+ DEST=${D}${datadir}/phosphor-led-manager
+ install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config/led.yaml b/meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config/led.yaml
new file mode 100644
index 000000000..4fb482cca
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config/led.yaml
@@ -0,0 +1,89 @@
+bmc_booted:
+ sys_log_id:
+ Action: 'On'
+
+sys_identify:
+ sys_log_id:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+
+fan0_fault:
+ fan0_amber:
+ Action: 'On'
+
+fan0_good:
+ fan0_blue:
+ Action: 'On'
+
+fan1_fault:
+ fan1_amber:
+ Action: 'On'
+
+fan1_good:
+ fan1_blue:
+ Action: 'On'
+
+fan2_fault:
+ fan2_amber:
+ Action: 'On'
+
+fan2_good:
+ fan2_blue:
+ Action: 'On'
+
+fan3_fault:
+ fan3_amber:
+ Action: 'On'
+
+fan3_good:
+ fan3_blue:
+ Action: 'On'
+
+sled0_fault:
+ sled0_amber:
+ Action: 'On'
+
+sled0_good:
+ sled0_blue:
+ Action: 'On'
+
+sled1_fault:
+ sled1_amber:
+ Action: 'On'
+
+sled1_good:
+ sled1_blue:
+ Action: 'On'
+
+sled2_fault:
+ sled2_amber:
+ Action: 'On'
+
+sled2_good:
+ sled2_blue:
+ Action: 'On'
+
+sled3_fault:
+ sled3_amber:
+ Action: 'On'
+
+sled3_good:
+ sled3_blue:
+ Action: 'On'
+
+sled4_fault:
+ sled4_amber:
+ Action: 'On'
+
+sled4_good:
+ sled4_blue:
+ Action: 'On'
+
+sled5_fault:
+ sled5_amber:
+ Action: 'On'
+
+sled5_good:
+ sled5_blue:
+ Action: 'On'
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/network/phosphor-network/config.json b/meta-facebook/meta-bletchley/recipes-phosphor/network/phosphor-network/config.json
new file mode 100644
index 000000000..52280a4e6
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/network/phosphor-network/config.json
@@ -0,0 +1,3 @@
+{
+ "eth0":"ethernet"
+}
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/network/phosphor-network_%.bbappend b/meta-facebook/meta-bletchley/recipes-phosphor/network/phosphor-network_%.bbappend
new file mode 100644
index 000000000..b91e82f91
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/network/phosphor-network_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+PACKAGECONFIG:append = " sync-mac"
+SRC_URI += " \
+ file://config.json \
+ "
+FILES:${PN} += "${datadir}/network/*.json"
+
+do_install:append() {
+ install -d ${D}${datadir}/network/
+ install -m 0644 ${WORKDIR}/config.json ${D}${datadir}/network/
+}
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme/nvme_config.json b/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme/nvme_config.json
new file mode 100644
index 000000000..f64382e9c
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme/nvme_config.json
@@ -0,0 +1,36 @@
+{
+ "config": [
+ {
+ "NVMeDriveIndex": 0,
+ "NVMeDriveBusID": 0
+ },
+ {
+ "NVMeDriveIndex": 1,
+ "NVMeDriveBusID": 1
+ },
+ {
+ "NVMeDriveIndex": 2,
+ "NVMeDriveBusID": 2
+ },
+ {
+ "NVMeDriveIndex": 3,
+ "NVMeDriveBusID": 3
+ },
+ {
+ "NVMeDriveIndex": 4,
+ "NVMeDriveBusID": 4
+ },
+ {
+ "NVMeDriveIndex": 5,
+ "NVMeDriveBusID": 5
+ }
+ ],
+ "threshold": [
+ {
+ "criticalHigh": 75,
+ "criticalLow": 0,
+ "maxValue": 127,
+ "minValue": -127
+ }
+ ]
+}
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend b/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
new file mode 100644
index 000000000..919cef113
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://nvme_config.json"
+
+do_install:append() {
+ install -d ${D}/${sysconfdir}/nvme/
+ install -m 0644 ${WORKDIR}/nvme_config.json ${D}/${sysconfdir}/nvme/
+}