summaryrefslogtreecommitdiff
path: root/meta-facebook/recipes-x86
diff options
context:
space:
mode:
Diffstat (limited to 'meta-facebook/recipes-x86')
-rw-r--r--meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host1.json2
-rw-r--r--meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host2.json10
-rw-r--r--meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host3.json10
-rw-r--r--meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host4.json10
-rw-r--r--meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend2
5 files changed, 17 insertions, 17 deletions
diff --git a/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host1.json b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host1.json
index 8c8379e1e..708f95729 100644
--- a/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host1.json
+++ b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host1.json
@@ -31,7 +31,7 @@
{
"Name" : "PowerOk",
"DbusName" : "xyz.openbmc_project.IpmbSensor",
- "Path" : "/xyz/openbmc_project/gpio/volt/1_CPU_Good",
+ "Path" : "/xyz/openbmc_project/gpio/ipmbGpioState/1_CPU_Good",
"Interface" : "xyz.openbmc_project.Chassis.Control.Power",
"Property" : "PGood",
"Type" : "DBUS"
diff --git a/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host2.json b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host2.json
index ebf7bf029..2455c620c 100644
--- a/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host2.json
+++ b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host2.json
@@ -2,28 +2,28 @@
"gpio_configs":[
{
"Name" : "PostComplete",
- "LineName" : "POST_COMPLETE",
+ "LineName" : "POST_COMPLETE2",
"Type" : "GPIO",
"Polarity" : "ActiveLow"
},
{
"Name" : "SlotPower",
- "LineName" : "SLOT1_POWER",
+ "LineName" : "SLOT2_POWER",
"Type" : "GPIO",
"Polarity" : "ActiveLow"
},
{
"Name" : "PowerOut",
- "LineName" : "POWER_OUT1",
+ "LineName" : "POWER_OUT2",
"Type" : "GPIO",
"Polarity" : "ActiveLow"
},
{
"Name" : "ResetOut",
- "LineName" : "RESET_OUT1",
+ "LineName" : "RESET_OUT2",
"Type" : "GPIO",
"Polarity" : "ActiveLow"
},
@@ -31,7 +31,7 @@
{
"Name" : "PowerOk",
"DbusName" : "xyz.openbmc_project.IpmbSensor",
- "Path" : "/xyz/openbmc_project/gpio/volt/2_CPU_Good",
+ "Path" : "/xyz/openbmc_project/gpio/ipmbGpioState/2_CPU_Good",
"Interface" : "xyz.openbmc_project.Chassis.Control.Power",
"Property" : "PGood",
"Type" : "DBUS"
diff --git a/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host3.json b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host3.json
index 3631dc392..66077a238 100644
--- a/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host3.json
+++ b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host3.json
@@ -2,28 +2,28 @@
"gpio_configs":[
{
"Name" : "PostComplete",
- "LineName" : "POST_COMPLETE",
+ "LineName" : "POST_COMPLETE3",
"Type" : "GPIO",
"Polarity" : "ActiveLow"
},
{
"Name" : "SlotPower",
- "LineName" : "SLOT1_POWER",
+ "LineName" : "SLOT3_POWER",
"Type" : "GPIO",
"Polarity" : "ActiveLow"
},
{
"Name" : "PowerOut",
- "LineName" : "POWER_OUT1",
+ "LineName" : "POWER_OUT3",
"Type" : "GPIO",
"Polarity" : "ActiveLow"
},
{
"Name" : "ResetOut",
- "LineName" : "RESET_OUT1",
+ "LineName" : "RESET_OUT3",
"Type" : "GPIO",
"Polarity" : "ActiveLow"
},
@@ -31,7 +31,7 @@
{
"Name" : "PowerOk",
"DbusName" : "xyz.openbmc_project.IpmbSensor",
- "Path" : "/xyz/openbmc_project/gpio/volt/3_CPU_Good",
+ "Path" : "/xyz/openbmc_project/gpio/ipmbGpioState/3_CPU_Good",
"Interface" : "xyz.openbmc_project.Chassis.Control.Power",
"Property" : "PGood",
"Type" : "DBUS"
diff --git a/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host4.json b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host4.json
index dac58ae34..0e7bc3c1c 100644
--- a/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host4.json
+++ b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host4.json
@@ -2,28 +2,28 @@
"gpio_configs":[
{
"Name" : "PostComplete",
- "LineName" : "POST_COMPLETE",
+ "LineName" : "POST_COMPLETE4",
"Type" : "GPIO",
"Polarity" : "ActiveLow"
},
{
"Name" : "SlotPower",
- "LineName" : "SLOT1_POWER",
+ "LineName" : "SLOT4_POWER",
"Type" : "GPIO",
"Polarity" : "ActiveLow"
},
{
"Name" : "PowerOut",
- "LineName" : "POWER_OUT1",
+ "LineName" : "POWER_OUT4",
"Type" : "GPIO",
"Polarity" : "ActiveLow"
},
{
"Name" : "ResetOut",
- "LineName" : "RESET_OUT1",
+ "LineName" : "RESET_OUT4",
"Type" : "GPIO",
"Polarity" : "ActiveLow"
},
@@ -31,7 +31,7 @@
{
"Name" : "PowerOk",
"DbusName" : "xyz.openbmc_project.IpmbSensor",
- "Path" : "/xyz/openbmc_project/gpio/volt/4_CPU_Good",
+ "Path" : "/xyz/openbmc_project/gpio/ipmbGpioState/4_CPU_Good",
"Interface" : "xyz.openbmc_project.Chassis.Control.Power",
"Property" : "PGood",
"Type" : "DBUS"
diff --git a/meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend
index 862f2f179..59f307877 100644
--- a/meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend
+++ b/meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -1,5 +1,5 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-EXTRA_OECMAKE += "-DCHASSIS_SYSTEM_RESET=ON"
+EXTRA_OEMESON += "-Dchassis-system-reset=enabled"
SRC_URI:append:yosemitev2 = " file://power-config-host1.json"
SRC_URI:append:yosemitev2 = " file://power-config-host2.json"