summaryrefslogtreecommitdiff
path: root/meta-facebook/recipes-x86
diff options
context:
space:
mode:
Diffstat (limited to 'meta-facebook/recipes-x86')
-rw-r--r--meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host1.json52
-rw-r--r--meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host2.json52
-rw-r--r--meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host3.json52
-rw-r--r--meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host4.json52
-rw-r--r--meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend11
5 files changed, 219 insertions, 0 deletions
diff --git a/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host1.json b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host1.json
new file mode 100644
index 000000000..8c8379e1e
--- /dev/null
+++ b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host1.json
@@ -0,0 +1,52 @@
+{
+ "gpio_configs":[
+ {
+ "Name" : "PostComplete",
+ "LineName" : "POST_COMPLETE",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "SlotPower",
+ "LineName" : "SLOT1_POWER",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "PowerOut",
+ "LineName" : "POWER_OUT1",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "ResetOut",
+ "LineName" : "RESET_OUT1",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "PowerOk",
+ "DbusName" : "xyz.openbmc_project.IpmbSensor",
+ "Path" : "/xyz/openbmc_project/gpio/volt/1_CPU_Good",
+ "Interface" : "xyz.openbmc_project.Chassis.Control.Power",
+ "Property" : "PGood",
+ "Type" : "DBUS"
+ }
+],
+"timing_configs":{
+ "PowerPulseMs": 200,
+ "ForceOffPulseMs": 15000,
+ "ResetPulseMs": 500,
+ "PowerCycleMs": 5000,
+ "SioPowerGoodWatchdogMs": 1000,
+ "PsPowerOKWatchdogMs": 8000,
+ "GracefulPowerOffS": 300,
+ "WarmResetCheckMs": 500,
+ "PowerOffSaveMs": 7000,
+ "slotPowerCycleTimeMs": 200
+}
+}
diff --git a/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host2.json b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host2.json
new file mode 100644
index 000000000..ebf7bf029
--- /dev/null
+++ b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host2.json
@@ -0,0 +1,52 @@
+{
+ "gpio_configs":[
+ {
+ "Name" : "PostComplete",
+ "LineName" : "POST_COMPLETE",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "SlotPower",
+ "LineName" : "SLOT1_POWER",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "PowerOut",
+ "LineName" : "POWER_OUT1",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "ResetOut",
+ "LineName" : "RESET_OUT1",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "PowerOk",
+ "DbusName" : "xyz.openbmc_project.IpmbSensor",
+ "Path" : "/xyz/openbmc_project/gpio/volt/2_CPU_Good",
+ "Interface" : "xyz.openbmc_project.Chassis.Control.Power",
+ "Property" : "PGood",
+ "Type" : "DBUS"
+ }
+],
+"timing_configs":{
+ "PowerPulseMs": 200,
+ "ForceOffPulseMs": 15000,
+ "ResetPulseMs": 500,
+ "PowerCycleMs": 5000,
+ "SioPowerGoodWatchdogMs": 1000,
+ "PsPowerOKWatchdogMs": 8000,
+ "GracefulPowerOffS": 300,
+ "WarmResetCheckMs": 500,
+ "PowerOffSaveMs": 7000,
+ "slotPowerCycleTimeMs": 200
+}
+}
diff --git a/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host3.json b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host3.json
new file mode 100644
index 000000000..3631dc392
--- /dev/null
+++ b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host3.json
@@ -0,0 +1,52 @@
+{
+ "gpio_configs":[
+ {
+ "Name" : "PostComplete",
+ "LineName" : "POST_COMPLETE",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "SlotPower",
+ "LineName" : "SLOT1_POWER",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "PowerOut",
+ "LineName" : "POWER_OUT1",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "ResetOut",
+ "LineName" : "RESET_OUT1",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "PowerOk",
+ "DbusName" : "xyz.openbmc_project.IpmbSensor",
+ "Path" : "/xyz/openbmc_project/gpio/volt/3_CPU_Good",
+ "Interface" : "xyz.openbmc_project.Chassis.Control.Power",
+ "Property" : "PGood",
+ "Type" : "DBUS"
+ }
+],
+"timing_configs":{
+ "PowerPulseMs": 200,
+ "ForceOffPulseMs": 15000,
+ "ResetPulseMs": 500,
+ "PowerCycleMs": 5000,
+ "SioPowerGoodWatchdogMs": 1000,
+ "PsPowerOKWatchdogMs": 8000,
+ "GracefulPowerOffS": 300,
+ "WarmResetCheckMs": 500,
+ "PowerOffSaveMs": 7000,
+ "slotPowerCycleTimeMs": 200
+}
+}
diff --git a/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host4.json b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host4.json
new file mode 100644
index 000000000..dac58ae34
--- /dev/null
+++ b/meta-facebook/recipes-x86/chassis/x86-power-control/yosemitev2/power-config-host4.json
@@ -0,0 +1,52 @@
+{
+ "gpio_configs":[
+ {
+ "Name" : "PostComplete",
+ "LineName" : "POST_COMPLETE",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "SlotPower",
+ "LineName" : "SLOT1_POWER",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "PowerOut",
+ "LineName" : "POWER_OUT1",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "ResetOut",
+ "LineName" : "RESET_OUT1",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+
+ {
+ "Name" : "PowerOk",
+ "DbusName" : "xyz.openbmc_project.IpmbSensor",
+ "Path" : "/xyz/openbmc_project/gpio/volt/4_CPU_Good",
+ "Interface" : "xyz.openbmc_project.Chassis.Control.Power",
+ "Property" : "PGood",
+ "Type" : "DBUS"
+ }
+],
+"timing_configs":{
+ "PowerPulseMs": 200,
+ "ForceOffPulseMs": 15000,
+ "ResetPulseMs": 500,
+ "PowerCycleMs": 5000,
+ "SioPowerGoodWatchdogMs": 1000,
+ "PsPowerOKWatchdogMs": 8000,
+ "GracefulPowerOffS": 300,
+ "WarmResetCheckMs": 500,
+ "PowerOffSaveMs": 7000,
+ "slotPowerCycleTimeMs": 200
+}
+}
diff --git a/meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend
index c119baca9..862f2f179 100644
--- a/meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend
+++ b/meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -1,2 +1,13 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
EXTRA_OECMAKE += "-DCHASSIS_SYSTEM_RESET=ON"
+
+SRC_URI:append:yosemitev2 = " file://power-config-host1.json"
+SRC_URI:append:yosemitev2 = " file://power-config-host2.json"
+SRC_URI:append:yosemitev2 = " file://power-config-host3.json"
+SRC_URI:append:yosemitev2 = " file://power-config-host4.json"
+
+do_install:append:yosemitev2() {
+ install -m 0755 -d ${D}/${datadir}/${BPN}
+ install -m 0644 -D ${WORKDIR}/*.json \
+ ${D}/${datadir}/${BPN}/
+}