summaryrefslogtreecommitdiff
path: root/meta-google/recipes-core/busybox
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-core/busybox')
-rw-r--r--meta-google/recipes-core/busybox/busybox_%.bbappend1
-rw-r--r--meta-google/recipes-core/busybox/files/gbmc.cfg34
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-google/recipes-core/busybox/busybox_%.bbappend b/meta-google/recipes-core/busybox/busybox_%.bbappend
index 0f2210d7f..fd7873cc1 100644
--- a/meta-google/recipes-core/busybox/busybox_%.bbappend
+++ b/meta-google/recipes-core/busybox/busybox_%.bbappend
@@ -1,2 +1,3 @@
FILESEXTRAPATHS:prepend:gbmc := "${THISDIR}/files:"
SRC_URI:append:gbmc = " file://gbmc.cfg"
+SRC_URI:remove:gbmc = "file://syslog.cfg"
diff --git a/meta-google/recipes-core/busybox/files/gbmc.cfg b/meta-google/recipes-core/busybox/files/gbmc.cfg
index 158f771b3..c76e4f0a7 100644
--- a/meta-google/recipes-core/busybox/files/gbmc.cfg
+++ b/meta-google/recipes-core/busybox/files/gbmc.cfg
@@ -19,3 +19,37 @@ CONFIG_FEATURE_UDHCPC6_RFC5970=y
# Misc
CONFIG_BC=y
+CONFIG_TRUNCATE=y
+CONFIG_BASE64=y
+CONFIG_FEATURE_TOP_INTERACTIVE=y
+CONFIG_FEATURE_TOP_SMP_CPU=y
+CONFIG_FEATURE_TOP_SMP_PROCESS=y
+CONFIG_FEATURE_TOPMEM=y
+
+# Remove unused things
+CONFIG_BUNZIP2=n
+CONFIG_BZIP2=n
+CONFIG_UNZIP=n
+CONFIG_ADDGROUP=n
+CONFIG_ADDUSER=n
+CONFIG_DELGROUP=n
+CONFIG_DELUSER=n
+CONFIG_LOGIN=n
+CONFIG_SU=n
+CONFIG_SULOGIN=n
+CONFIG_FDISK=n
+CONFIG_FSTRIM=n
+CONFIG_MKSWAP=n
+CONFIG_SWAPON=n
+CONFIG_SWAPOFF=n
+CONFIG_WATCHDOG=n
+CONFIG_IFCONFIG=n
+CONFIG_IFUP=n
+CONFIG_IFDOWN=n
+CONFIG_ROUTE=n
+CONFIG_TFTP=n
+CONFIG_TLS=n
+CONFIG_TRACEROUTE=n
+CONFIG_KLOGD=n
+CONFIG_LOGREAD=n
+CONFIG_SYSLOGD=n