summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb')
-rw-r--r--meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb b/meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb
new file mode 100644
index 000000000..a9595c37c
--- /dev/null
+++ b/meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Watchdog Shell Library"
+DESCRIPTION = "Watchdog Shell Library"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI += " \
+ file://libwatchdog.sh \
+"
+
+RDEPENDS:${PN} = "bash"
+
+do_install() {
+ install -d ${D}${libexecdir}
+ install -m 0755 ${WORKDIR}/libwatchdog.sh ${D}${libexecdir}/
+}