summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/networking/gbmc-bridge.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-google/networking/gbmc-bridge.bb')
-rw-r--r--meta-google/recipes-google/networking/gbmc-bridge.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta-google/recipes-google/networking/gbmc-bridge.bb b/meta-google/recipes-google/networking/gbmc-bridge.bb
index dea14f00b..509d871d9 100644
--- a/meta-google/recipes-google/networking/gbmc-bridge.bb
+++ b/meta-google/recipes-google/networking/gbmc-bridge.bb
@@ -20,6 +20,8 @@ SRC_URI += " \
file://gbmc-br-ensure-ra.service \
file://gbmc-br-gw-src.sh \
file://gbmc-br-nft.sh \
+ file://gbmc-br-dhcp.sh \
+ file://gbmc-br-dhcp.service \
"
FILES:${PN}:append = " \
@@ -37,7 +39,10 @@ RDEPENDS:${PN}:append = " \
ndisc6-rdisc6 \
"
-SYSTEMD_SERVICE:${PN} += "gbmc-br-ensure-ra.service"
+SYSTEMD_SERVICE:${PN} += " \
+ gbmc-br-ensure-ra.service \
+ gbmc-br-dhcp.service \
+ "
GBMC_BR_MAC_ADDR ?= ""
@@ -94,8 +99,10 @@ do_install() {
install -d -m0755 ${D}${libexecdir}
install -m0755 ${WORKDIR}/gbmc-br-ensure-ra.sh ${D}${libexecdir}/
+ install -m0755 ${WORKDIR}/gbmc-br-dhcp.sh ${D}${libexecdir}/
install -d -m0755 ${D}${systemd_system_unitdir}
- install -m0755 ${WORKDIR}/gbmc-br-ensure-ra.service ${D}${systemd_system_unitdir}/
+ install -m0644 ${WORKDIR}/gbmc-br-ensure-ra.service ${D}${systemd_system_unitdir}/
+ install -m0644 ${WORKDIR}/gbmc-br-dhcp.service ${D}${systemd_system_unitdir}/
}
do_rm_work:prepend() {