summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/networking/gbmc-iperf3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-google/networking/gbmc-iperf3.bb')
-rw-r--r--meta-google/recipes-google/networking/gbmc-iperf3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-google/recipes-google/networking/gbmc-iperf3.bb b/meta-google/recipes-google/networking/gbmc-iperf3.bb
new file mode 100644
index 000000000..f1a88b459
--- /dev/null
+++ b/meta-google/recipes-google/networking/gbmc-iperf3.bb
@@ -0,0 +1,18 @@
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+RDEPENDS_${PN} += "iperf3"
+
+SRC_URI += "file://iperf3.service"
+
+SYSTEMD_SERVICE_${PN} += "iperf3.service"
+
+do_install() {
+ # Install service definitions
+ install -d -m 0755 ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/iperf3.service ${D}${systemd_system_unitdir}
+}