summaryrefslogtreecommitdiff
path: root/meta-hpe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-hpe')
-rw-r--r--meta-hpe/README.md2
-rw-r--r--meta-hpe/conf/layer.conf2
-rw-r--r--meta-hpe/meta-dl360poc/conf/bblayers.conf.sample13
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-common-gxp_2020.10.inc2
-rw-r--r--meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc1
-rw-r--r--meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig3
-rw-r--r--meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.14.bb (renamed from meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.10.bb)6
7 files changed, 10 insertions, 19 deletions
diff --git a/meta-hpe/README.md b/meta-hpe/README.md
index d2960f4d7..ef07653e0 100644
--- a/meta-hpe/README.md
+++ b/meta-hpe/README.md
@@ -39,7 +39,7 @@ meta-hpe patches are reviewed using the Gerrit instance at
https://gerrit.openbmc-project.xyz.
Please submit patches to Gerrit. More information about using Gerrit can be found
-[here](https://github.com/openbmc/docs/blob/meta-hpe/master/CONTRIBUTING.md#submitting-changes-via-gerrit-server).
+[here](https://github.com/openbmc/docs/blob/master/CONTRIBUTING.md#submitting-changes-via-gerrit-server).
https://github.com/openbmc/meta-hpe is a hosting mirror only. GitHub
pull requests are not monitored and will not be accepted.
diff --git a/meta-hpe/conf/layer.conf b/meta-hpe/conf/layer.conf
index da14cfc28..1072f7d48 100644
--- a/meta-hpe/conf/layer.conf
+++ b/meta-hpe/conf/layer.conf
@@ -6,7 +6,7 @@ BBFILES += "${LAYERDIR}/meta-common/recipes-*/*/*.bb \
${LAYERDIR}/meta-common/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "hpe-layer"
-BBFILE_PATTERN_hpe-layer := "^${LAYERDIR}/"
+BBFILE_PATTERN_hpe-layer := "^${LAYERDIR}/meta-common/"
LAYERSERIES_COMPAT_hpe-layer = "hardknott honister"
# Provide a variable that points the base of the hpe layer.
diff --git a/meta-hpe/meta-dl360poc/conf/bblayers.conf.sample b/meta-hpe/meta-dl360poc/conf/bblayers.conf.sample
index ef28dc220..d75648063 100644
--- a/meta-hpe/meta-dl360poc/conf/bblayers.conf.sample
+++ b/meta-hpe/meta-dl360poc/conf/bblayers.conf.sample
@@ -18,16 +18,3 @@ BBLAYERS ?= " \
##OEROOT##/meta-hpe \
##OEROOT##/meta-hpe/meta-dl360poc \
"
-BBLAYERS_NON_REMOVABLE ?= " \
- ##OEROOT##/meta \
- ##OEROOT##/meta-openembedded/meta-oe \
- ##OEROOT##/meta-openembedded/meta-networking \
- ##OEROOT##/meta-openembedded/meta-perl \
- ##OEROOT##/meta-openembedded/meta-python \
- ##OEROOT##/meta-openembedded/meta-webserver \
- ##OEROOT##/meta-security \
- ##OEROOT##/meta-phosphor \
- ##OEROOT##/meta-hpe/meta-gxp \
- ##OEROOT##/meta-hpe \
- ##OEROOT##/meta-hpe/meta-dl360poc \
- "
diff --git a/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-common-gxp_2020.10.inc b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-common-gxp_2020.10.inc
index 2efeb9e09..d8f45ed78 100644
--- a/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-common-gxp_2020.10.inc
+++ b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-common-gxp_2020.10.inc
@@ -7,7 +7,7 @@ PE = "1"
# We use the revision in order to avoid having to fetch it from the
# repo during parse
-SRCREV = "b139a8a9e6e89e4115741498d454847d99239eda"
+SRCREV = "7e035b9bf331426919aa993a6bb1de3c837e5d3c"
UBRANCH = "v2020.10-gxp-openbmc"
SRC_URI = "git://github.com/HewlettPackard/gxp-uboot.git;branch=${UBRANCH}"
diff --git a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc
index 5d79797f7..dfa9e806f 100644
--- a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc
+++ b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc
@@ -21,4 +21,5 @@ require recipes-kernel/linux/linux-yocto.inc
# From 4.16+ the COPYING file changed
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+KERNEL_FEATURES:remove = "phosphor-gpio-keys"
diff --git a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig
index cdd03e3f7..12e1eb636 100644
--- a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig
+++ b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig
@@ -216,6 +216,7 @@ CONFIG_HPE_GXP_FN2=y
CONFIG_HPE_GXP_CSM=y
CONFIG_HPE_GXP_SROM=y
CONFIG_HPE_GXP_CHIF=y
+CONFIG_HPE_GXP_DBG=y
CONFIG_PECI=y
CONFIG_PECI_CHARDEV=y
CONFIG_PECI_GXP=y
@@ -277,3 +278,5 @@ CONFIG_DEBUG_UART_VIRT=0xF00000F0
CONFIG_DEBUG_UART_8250_SHIFT=0
CONFIG_EARLY_PRINTK=y
CONFIG_TEST_KSTRTOX=y
+CONFIG_IPMI_KCS_BMC_CDEV_IPMI=y
+CONFIG_FUSE_FS=y
diff --git a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.10.bb b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.14.bb
index d0b5407ae..030a6fa93 100644
--- a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.10.bb
+++ b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.14.bb
@@ -1,6 +1,6 @@
-KBRANCH ?= "dev-5.10-gxp-openbmc"
-LINUX_VERSION ?= "5.10.17"
-SRCREV="8d942b456304d3a21597cda47387a45ace61a225"
+KBRANCH ?= "dev-5.14-gxp-openbmc"
+LINUX_VERSION ?= "5.14.0"
+SRCREV="6f1a2c5c0cc59692d5beafe5ff8a4c7539b82d7d"
require linux-obmc.inc
require conf/machine/include/fitimage-sign.inc