summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/conf/bblayers.conf.sample13
-rw-r--r--meta-ibm/conf/machine/witherspoon.conf2
-rw-r--r--meta-ibm/meta-palmetto/conf/bblayers.conf.sample12
-rw-r--r--meta-ibm/meta-romulus/conf/bblayers.conf.sample12
-rw-r--r--meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,everest_associations.json41
-rw-r--r--meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,rainier-2u_associations.json41
-rw-r--r--meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,rainier-4u_associations.json41
-rw-r--r--meta-ibm/recipes-phosphor/state/phosphor-post-code-manager_%.bbappend4
8 files changed, 127 insertions, 39 deletions
diff --git a/meta-ibm/conf/bblayers.conf.sample b/meta-ibm/conf/bblayers.conf.sample
index 11b3f5980..4f70015be 100644
--- a/meta-ibm/conf/bblayers.conf.sample
+++ b/meta-ibm/conf/bblayers.conf.sample
@@ -18,16 +18,3 @@ BBLAYERS ?= " \
##OEROOT##/meta-openpower \
##OEROOT##/meta-ibm \
"
-BBLAYERS_NON_REMOVABLE ?= " \
- ##OEROOT##/meta \
- ##OEROOT##/meta-openembedded/meta-oe \
- ##OEROOT##/meta-openembedded/meta-networking \
- ##OEROOT##/meta-openembedded/meta-perl \
- ##OEROOT##/meta-openembedded/meta-python \
- ##OEROOT##/meta-security/meta-tpm \
- ##OEROOT##/meta-security \
- ##OEROOT##/meta-phosphor \
- ##OEROOT##/meta-aspeed \
- ##OEROOT##/meta-openpower \
- ##OEROOT##/meta-ibm \
- "
diff --git a/meta-ibm/conf/machine/witherspoon.conf b/meta-ibm/conf/machine/witherspoon.conf
index 42844c1cc..e71992219 100644
--- a/meta-ibm/conf/machine/witherspoon.conf
+++ b/meta-ibm/conf/machine/witherspoon.conf
@@ -32,3 +32,5 @@ PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config:df-mrw = \
# Inhibit phosphor-fan-control-fan-config-mrw-native
PREFERRED_PROVIDER_virtual/phosphor-fan-control-fan-config:df-mrw = \
"phosphor-fan-control-fan-config"
+
+IMAGE_FEATURES:remove = "obmc-ikvm"
diff --git a/meta-ibm/meta-palmetto/conf/bblayers.conf.sample b/meta-ibm/meta-palmetto/conf/bblayers.conf.sample
index b5c268c64..750b4763c 100644
--- a/meta-ibm/meta-palmetto/conf/bblayers.conf.sample
+++ b/meta-ibm/meta-palmetto/conf/bblayers.conf.sample
@@ -17,15 +17,3 @@ BBLAYERS ?= " \
##OEROOT##/meta-openpower \
##OEROOT##/meta-ibm/meta-palmetto \
"
-BBLAYERS_NON_REMOVABLE ?= " \
- ##OEROOT##/meta \
- ##OEROOT##/meta-openembedded/meta-oe \
- ##OEROOT##/meta-openembedded/meta-networking \
- ##OEROOT##/meta-openembedded/meta-perl \
- ##OEROOT##/meta-openembedded/meta-python \
- ##OEROOT##/meta-security \
- ##OEROOT##/meta-phosphor \
- ##OEROOT##/meta-aspeed \
- ##OEROOT##/meta-openpower \
- ##OEROOT##/meta-ibm/meta-palmetto \
- "
diff --git a/meta-ibm/meta-romulus/conf/bblayers.conf.sample b/meta-ibm/meta-romulus/conf/bblayers.conf.sample
index 1bb30353e..bf1f4e986 100644
--- a/meta-ibm/meta-romulus/conf/bblayers.conf.sample
+++ b/meta-ibm/meta-romulus/conf/bblayers.conf.sample
@@ -17,15 +17,3 @@ BBLAYERS ?= " \
##OEROOT##/meta-openpower \
##OEROOT##/meta-ibm/meta-romulus \
"
-BBLAYERS_NON_REMOVABLE ?= " \
- ##OEROOT##/meta \
- ##OEROOT##/meta-openembedded/meta-oe \
- ##OEROOT##/meta-openembedded/meta-networking \
- ##OEROOT##/meta-openembedded/meta-perl \
- ##OEROOT##/meta-openembedded/meta-python \
- ##OEROOT##/meta-security \
- ##OEROOT##/meta-phosphor \
- ##OEROOT##/meta-aspeed \
- ##OEROOT##/meta-openpower \
- ##OEROOT##/meta-ibm/meta-romulus \
- "
diff --git a/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,everest_associations.json b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,everest_associations.json
index 7405ce1fc..8693e7d1d 100644
--- a/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,everest_associations.json
+++ b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,everest_associations.json
@@ -177,11 +177,34 @@
{
"types":
{
+ "rType": "fault_inventory_object",
+ "fType": "fault_led_group"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/led/groups/enclosure_fault"
+ ]
+ },
+ {
+ "types":
+ {
+ "rType": "identify_inventory_object",
+ "fType": "identify_led_group"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/led/groups/enclosure_identify"
+ ]
+ },
+ {
+ "types":
+ {
"rType": "chassis",
"fType": "all_sensors"
},
"paths":
[
+ "/xyz/openbmc_project/sensors/altitude/Altitude",
"/xyz/openbmc_project/sensors/fan_tach/fan0_0",
"/xyz/openbmc_project/sensors/fan_tach/fan0_1",
"/xyz/openbmc_project/sensors/fan_tach/fan1_0",
@@ -256,6 +279,24 @@
]
},
{
+ "path": "system",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "fault_inventory_object",
+ "fType": "fault_led_group"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/led/groups/partition_system_attention_indicator",
+ "/xyz/openbmc_project/led/groups/platform_system_attention_indicator"
+ ]
+ }
+ ]
+ },
+ {
"path": "system/chassis/motherboard/powersupply0",
"endpoints":
[
diff --git a/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,rainier-2u_associations.json b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,rainier-2u_associations.json
index 65f389998..2ea36bc67 100644
--- a/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,rainier-2u_associations.json
+++ b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,rainier-2u_associations.json
@@ -258,11 +258,34 @@
{
"types":
{
+ "rType": "fault_inventory_object",
+ "fType": "fault_led_group"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/led/groups/enclosure_fault"
+ ]
+ },
+ {
+ "types":
+ {
+ "rType": "identify_inventory_object",
+ "fType": "identify_led_group"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/led/groups/enclosure_identify"
+ ]
+ },
+ {
+ "types":
+ {
"rType": "chassis",
"fType": "all_sensors"
},
"paths":
[
+ "/xyz/openbmc_project/sensors/altitude/Altitude",
"/xyz/openbmc_project/sensors/fan_tach/fan0_0",
"/xyz/openbmc_project/sensors/fan_tach/fan0_1",
"/xyz/openbmc_project/sensors/fan_tach/fan1_0",
@@ -299,6 +322,24 @@
]
},
{
+ "path": "system",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "fault_inventory_object",
+ "fType": "fault_led_group"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/led/groups/partition_system_attention_indicator",
+ "/xyz/openbmc_project/led/groups/platform_system_attention_indicator"
+ ]
+ }
+ ]
+ },
+ {
"path": "system/chassis/motherboard/powersupply0",
"endpoints":
[
diff --git a/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,rainier-4u_associations.json b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,rainier-4u_associations.json
index 5cda22d66..6d9bc42f1 100644
--- a/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,rainier-4u_associations.json
+++ b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/p10bmc/ibm,rainier-4u_associations.json
@@ -252,11 +252,34 @@
{
"types":
{
+ "rType": "fault_inventory_object",
+ "fType": "fault_led_group"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/led/groups/enclosure_fault"
+ ]
+ },
+ {
+ "types":
+ {
+ "rType": "identify_inventory_object",
+ "fType": "identify_led_group"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/led/groups/enclosure_identify"
+ ]
+ },
+ {
+ "types":
+ {
"rType": "chassis",
"fType": "all_sensors"
},
"paths":
[
+ "/xyz/openbmc_project/sensors/altitude/Altitude",
"/xyz/openbmc_project/sensors/fan_tach/fan0_0",
"/xyz/openbmc_project/sensors/fan_tach/fan1_0",
"/xyz/openbmc_project/sensors/fan_tach/fan2_0",
@@ -287,6 +310,24 @@
]
},
{
+ "path": "system",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "fault_inventory_object",
+ "fType": "fault_led_group"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/led/groups/partition_system_attention_indicator",
+ "/xyz/openbmc_project/led/groups/platform_system_attention_indicator"
+ ]
+ }
+ ]
+ },
+ {
"path": "system/chassis/motherboard/powersupply0",
"endpoints":
[
diff --git a/meta-ibm/recipes-phosphor/state/phosphor-post-code-manager_%.bbappend b/meta-ibm/recipes-phosphor/state/phosphor-post-code-manager_%.bbappend
index bee5a5ffa..e9f35d42d 100644
--- a/meta-ibm/recipes-phosphor/state/phosphor-post-code-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/state/phosphor-post-code-manager_%.bbappend
@@ -1,4 +1,4 @@
# Set MaxBootCycleCount to 5 on IBM systems
-EXTRA_OECMAKE:append:p10bmc = "-DMAX_BOOT_CYCLE_COUNT=5"
-EXTRA_OECMAKE:append:witherspoon-tacoma = "-DMAX_BOOT_CYCLE_COUNT=5"
+EXTRA_OEMESON:append:p10bmc = "-Dmax-boot-cycle-count=5"
+EXTRA_OEMESON:append:witherspoon-tacoma = "-Dmax-boot-cycle-count=5"