summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-core/systemd/systemd_%.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-ibm/recipes-core/systemd/systemd_%.bbappend b/meta-ibm/recipes-core/systemd/systemd_%.bbappend
index b61d9306d..354ea4055 100644
--- a/meta-ibm/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-ibm/recipes-core/systemd/systemd_%.bbappend
@@ -25,3 +25,9 @@ do_install:append:p10bmc() {
install -m 644 -D ${WORKDIR}/systemd-journald-override.conf ${D}${systemd_system_unitdir}/systemd-journald.service.d/systemd-journald-override.conf
install -m 644 -D ${WORKDIR}/journald-size-policy-16MB.conf ${D}${systemd_unitdir}/journald.conf.d/journald-size-policy.conf
}
+
+# Witherspoon doesn't have the space for the both zstd and xz compression
+# libraries and currently phosphor-debug-collector is using xz. Switch systemd
+# to use xz so only one of the two is added into the image.
+PACKAGECONFIG:remove:witherspoon = "zstd"
+PACKAGECONFIG:append:witherspoon = " xz"