summaryrefslogtreecommitdiff
path: root/meta-inventec/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-inventec/conf/layer.conf')
-rw-r--r--meta-inventec/conf/layer.conf12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-inventec/conf/layer.conf b/meta-inventec/conf/layer.conf
index 2b5eade4c..e390573be 100644
--- a/meta-inventec/conf/layer.conf
+++ b/meta-inventec/conf/layer.conf
@@ -1,7 +1,15 @@
# We have a conf and classes directory, add to BBPATH
BBPATH .= ":${LAYERDIR}"
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/meta-common/recipes-*/*/*.bb \
+ ${LAYERDIR}/meta-common/recipes-*/*/*.bbappend"
+
BBFILE_COLLECTIONS += "inventec"
-BBFILE_PATTERN_inventec = ""
+BBFILE_PATTERN_inventec := "^${LAYERDIR}/"
+LAYERSERIES_COMPAT_inventec = "hardknott honister"
+BBFILE_PRIORITY_inventec = "6"
+
+# Provide a variable that points the base of the hpe layer.
+INVENTECBASE = '${@os.path.normpath("${LAYERDIR}/")}'
-LAYERSERIES_COMPAT_inventec = "hardknott"