summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dump
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dump')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector.bbappend21
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector/plugins.d/ibm_elogall29
2 files changed, 0 insertions, 50 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector.bbappend b/meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector.bbappend
deleted file mode 100644
index 402e4fa09..000000000
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector.bbappend
+++ /dev/null
@@ -1,21 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://plugins.d/ibm_elogall"
-
-install_ibm_plugins() {
-
- install -m 0755 ${WORKDIR}/plugins.d/ibm_elogall ${D}${dreport_plugin_dir}
-
-}
-
-#Link in the plugins so dreport run them at the appropriate time
-python link_ibm_plugins() {
-
- workdir = d.getVar('WORKDIR', True)
- script = os.path.join(workdir, 'plugins.d', 'ibm_elogall')
- install_dreport_user_script(script, d)
-
-}
-
-do_install[postfuncs] += "install_ibm_plugins"
-do_install[postfuncs] += "link_ibm_plugins"
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector/plugins.d/ibm_elogall b/meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector/plugins.d/ibm_elogall
deleted file mode 100644
index 3054f237c..000000000
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector/plugins.d/ibm_elogall
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/bash
-#
-# config: 2 20
-# @brief: Get the IBM specific elog objects
-#
-
-. $DREPORT_INCLUDE/functions
-
-desc="IBM elog"
-
-entries=$(busctl --list --no-pager tree \
- com.ibm.Logging | grep \
- '/xyz/openbmc_project/logging/entry/')
-
-#check for elog entries.
-if [ -z "$entries" ]; then
- log_info "No $desc entries"
- exit 0
-fi
-
-command="busctl call --verbose --no-pager \
- com.ibm.Logging \
- /xyz/openbmc_project/logging \
- org.freedesktop.DBus.ObjectManager \
- GetManagedObjects"
-
-file_name="ibm_elogall.log"
-
-add_cmd_output "$command" "$file_name" "$desc"