summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-ast2500/recipes-bsp/u-boot/files/0046-Enable-FMC-DMA-for-memmove.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-ast2500/recipes-bsp/u-boot/files/0046-Enable-FMC-DMA-for-memmove.patch')
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-bsp/u-boot/files/0046-Enable-FMC-DMA-for-memmove.patch20
1 files changed, 9 insertions, 11 deletions
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-bsp/u-boot/files/0046-Enable-FMC-DMA-for-memmove.patch b/meta-openbmc-mods/meta-ast2500/recipes-bsp/u-boot/files/0046-Enable-FMC-DMA-for-memmove.patch
index e75b732b1..547754996 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-bsp/u-boot/files/0046-Enable-FMC-DMA-for-memmove.patch
+++ b/meta-openbmc-mods/meta-ast2500/recipes-bsp/u-boot/files/0046-Enable-FMC-DMA-for-memmove.patch
@@ -1,4 +1,4 @@
-From 38d3fba3ac2d4240bab1e5427fc6ed71291e1cc8 Mon Sep 17 00:00:00 2001
+From da1a1d60346118e6d05efc39c8899f590b483a25 Mon Sep 17 00:00:00 2001
From: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
Date: Fri, 19 Jun 2020 16:30:47 -0700
Subject: [PATCH] Enable FMC DMA for memmove
@@ -8,16 +8,17 @@ completed quickly.
Signed-off-by: Chia-Wei Wang <chiawei_wang@aspeedtech.com>
Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
+
---
arch/arm/mach-aspeed/Makefile | 2 +-
- arch/arm/mach-aspeed/utils.S | 53 +++++++++++++++++++++++++++++++++++++++++++
- lib/Kconfig | 6 +++++
- lib/string.c | 12 +++++++++-
+ arch/arm/mach-aspeed/utils.S | 53 +++++++++++++++++++++++++++++++++++
+ lib/Kconfig | 6 ++++
+ lib/string.c | 12 +++++++-
4 files changed, 71 insertions(+), 2 deletions(-)
create mode 100644 arch/arm/mach-aspeed/utils.S
diff --git a/arch/arm/mach-aspeed/Makefile b/arch/arm/mach-aspeed/Makefile
-index 7d8930beb988..b9fcf41d8c97 100644
+index 7d8930beb9..b9fcf41d8c 100644
--- a/arch/arm/mach-aspeed/Makefile
+++ b/arch/arm/mach-aspeed/Makefile
@@ -11,7 +11,7 @@
@@ -31,7 +32,7 @@ index 7d8930beb988..b9fcf41d8c97 100644
obj-$(CONFIG_ARCH_AST2400) += platform_g4.o
diff --git a/arch/arm/mach-aspeed/utils.S b/arch/arm/mach-aspeed/utils.S
new file mode 100644
-index 000000000000..a06d72552eef
+index 0000000000..a06d72552e
--- /dev/null
+++ b/arch/arm/mach-aspeed/utils.S
@@ -0,0 +1,53 @@
@@ -89,7 +90,7 @@ index 000000000000..a06d72552eef
+ mov pc, lr
+ENDPROC(aspeed_spi_fastcpy)
diff --git a/lib/Kconfig b/lib/Kconfig
-index 02ca4058d37e..8c8fde6b1b28 100644
+index 02ca4058d3..8c8fde6b1b 100644
--- a/lib/Kconfig
+++ b/lib/Kconfig
@@ -149,6 +149,12 @@ config SPL_OF_LIBFDT
@@ -106,7 +107,7 @@ index 02ca4058d37e..8c8fde6b1b28 100644
source lib/efi_loader/Kconfig
diff --git a/lib/string.c b/lib/string.c
-index 0bf472f1f69e..f95b8e478fa6 100644
+index 0bf472f1f6..f95b8e478f 100644
--- a/lib/string.c
+++ b/lib/string.c
@@ -15,11 +15,12 @@
@@ -146,6 +147,3 @@ index 0bf472f1f69e..f95b8e478fa6 100644
if (unaligned_src || unaligned_dst) {
if (unaligned_dst != unaligned_src) {
unaligned_header = count;
---
-2.7.4
-