summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common-small/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common-small/recipes-devtools')
-rw-r--r--meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/files/0001-hw-arm-aspeed-Add-an-intel-ast2500-machine-type.patch63
-rw-r--r--meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/files/0002-Turn-Off-FFWUPD-Jumper.patch32
-rw-r--r--meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-native_%.bbappend7
-rw-r--r--meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-system-native_%.bbappend6
-rw-r--r--meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu_%.bbappend5
5 files changed, 46 insertions, 67 deletions
diff --git a/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/files/0001-hw-arm-aspeed-Add-an-intel-ast2500-machine-type.patch b/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/files/0001-hw-arm-aspeed-Add-an-intel-ast2500-machine-type.patch
index cca6c838b..deccc47f3 100644
--- a/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/files/0001-hw-arm-aspeed-Add-an-intel-ast2500-machine-type.patch
+++ b/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/files/0001-hw-arm-aspeed-Add-an-intel-ast2500-machine-type.patch
@@ -12,15 +12,15 @@ Signed-off-by: James Feist <james.feist@linux.intel.com>
1 file changed, 42 insertions(+)
diff --git a/hw/arm/aspeed.c b/hw/arm/aspeed.c
-index 465e65f323..80e8466aa9 100644
+index 6f4d707..5a9d58b 100644
--- a/hw/arm/aspeed.c
+++ b/hw/arm/aspeed.c
-@@ -60,6 +60,21 @@ struct AspeedBoardState {
+@@ -64,6 +64,21 @@ struct AspeedBoardState {
SCU_HW_STRAP_MAC0_RGMII) & \
~SCU_HW_STRAP_2ND_BOOT_WDT)
-
+
+/* intel ast2500 hardware value: 0xF3CCC286 */
-+#define INTEL_AST2500_BMC_HW_STRAP1 (( \
++#define INTEL_AST2500_BMC_HW_STRAP1 (( \
+ AST2500_HW_STRAP1_DEFAULTS | \
+ SCU_AST2500_HW_STRAP_SPI_AUTOFETCH_ENABLE | \
+ SCU_AST2500_HW_STRAP_GPIO_STRAP_ENABLE | \
@@ -37,10 +37,10 @@ index 465e65f323..80e8466aa9 100644
/* Romulus hardware value: 0xF10AD206 */
#define ROMULUS_BMC_HW_STRAP1 ( \
AST2500_HW_STRAP1_DEFAULTS | \
-@@ -281,6 +296,24 @@ static void ast2500_evb_i2c_init(AspeedBoardState *bmc)
- i2c_create_slave(aspeed_i2c_get_bus(DEVICE(&soc->i2c), 11), "ds1338", 0x32);
+@@ -396,6 +411,24 @@ static void ast2600_evb_i2c_init(AspeedBoardState *bmc)
+ ast2500_evb_i2c_init(bmc);
}
-
+
+static void intel_ast2500_i2c_init(AspeedBoardState *bmc)
+{
+ AspeedSoCState *soc = &bmc->soc;
@@ -62,22 +62,39 @@ index 465e65f323..80e8466aa9 100644
static void romulus_bmc_i2c_init(AspeedBoardState *bmc)
{
AspeedSoCState *soc = &bmc->soc;
-@@ -390,6 +423,15 @@ static const AspeedBoardConfig aspeed_boards[] = {
- .spi_model = "mx25l25635e",
- .num_cs = 1,
- .i2c_init = ast2500_evb_i2c_init,
-+ }, {
-+ .name = MACHINE_TYPE_NAME("intel-ast2500"),
-+ .desc = "Intel AST2500 BMC (ARM1176)",
-+ .soc_name = "ast2500-a1",
-+ .hw_strap1 = INTEL_AST2500_BMC_HW_STRAP1,
-+ .fmc_model = "n25q512a",
-+ .spi_model = "n25q512a",
-+ .num_cs = 1,
-+ .i2c_init = intel_ast2500_i2c_init,
+@@ -537,6 +570,21 @@ static void aspeed_machine_ast2500_evb_class_init(ObjectClass *oc, void *data)
+ mc->default_ram_size = 512 * MiB;
+ };
+
++static void aspeed_machine_intel_ast2500_class_init(ObjectClass *oc, void *data)
++{
++ MachineClass *mc = MACHINE_CLASS(oc);
++ AspeedMachineClass *amc = ASPEED_MACHINE_CLASS(oc);
++
++ mc->desc = "Intel AST2500 BMC (ARM1176)";
++ amc->soc_name = "ast2500-a1";
++ amc->hw_strap1 = INTEL_AST2500_BMC_HW_STRAP1;
++ amc->fmc_model = "n25q512a";
++ amc->spi_model = "n25q512a";
++ amc->num_cs = 1;
++ amc->i2c_init = intel_ast2500_i2c_init;
++ mc->default_ram_size = 512 * MiB;
++};
++
+ static void aspeed_machine_romulus_class_init(ObjectClass *oc, void *data)
+ {
+ MachineClass *mc = MACHINE_CLASS(oc);
+@@ -624,6 +672,10 @@ static const TypeInfo aspeed_machine_types[] = {
+ .parent = TYPE_ASPEED_MACHINE,
+ .class_init = aspeed_machine_ast2500_evb_class_init,
}, {
- .name = MACHINE_TYPE_NAME("romulus-bmc"),
- .desc = "OpenPOWER Romulus BMC (ARM1176)",
---
++ .name = MACHINE_TYPE_NAME("intel-ast2500"),
++ .parent = TYPE_ASPEED_MACHINE,
++ .class_init = aspeed_machine_intel_ast2500_class_init,
++ }, {
+ .name = MACHINE_TYPE_NAME("romulus-bmc"),
+ .parent = TYPE_ASPEED_MACHINE,
+ .class_init = aspeed_machine_romulus_class_init,
+--
2.17.1
diff --git a/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/files/0002-Turn-Off-FFWUPD-Jumper.patch b/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/files/0002-Turn-Off-FFWUPD-Jumper.patch
deleted file mode 100644
index 2f81895d0..000000000
--- a/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/files/0002-Turn-Off-FFWUPD-Jumper.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From db99abbddc9fe958353e47fcd91c741bd7a93066 Mon Sep 17 00:00:00 2001
-From: James Feist <james.feist@linux.intel.com>
-Date: Wed, 19 Jun 2019 14:15:07 -0700
-Subject: [PATCH] Turn Off FFWUPD Jumper
-
-This disabled the jumper so we don't get stuck during
-boot.
-
-TODO: Do this the "right way", if there is one.
-
-Signed-off-by: James Feist <james.feist@linux.intel.com>
----
- hw/gpio/aspeed_gpio.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/hw/gpio/aspeed_gpio.c b/hw/gpio/aspeed_gpio.c
-index 12d8a49666..ca6f8dd0dd 100644
---- a/hw/gpio/aspeed_gpio.c
-+++ b/hw/gpio/aspeed_gpio.c
-@@ -29,6 +29,9 @@ static uint64_t aspeed_gpio_read(void *opaque, hwaddr addr,
- val = s->regs[addr];
- }
-
-+ if (addr == 0x0){
-+ val |= 1 << 0x18; // ffupd jumper
-+ }
- return val;
- }
-
---
-2.17.1
-
diff --git a/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-native_%.bbappend b/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-native_%.bbappend
index e0bc525ba..d2855db1b 100644
--- a/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-native_%.bbappend
+++ b/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-native_%.bbappend
@@ -1,11 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI = "git://github.com/openbmc/qemu.git;nobranch=1 \
- file://0001-hw-arm-aspeed-Add-an-intel-ast2500-machine-type.patch \
- file://0002-Turn-Off-FFWUPD-Jumper.patch"
+ file://0001-hw-arm-aspeed-Add-an-intel-ast2500-machine-type.patch"
QEMU_TARGETS = "arm"
S = "${WORKDIR}/git"
-SRCREV = "5dca85cb0b85ac309d131f9db1fb57af282d67cc"
-
-PACKAGECONFIG[ssh] = "--enable-libssh2,--disable-libssh2,libssh2,"
+SRCREV = "8ab0db0624b454bd69a04ca0010f165cb7119100"
diff --git a/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-system-native_%.bbappend b/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-system-native_%.bbappend
index 3a0ccb83f..f8c8c66c1 100644
--- a/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-system-native_%.bbappend
+++ b/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-system-native_%.bbappend
@@ -1,11 +1,9 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI = "git://github.com/openbmc/qemu.git;nobranch=1 \
file://powerpc_rom.bin \
- file://run-ptest \
- file://0001-hw-arm-aspeed-Add-an-intel-ast2500-machine-type.patch \
- file://0002-Turn-Off-FFWUPD-Jumper.patch"
+ file://0001-hw-arm-aspeed-Add-an-intel-ast2500-machine-type.patch"
QEMU_TARGETS = "arm"
S = "${WORKDIR}/git"
-SRCREV = "5dca85cb0b85ac309d131f9db1fb57af282d67cc"
+SRCREV = "8ab0db0624b454bd69a04ca0010f165cb7119100"
diff --git a/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu_%.bbappend b/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu_%.bbappend
index 6b59f16b0..cfc1a3ace 100644
--- a/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu_%.bbappend
+++ b/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu_%.bbappend
@@ -1,7 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI = "git://github.com/openbmc/qemu.git;nobranch=1 \
- file://0001-hw-arm-aspeed-Add-an-intel-ast2500-machine-type.patch \
- file://0002-Turn-Off-FFWUPD-Jumper.patch"
+ file://0001-hw-arm-aspeed-Add-an-intel-ast2500-machine-type.patch"
S = "${WORKDIR}/git"
-SRCREV = "5dca85cb0b85ac309d131f9db1fb57af282d67cc"
+SRCREV = "8ab0db0624b454bd69a04ca0010f165cb7119100"