summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0006-Add-Aspeed-g5-interrupt-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0006-Add-Aspeed-g5-interrupt-support.patch')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0006-Add-Aspeed-g5-interrupt-support.patch42
1 files changed, 20 insertions, 22 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0006-Add-Aspeed-g5-interrupt-support.patch b/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0006-Add-Aspeed-g5-interrupt-support.patch
index dbaf7b362..4f90d6dfe 100644
--- a/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0006-Add-Aspeed-g5-interrupt-support.patch
+++ b/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0006-Add-Aspeed-g5-interrupt-support.patch
@@ -1,7 +1,7 @@
-From f33755167ddcdebbf56bc875e4091990273c6997 Mon Sep 17 00:00:00 2001
+From e782f6a90468fee35877b78e248a17f39f67c94c Mon Sep 17 00:00:00 2001
From: Vernon Mauery <vernon.mauery@linux.intel.com>
Date: Wed, 14 Nov 2018 10:21:40 -0800
-Subject: [PATCH 1/7] Add Aspeed g5 interrupt support
+Subject: [PATCH] Add Aspeed g5 interrupt support
This adds a few new files to the board g5 directory. Several Intel
features require interrupts running in U-Boot, so this adds basic
@@ -9,25 +9,26 @@ interrupt registration and handling support.
Signed-off-by: Vernon Mauery <vernon.mauery@linux.intel.com>
Change-Id: Id7072f1408dcf364968b1b74f2192e50a22a82f0
+
---
- Kconfig | 13 ++
- arch/arm/lib/interrupts.c | 11 ++
- board/aspeed/ast-g5/Makefile | 4 +-
- board/aspeed/ast-g5/ast-g5-irq.c | 176 ++++++++++++++++++++++++++++
- board/aspeed/ast-g5/ast-g5-irq.h | 39 ++++++
+ Kconfig | 13 +++
+ arch/arm/lib/interrupts.c | 11 +++
+ board/aspeed/ast-g5/Makefile | 3 +-
+ board/aspeed/ast-g5/ast-g5-irq.c | 176 ++++++++++++++++++++++++++++++++++++
+ board/aspeed/ast-g5/ast-g5-irq.h | 39 ++++++++
board/aspeed/ast-g5/ast-g5.c | 3 +
board/aspeed/ast-g5/ast-g5.h | 7 ++
cmd/Kconfig | 5 +
configs/ast_g5_ncsi_2boot_defconfig | 1 +
configs/ast_g5_ncsi_defconfig | 1 +
configs/ast_g5_phy_defconfig | 1 +
- 11 files changed, 260 insertions(+), 1 deletion(-)
+ 11 files changed, 259 insertions(+), 1 deletion(-)
create mode 100644 board/aspeed/ast-g5/ast-g5-irq.c
create mode 100644 board/aspeed/ast-g5/ast-g5-irq.h
create mode 100644 board/aspeed/ast-g5/ast-g5.h
diff --git a/Kconfig b/Kconfig
-index 3ceff25032..d6439d01ca 100644
+index 3ceff25..d6439d0 100644
--- a/Kconfig
+++ b/Kconfig
@@ -115,6 +115,19 @@ if EXPERT
@@ -51,7 +52,7 @@ index 3ceff25032..d6439d01ca 100644
menu "Boot images"
diff --git a/arch/arm/lib/interrupts.c b/arch/arm/lib/interrupts.c
-index ed83043abb..a96b3aa070 100644
+index ed83043..a96b3aa 100644
--- a/arch/arm/lib/interrupts.c
+++ b/arch/arm/lib/interrupts.c
@@ -94,6 +94,17 @@ int disable_interrupts (void)
@@ -73,7 +74,7 @@ index ed83043abb..a96b3aa070 100644
int interrupt_init (void)
{
diff --git a/board/aspeed/ast-g5/Makefile b/board/aspeed/ast-g5/Makefile
-index d1d7f8525e..d41b11589f 100644
+index d1d7f85..df4e639 100644
--- a/board/aspeed/ast-g5/Makefile
+++ b/board/aspeed/ast-g5/Makefile
@@ -1 +1,2 @@
@@ -82,7 +83,7 @@ index d1d7f8525e..d41b11589f 100644
+obj-y += ast-g5-irq.o
diff --git a/board/aspeed/ast-g5/ast-g5-irq.c b/board/aspeed/ast-g5/ast-g5-irq.c
new file mode 100644
-index 0000000000..860f16cf05
+index 0000000..860f16c
--- /dev/null
+++ b/board/aspeed/ast-g5/ast-g5-irq.c
@@ -0,0 +1,176 @@
@@ -264,7 +265,7 @@ index 0000000000..860f16cf05
+#endif
diff --git a/board/aspeed/ast-g5/ast-g5-irq.h b/board/aspeed/ast-g5/ast-g5-irq.h
new file mode 100644
-index 0000000000..703eeabf13
+index 0000000..703eeab
--- /dev/null
+++ b/board/aspeed/ast-g5/ast-g5-irq.h
@@ -0,0 +1,39 @@
@@ -308,7 +309,7 @@ index 0000000000..703eeabf13
+
+#endif /* __AST_G5_IRQ_H__ */
diff --git a/board/aspeed/ast-g5/ast-g5.c b/board/aspeed/ast-g5/ast-g5.c
-index b492003f51..2472aa3603 100644
+index b492003..2472aa3 100644
--- a/board/aspeed/ast-g5/ast-g5.c
+++ b/board/aspeed/ast-g5/ast-g5.c
@@ -14,6 +14,8 @@
@@ -330,7 +331,7 @@ index b492003f51..2472aa3603 100644
}
diff --git a/board/aspeed/ast-g5/ast-g5.h b/board/aspeed/ast-g5/ast-g5.h
new file mode 100644
-index 0000000000..9fd10eccb3
+index 0000000..9fd10ec
--- /dev/null
+++ b/board/aspeed/ast-g5/ast-g5.h
@@ -0,0 +1,7 @@
@@ -342,7 +343,7 @@ index 0000000000..9fd10eccb3
+
+#endif /* _AST_G5_H_ */
diff --git a/cmd/Kconfig b/cmd/Kconfig
-index d69b817c82..33be2407d2 100644
+index d69b817..33be240 100644
--- a/cmd/Kconfig
+++ b/cmd/Kconfig
@@ -313,6 +313,11 @@ endmenu
@@ -358,7 +359,7 @@ index d69b817c82..33be2407d2 100644
bool "dm - Access to driver model information"
depends on DM
diff --git a/configs/ast_g5_ncsi_2boot_defconfig b/configs/ast_g5_ncsi_2boot_defconfig
-index 2d28c86966..d5b7894a9e 100644
+index 2d28c86..d5b7894 100644
--- a/configs/ast_g5_ncsi_2boot_defconfig
+++ b/configs/ast_g5_ncsi_2boot_defconfig
@@ -33,3 +33,4 @@ CONFIG_CMD_CRC32=y
@@ -367,7 +368,7 @@ index 2d28c86966..d5b7894a9e 100644
CONFIG_CMD_MX_CYCLIC=y
+CONFIG_USE_IRQ=y
diff --git a/configs/ast_g5_ncsi_defconfig b/configs/ast_g5_ncsi_defconfig
-index 74029ed514..9481e5fb6e 100644
+index 74029ed..9481e5f 100644
--- a/configs/ast_g5_ncsi_defconfig
+++ b/configs/ast_g5_ncsi_defconfig
@@ -11,3 +11,4 @@ CONFIG_HUSH_PARSER=y
@@ -376,7 +377,7 @@ index 74029ed514..9481e5fb6e 100644
CONFIG_SYS_NS16550=y
+CONFIG_USE_IRQ=y
diff --git a/configs/ast_g5_phy_defconfig b/configs/ast_g5_phy_defconfig
-index 767f3af605..4aefcf49e8 100644
+index 767f3af..4aefcf4 100644
--- a/configs/ast_g5_phy_defconfig
+++ b/configs/ast_g5_phy_defconfig
@@ -12,3 +12,4 @@ CONFIG_HUSH_PARSER=y
@@ -384,6 +385,3 @@ index 767f3af605..4aefcf49e8 100644
CONFIG_SPI_FLASH=y
CONFIG_SYS_NS16550=y
+CONFIG_USE_IRQ=y
---
-2.17.1
-