summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0027-CPLD-u-boot-commands-support-for-PFR.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0027-CPLD-u-boot-commands-support-for-PFR.patch')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0027-CPLD-u-boot-commands-support-for-PFR.patch13
1 files changed, 7 insertions, 6 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0027-CPLD-u-boot-commands-support-for-PFR.patch b/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0027-CPLD-u-boot-commands-support-for-PFR.patch
index b5f7ccf07..ac458dd6c 100644
--- a/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0027-CPLD-u-boot-commands-support-for-PFR.patch
+++ b/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0027-CPLD-u-boot-commands-support-for-PFR.patch
@@ -1,4 +1,4 @@
-From cdb62eb60de0b99276ff755b896fc51c8ed2606d Mon Sep 17 00:00:00 2001
+From 0083904a79527cef9ca99e516ed015b56a6b95c7 Mon Sep 17 00:00:00 2001
From: AppaRao Puli <apparao.puli@linux.intel.com>
Date: Tue, 7 May 2019 11:26:35 +0530
Subject: [PATCH] CPLD u-boot commands support for PFR
@@ -28,14 +28,15 @@ ast#
Signed-off-by: AppaRao Puli <apparao.puli@linux.intel.com>
+Signed-off-by: Vikram Bodireddy <vikram.bodireddy@intel.com>
---
cmd/Makefile | 1 +
- cmd/cpld.c | 244 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ cmd/cpld.c | 244 +++++++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 245 insertions(+)
create mode 100644 cmd/cpld.c
diff --git a/cmd/Makefile b/cmd/Makefile
-index a1731be..c8ac0af 100644
+index a1731be701..c8ac0af55c 100644
--- a/cmd/Makefile
+++ b/cmd/Makefile
@@ -66,6 +66,7 @@ obj-$(CONFIG_CMD_FUSE) += fuse.o
@@ -48,7 +49,7 @@ index a1731be..c8ac0af 100644
obj-$(CONFIG_CMD_IDE) += ide.o
diff --git a/cmd/cpld.c b/cmd/cpld.c
new file mode 100644
-index 0000000..06b2e98
+index 0000000000..1b225d20dc
--- /dev/null
+++ b/cmd/cpld.c
@@ -0,0 +1,244 @@
@@ -67,7 +68,7 @@ index 0000000..06b2e98
+#include <linux/compiler.h>
+
+#define PFR_CPLD_I2C_BUSNO 4
-+#define PFR_CPLD_SLAVE_ADDR 0xE0
++#define PFR_CPLD_SLAVE_ADDR 0x70
+
+#define CPLD_READ_TIMEOUT_ATTEMPTS 5
+
@@ -297,5 +298,5 @@ index 0000000..06b2e98
+
+U_BOOT_CMD(cpld, 4, 1, do_cpld, "PFR CPLD information", cpld_help_text);
--
-2.7.4
+2.17.1