summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-core')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/at-scale-debug_git.bb6
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/files/0001-ASD-Fix-sprintf_s-compilation-issue-for-safec-3.5.1.patch35
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/interfaces/libmctp_git.bb2
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem_%.bbappend2
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/ncurses/ncurses/0001-Fix-heap-buffer-overflow-in-captoinfo.patch47
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/ncurses/ncurses_%.bbappend2
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/safec/safec_%.bbappend11
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/safec/safec_3.4.bb15
8 files changed, 90 insertions, 30 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/at-scale-debug_git.bb b/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/at-scale-debug_git.bb
index 74db92917..e2fa7b57e 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/at-scale-debug_git.bb
+++ b/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/at-scale-debug_git.bb
@@ -12,8 +12,10 @@ DEPENDS = "sdbusplus openssl libpam libgpiod safec"
do_configure[depends] += "virtual/kernel:do_shared_workdir"
-SRC_URI = "git://github.com/Intel-BMC/asd;protocol=git"
-SRCREV = "1.4.6"
+SRC_URI = "git://github.com/Intel-BMC/asd;protocol=https"
+SRCREV = "1.4.7"
+
+SRC_URI += "file://0001-ASD-Fix-sprintf_s-compilation-issue-for-safec-3.5.1.patch"
inherit useradd
diff --git a/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/files/0001-ASD-Fix-sprintf_s-compilation-issue-for-safec-3.5.1.patch b/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/files/0001-ASD-Fix-sprintf_s-compilation-issue-for-safec-3.5.1.patch
new file mode 100644
index 000000000..943ffb4a8
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/files/0001-ASD-Fix-sprintf_s-compilation-issue-for-safec-3.5.1.patch
@@ -0,0 +1,35 @@
+From efd1373e7c4a7a89609184aa0b5e1c3edcb8be6a Mon Sep 17 00:00:00 2001
+From: Ernesto Corona <ernesto.corona@intel.com>
+Date: Fri, 19 Nov 2021 09:11:03 -0800
+Subject: [PATCH] ASD Fix sprintf_s compilation issue for safec 3.5.1
+
+A missing macro was defined to ensure sprintf_s macro defintion is
+set when safe_str_lib.h is included.
+
+Test:
+Remove openbmc-meta-intel/meta-common/recipes-core/safec/safec_3.4.bb
+Compile at-scale-debug using devtool
+ASD Sanity finished successfully(SPR).
+
+Signed-off-by: Ernesto Corona <ernesto.corona@intel.com>
+Change-Id: Idd94b4ba9ff8b4194317a045b140ce90db2ee860
+---
+ CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 59ff03c..d6239a4 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -4,6 +4,8 @@ project(at-scale-debug C)
+ find_package (PkgConfig REQUIRED)
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/sysroot/include)
+ pkg_check_modules (SAFEC REQUIRED libsafec)
++# Define HAVE_C99 to include sprintf_s macro in safec library
++set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DHAVE_C99")
+ include_directories (${SAFEC_INCLUDE_DIRS})
+ link_directories (${SAFEC_LIBRARY_DIRS})
+
+--
+2.25.1
+
diff --git a/meta-openbmc-mods/meta-common/recipes-core/interfaces/libmctp_git.bb b/meta-openbmc-mods/meta-common/recipes-core/interfaces/libmctp_git.bb
index eba56f829..79027b766 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/interfaces/libmctp_git.bb
+++ b/meta-openbmc-mods/meta-common/recipes-core/interfaces/libmctp_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "libmctp"
DESCRIPTION = "Implementation of MCTP (DTMF DSP0236)"
SRC_URI = "git://github.com/openbmc/libmctp.git"
-SRCREV = "663ec39ea107c2a736f9bcb20cbfdfa623092ab1"
+SRCREV = "983cc3fa49dcac2e640e814500221c6acc177eff"
PV = "0.1+git${SRCPV}"
diff --git a/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem_%.bbappend b/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem_%.bbappend
index ac61d983c..a9e6c81ad 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem_%.bbappend
@@ -2,7 +2,7 @@ EXTRA_OECMAKE += "${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', '-DINTEL_PF
EXTRA_OECMAKE += "${@bb.utils.contains('EXTRA_IMAGE_FEATURES', 'validation-unsecure', '-DBMC_VALIDATION_UNSECURE_FEATURE=ON', '', d)}"
EXTRA_OECMAKE += "-DUSING_ENTITY_MANAGER_DECORATORS=OFF"
SRC_URI = "git://github.com/openbmc/intel-ipmi-oem.git"
-SRCREV = "9e58cfe1ba5ca5bcd5263b50730c5a231eabdd4f"
+SRCREV = "d2d60ab5b325c4630c8e794e861b88cf3c9337bf"
FILESEXTRAPATHS:append := ":${THISDIR}/${PN}"
diff --git a/meta-openbmc-mods/meta-common/recipes-core/ncurses/ncurses/0001-Fix-heap-buffer-overflow-in-captoinfo.patch b/meta-openbmc-mods/meta-common/recipes-core/ncurses/ncurses/0001-Fix-heap-buffer-overflow-in-captoinfo.patch
new file mode 100644
index 000000000..420a19b41
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-core/ncurses/ncurses/0001-Fix-heap-buffer-overflow-in-captoinfo.patch
@@ -0,0 +1,47 @@
+From ad135388ac66b7c8276b0899d9b43433e2faffa6 Mon Sep 17 00:00:00 2001
+From: P Dheeraj Srujan Kumar <p.dheeraj.srujan.kumar@intel.com>
+Date: Tue, 7 Dec 2021 23:58:53 +0000
+Subject: [PATCH] Fix heap-buffer-overflow in captoinfo
+
+This has been picked up from http://cvsweb.netbsd.org/
+bsdweb.cgi/pkgsrc/devel/ncurses/patches/Attic/
+patch-ncurses_tinfo_captoinfo.c
+?rev=1.1&content-type=text/x-cvsweb-markup
+
+Thomas Dickey is the owner of this patch.
+This fix is a part of
+https://github.com/ThomasDickey/ncurses-snapshots/
+commit/63ca9e061f4644795d6f3f559557f3e1ed8c738b#diff-
+7e95c7bc5f213e9be438e69a9d5d0f261a14952bcbd692f7b9014217b8047340
+
+Signed-off-by: P Dheeraj Srujan Kumar <p.dheeraj.srujan.kumar@intel.com>
+---
+ ncurses/tinfo/captoinfo.c | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/ncurses/tinfo/captoinfo.c b/ncurses/tinfo/captoinfo.c
+index 8b3b83d1..c9741405 100644
+--- a/ncurses/tinfo/captoinfo.c
++++ b/ncurses/tinfo/captoinfo.c
+@@ -216,12 +216,15 @@ cvtchar(register const char *sp)
+ }
+ break;
+ case '^':
++ len = 2;
+ c = UChar(*++sp);
+- if (c == '?')
++ if (c == '?') {
+ c = 127;
+- else
++ } else if (c == '\0') {
++ len = 1;
++ } else {
+ c &= 0x1f;
+- len = 2;
++ }
+ break;
+ default:
+ c = UChar(*sp);
+--
+2.17.1
+
diff --git a/meta-openbmc-mods/meta-common/recipes-core/ncurses/ncurses_%.bbappend b/meta-openbmc-mods/meta-common/recipes-core/ncurses/ncurses_%.bbappend
new file mode 100644
index 000000000..e60bd9a6b
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-core/ncurses/ncurses_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://0001-Fix-heap-buffer-overflow-in-captoinfo.patch"
diff --git a/meta-openbmc-mods/meta-common/recipes-core/safec/safec_%.bbappend b/meta-openbmc-mods/meta-common/recipes-core/safec/safec_%.bbappend
deleted file mode 100644
index b8256e2b1..000000000
--- a/meta-openbmc-mods/meta-common/recipes-core/safec/safec_%.bbappend
+++ /dev/null
@@ -1,11 +0,0 @@
-RDEPENDS:${PN} = ""
-do_install:append() {
- F=$(find ${D} -name check_for_unsafe_apis)
- if [ -n "${F}" ]; then
- # remove the unused perl script
- rm -f "${F}"
- # remove the script's destination directory, only if it is empty
- rmdir "$(dirname ${F})" 2>/dev/null || :
- fi
-}
-
diff --git a/meta-openbmc-mods/meta-common/recipes-core/safec/safec_3.4.bb b/meta-openbmc-mods/meta-common/recipes-core/safec/safec_3.4.bb
deleted file mode 100644
index cf83203ec..000000000
--- a/meta-openbmc-mods/meta-common/recipes-core/safec/safec_3.4.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-SUMMARY = "Safe C Library"
-
-LICENSE = "safec"
-LIC_FILES_CHKSUM = "file://COPYING;md5=6d0eb7dfc57806a006fcbc4e389cf164"
-SECTION = "lib"
-
-inherit autotools pkgconfig
-
-S = "${WORKDIR}/git"
-SRCREV = "e8bf1fff157ba931692130a0ec6f2833fa7d5f87"
-SRC_URI = "git://github.com/rurban/safeclib.git"
-
-COMPATIBLE_HOST = '(x86_64|i.86|powerpc|powerpc64|arm|aarch64).*-linux'
-
-RDEPENDS:${PN} = "perl"