summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-intel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-intel')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-intel/chassis/intel-chassis-control.bb2
-rw-r--r--meta-openbmc-mods/meta-common/recipes-intel/hsbp/hsbp-manager_git.bb21
-rw-r--r--meta-openbmc-mods/meta-common/recipes-intel/images/intel-platforms.bb1
-rwxr-xr-xmeta-openbmc-mods/meta-common/recipes-intel/intel-pfr/files/pfr_image.py22
-rw-r--r--meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/files/pfr_manifest.json16
-rw-r--r--meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/intel-blocksign-native.bb40
-rw-r--r--meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/intel-pfr-manager_git.bb4
-rw-r--r--meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/obmc-intel-pfr-image-native.bb73
-rw-r--r--meta-openbmc-mods/meta-common/recipes-intel/ipccli/ipccli_svn.bb14
-rw-r--r--meta-openbmc-mods/meta-common/recipes-intel/packagegroups/packagegroup-obmc-apps.bbappend1
-rw-r--r--meta-openbmc-mods/meta-common/recipes-intel/psu-manager/psu-manager.bb6
-rw-r--r--meta-openbmc-mods/meta-common/recipes-intel/smbios/smbios-mdrv1.bb2
-rw-r--r--meta-openbmc-mods/meta-common/recipes-intel/smbios/smbios-mdrv2.bb2
13 files changed, 106 insertions, 98 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/chassis/intel-chassis-control.bb b/meta-openbmc-mods/meta-common/recipes-intel/chassis/intel-chassis-control.bb
index f727b4536..193ad8ba0 100644
--- a/meta-openbmc-mods/meta-common/recipes-intel/chassis/intel-chassis-control.bb
+++ b/meta-openbmc-mods/meta-common/recipes-intel/chassis/intel-chassis-control.bb
@@ -2,7 +2,7 @@ SUMMARY = "Chassis Power Control service for Intel based platform"
DESCRIPTION = "Chassis Power Control service for Intel based platfrom"
SRC_URI = "git://git@github.com/Intel-BMC/intel-chassis-control.git;protocol=ssh"
-SRCREV = "b9e1b13e42359baf21592480874a176548071cf2"
+SRCREV = "0d766e3ea2af610ca63c8c828cb284da0e706b19"
S = "${WORKDIR}/git/services/chassis/"
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/hsbp/hsbp-manager_git.bb b/meta-openbmc-mods/meta-common/recipes-intel/hsbp/hsbp-manager_git.bb
new file mode 100644
index 000000000..c92ea6d01
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-intel/hsbp/hsbp-manager_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "HSBP Manager"
+DESCRIPTION = "HSBP Manager monitors HSBPs through SMBUS"
+
+SRC_URI = "git://git@github.com/Intel-BMC/provingground.git;protocol=ssh"
+SRCREV = "30110fe5b18999bddc5721dc5611f542f6feeabd"
+PV = "0.1+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SYSTEMD_SERVICE_${PN} = "hsbp-manager.service"
+
+DEPENDS = "boost \
+ i2c-tools \
+ sdbusplus"
+
+S = "${WORKDIR}/git/hsbp-manager"
+inherit cmake systemd
+
+EXTRA_OECMAKE = "-DYOCTO=1"
+
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/images/intel-platforms.bb b/meta-openbmc-mods/meta-common/recipes-intel/images/intel-platforms.bb
index 545ecae7f..8fa7ba865 100644
--- a/meta-openbmc-mods/meta-common/recipes-intel/images/intel-platforms.bb
+++ b/meta-openbmc-mods/meta-common/recipes-intel/images/intel-platforms.bb
@@ -3,7 +3,6 @@ DESCRIPTION = "Image with Intel content based upon Phosphor, an OpenBMC framewor
inherit obmc-phosphor-full-fitimage
inherit obmc-phosphor-image-common
inherit obmc-phosphor-image-dev
-inherit ${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', 'image_types_intel_pfr', '', d)}
DEPENDS += "${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', 'obmc-intel-pfr-image-native', '', d)}"
DEPENDS += "${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', 'intel-pfr-manager', '', d)}"
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/files/pfr_image.py b/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/files/pfr_image.py
index 5cda38b79..c2c18247d 100755
--- a/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/files/pfr_image.py
+++ b/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/files/pfr_image.py
@@ -1,4 +1,4 @@
-#/usr/bin/env python3
+#!/usr/bin/env python3
# coding: utf-8
# our image is contained as parts, including the hash
# then it gets zipped up and signed again
@@ -46,7 +46,7 @@ PFM_SPI = 0x1
PFM_I2C = 0x2
SHA256 = 0x1
SHA256_SIZE = 32
-PFM_DEF_SIZE = 16
+PFM_DEF_SIZE = 32 # 32 bytes of PFM header
PFM_SPI_SIZE_DEF = 16 # 16 bytes of SPI PFM
PFM_SPI_SIZE_HASH = 32 # 32 bytes of SPI region HASH
PFM_I2C_SIZE = 40 # 40 bytes of i2c rules region in PFM
@@ -102,7 +102,6 @@ class pfr_bmc_image(object):
for p in self.manifest['image-parts']:
# the json should have in the order- filename, index, offset, size and protection byte
self.image_parts.append((p['name'], p['index'], p['offset'], p['size'], p['prot_mask'], p['pfm'], p['hash'], p['compress']))
- print(self.image_parts)
self.act_dgst = hashlib.sha256()
@@ -124,7 +123,6 @@ class pfr_bmc_image(object):
for i in self.manifest['i2c-rules']:
# the json should have in the order- bus-id, rule-id, address, size and cmd-whitelist
self.i2c_rules.append((i['bus-id'], i['rule-id'], i['address'], i['cmd-whitelist']))
- print(self.i2c_rules)
# I2C rules PFM array
self.pfm_i2c_rules = []
@@ -205,7 +203,7 @@ class pfr_bmc_image(object):
if pfm_flag == 1:
self.pfm_bytes += PFM_SPI_SIZE_DEF
- hash = b'\x00' * 32
+ hash = bytearray(32)
hash_pres = 0
if hash_flag == 1:
@@ -232,7 +230,7 @@ class pfr_bmc_image(object):
whitelist_map[i] = 0xff
break
else:
- idx = int(c,16) / 8 # index in the 32 bytes of white list i2c cmds
+ idx = int(c,16) // 8 # index in the 32 bytes of white list i2c cmds
bit = int(c,16) % 8 # bit position to set
whitelist_map[idx] |= (1 << bit)
@@ -241,7 +239,6 @@ class pfr_bmc_image(object):
def build_i2c_rules(self):
for i in self.i2c_rules:
- print(i[0], i[1], i[2], i[3])
self.add_i2c_rules(i)
def hash_and_map(self):
@@ -327,10 +324,15 @@ class pfr_bmc_image(object):
}
# PFM should be 128bytes aligned, find the padding bytes
- padding_bytes = 128 - (self.pfm_bytes % 128)
+ padding_bytes = 0
+ if (self.pfm_bytes % 128) != 0:
+ padding_bytes = 128 - (self.pfm_bytes % 128)
+
+ print("padding={}".format(padding_bytes))
+ print("PFM size1={}".format(self.pfm_bytes))
self.pfm_bytes += padding_bytes
parts['pfm_len'] = struct.pack('<I', self.pfm_bytes)
- print("PFM size={}".format(self.pfm_bytes))
+ print("PFM size2={}".format(self.pfm_bytes))
with open("pfm.bin", "wb+") as f:
f.write(b''.join([parts[n] for n in names]))
@@ -343,7 +345,7 @@ class pfr_bmc_image(object):
f.write(struct.pack('<I', int(i.spi_end_addr)))
if i.spi_hash_pres == 1:
- f.write(i.spi_hash.decode('hex'))
+ f.write(bytearray.fromhex(i.spi_hash))
for r in self.pfm_i2c_rules:
f.write(struct.pack('<B', int(r.i2c_pfm)))
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/files/pfr_manifest.json b/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/files/pfr_manifest.json
index adea41eab..c9f7d0746 100644
--- a/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/files/pfr_manifest.json
+++ b/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/files/pfr_manifest.json
@@ -81,24 +81,24 @@
}
],
"i2c-rules": [{
- "bus-id": 5,
- "rule-id": 1,
+ "bus-id": 3,
+ "rule-id": 3,
"address": "0xD0",
"cmd-whitelist": ["0x00", "0x01", "0x02", "0x03", "0x04", "0x09", "0x0A", "0x0B", "0x0C", "0x0D", "0x0E", "0x0F",
"0x10", "0x13", "0x17", "0x1B", "0x1C", "0x1D", "0x02", "0x021", "0x22", "0x23", "0x25", "0x30",
"0x31", "0x32", "0x33", "0x035", "0x36", "0x37", "0x38", "0x39", "0x3A", "0x3B", "0x3C", "0x3D"]
},
{
- "bus-id": 5,
- "rule-id": 2,
- "address": "0xD6",
+ "bus-id": 3,
+ "rule-id": 4,
+ "address": "0xD8",
"cmd-whitelist": ["0x00", "0x01", "0x02", "0x03", "0x04", "0x09", "0x0A", "0x0B", "0x0C", "0x0D", "0x0E", "0x0F",
"0x10", "0x13", "0x17", "0x1B", "0x1C", "0x1D", "0x02", "0x021", "0x22", "0x23", "0x25", "0x30",
"0x31", "0x32", "0x33", "0x035", "0x36", "0x37", "0x38", "0x39", "0x3A", "0x3B", "0x3C", "0x3D"]
},
{
- "bus-id": 8,
- "rule-id": 3,
+ "bus-id": 1,
+ "rule-id": 6,
"address": "0xB0",
"cmd-whitelist": ["0x03", "0x05", "0x06", "0x19", "0x1A", "0x30", "0x3A", "0x3B", "0x3C", "0x3D", "0x3E", "0x3F",
"0x79", "0x7A", "0x7B", "0x7C", "0x7D", "0x7E", "0x7F", "0x81", "0x82", "0x86", "0x87", "0x88",
@@ -107,7 +107,7 @@
"0xD9", "0xDC", "0xDD", "0xDE", "0xDE"]
},
{
- "bus-id": 8,
+ "bus-id": 1,
"rule-id": 4,
"address": "0xB2",
"cmd-whitelist": ["0x03", "0x05", "0x06", "0x19", "0x1A", "0x30", "0x3A", "0x3B", "0x3C", "0x3D", "0x3E", "0x3F",
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/intel-blocksign-native.bb b/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/intel-blocksign-native.bb
index 12394dd91..3f7776e06 100644
--- a/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/intel-blocksign-native.bb
+++ b/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/intel-blocksign-native.bb
@@ -1,20 +1,20 @@
-SUMMARY = "Intel Blocksign tool for PFR image"
-DESCRIPTION = "Image signing tool for BMC PFR image"
-
-inherit native cmake
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-DEPENDS = "openssl-native libxml2-native "
-
-SRC_URI = "git://git@github.com/Intel-BMC/blocksign;protocol=ssh"
-
-SRCREV = "60d76db038a0d85851098b13451246abb0d876ed"
-
-S = "${WORKDIR}/git/"
-
-do_install_append() {
- install -d ${STAGING_DIR}/intel-pfr-files
- install -m 775 ${B}/blocksign ${STAGING_DIR}/intel-pfr-files
-}
+SUMMARY = "Intel Blocksign tool for PFR image"
+DESCRIPTION = "Image signing tool for BMC PFR image"
+
+inherit native cmake
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+DEPENDS = "openssl-native libxml2-native "
+
+SRC_URI = "git://git@github.com/Intel-BMC/blocksign;protocol=ssh"
+
+SRCREV = "60d76db038a0d85851098b13451246abb0d876ed"
+
+S = "${WORKDIR}/git/"
+
+do_install_append() {
+ install -d ${D}/${bindir}
+ install -m 775 ${B}/blocksign ${D}/${bindir}
+}
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/intel-pfr-manager_git.bb b/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/intel-pfr-manager_git.bb
index 96bfec0a8..a832a5952 100644
--- a/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/intel-pfr-manager_git.bb
+++ b/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/intel-pfr-manager_git.bb
@@ -9,10 +9,10 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI = "git://git@github.com/Intel-BMC/provingground.git;protocol=ssh"
-SRCREV = "226ca2842e0a14ad56b4ebeedfd82ac2ea7e145e"
+SRCREV = "30110fe5b18999bddc5721dc5611f542f6feeabd"
inherit cmake systemd
-SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Intel.PFR.Manager.service"
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.PFR.Manager.service"
DEPENDS += " \
sdbusplus \
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/obmc-intel-pfr-image-native.bb b/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/obmc-intel-pfr-image-native.bb
index 307fe1829..910e61142 100644
--- a/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/obmc-intel-pfr-image-native.bb
+++ b/meta-openbmc-mods/meta-common/recipes-intel/intel-pfr/obmc-intel-pfr-image-native.bb
@@ -1,37 +1,36 @@
-SUMMARY = "Intel PFR manifest and signing key for development and testing"
-DESCRIPTION = "Do not use this signing keys to sign CI and release images."
-
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit native
-
-PFR_KEY_NAME ?= "pfr-dev-key"
-PFR_SIGN_UTIL ?= "blocksign"
-DEPENDS += " intel-blocksign-native"
-
-SRC_URI = " \
- file://pfr_manifest.json \
- file://pfr_image.py \
- file://pfm_config.xml \
- file://bmc_config.xml \
- file://csk_prv.pem \
- file://csk_pub.pem \
- file://rk_pub.pem \
- file://rk_prv.pem \
- "
-
-do_install() {
- bbplain "Copying the intel pfr image generation scripts and image signing keys"
-
- install -d ${STAGING_DIR}/intel-pfr-files
- install -m 400 ${WORKDIR}/pfr_manifest.json ${STAGING_DIR}/intel-pfr-files
- install -m 400 ${WORKDIR}/pfm_config.xml ${STAGING_DIR}/intel-pfr-files
- install -m 400 ${WORKDIR}/bmc_config.xml ${STAGING_DIR}/intel-pfr-files
- install -m 775 ${WORKDIR}/pfr_image.py ${STAGING_DIR}/intel-pfr-files
- install -m 400 ${WORKDIR}/csk_prv.pem ${STAGING_DIR}/intel-pfr-files
- install -m 400 ${WORKDIR}/csk_pub.pem ${STAGING_DIR}/intel-pfr-files
- install -m 400 ${WORKDIR}/rk_pub.pem ${STAGING_DIR}/intel-pfr-files
- install -m 400 ${WORKDIR}/rk_prv.pem ${STAGING_DIR}/intel-pfr-files
-}
+SUMMARY = "Intel PFR image manifest and image signing keys"
+DESCRIPTION = "This copies PFR image generation scripts and image signing keys to staging area"
+
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit native
+
+DEPENDS += " intel-blocksign-native"
+
+SRC_URI = " \
+ file://pfr_manifest.json \
+ file://pfr_image.py \
+ file://pfm_config.xml \
+ file://bmc_config.xml \
+ file://csk_prv.pem \
+ file://csk_pub.pem \
+ file://rk_pub.pem \
+ file://rk_prv.pem \
+ "
+
+do_install() {
+ bbplain "Copying intel pfr image generation scripts and image signing keys"
+
+ install -d ${D}/${bindir}
+ install -d ${D}/${datadir}/pfrconfig
+ install -m 775 ${WORKDIR}/pfr_image.py ${D}${bindir}
+ install -m 400 ${WORKDIR}/pfr_manifest.json ${D}/${datadir}/pfrconfig
+ install -m 400 ${WORKDIR}/pfm_config.xml ${D}/${datadir}/pfrconfig
+ install -m 400 ${WORKDIR}/bmc_config.xml ${D}/${datadir}/pfrconfig
+ install -m 400 ${WORKDIR}/csk_prv.pem ${D}/${datadir}/pfrconfig
+ install -m 400 ${WORKDIR}/csk_pub.pem ${D}/${datadir}/pfrconfig
+ install -m 400 ${WORKDIR}/rk_pub.pem ${D}/${datadir}/pfrconfig
+ install -m 400 ${WORKDIR}/rk_prv.pem ${D}/${datadir}/pfrconfig
+}
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/ipccli/ipccli_svn.bb b/meta-openbmc-mods/meta-common/recipes-intel/ipccli/ipccli_svn.bb
deleted file mode 100644
index ce7d79975..000000000
--- a/meta-openbmc-mods/meta-common/recipes-intel/ipccli/ipccli_svn.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "ipccli"
-HOMEPAGE = "https://www.intel.com"
-LICENSE = "CLOSED"
-LIC_FILES_CHKSUM = ""
-
-SRC_URI[md5sum] = "917092bfe4244aa4312b572c2c9c303f"
-SRC_URI = "svn://ssvn.pdx.intel.com/deg/pve/csv/pythonsv/subprojects/;module=ipccli;rev=804701;protocol=https;user=etanous;pswd=Cardinal2bali!"
-
-DEPENDS_${PN} += "python-setuptools-native"
-
-S = "${WORKDIR}/ipccli/trunk"
-inherit setuptools
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/packagegroups/packagegroup-obmc-apps.bbappend b/meta-openbmc-mods/meta-common/recipes-intel/packagegroups/packagegroup-obmc-apps.bbappend
index d3b283202..c3443107d 100644
--- a/meta-openbmc-mods/meta-common/recipes-intel/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-intel/packagegroups/packagegroup-obmc-apps.bbappend
@@ -1 +1,2 @@
RDEPENDS_${PN}-extrasdevtools = "libgpiod-tools"
+RDEPENDS_${PN}-chassis-state-mgmt_remove = "obmc-phosphor-power"
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/psu-manager/psu-manager.bb b/meta-openbmc-mods/meta-common/recipes-intel/psu-manager/psu-manager.bb
index 63576a3de..88b49a2fd 100644
--- a/meta-openbmc-mods/meta-common/recipes-intel/psu-manager/psu-manager.bb
+++ b/meta-openbmc-mods/meta-common/recipes-intel/psu-manager/psu-manager.bb
@@ -1,8 +1,8 @@
SUMMARY = "Power supply manager for Intel based platform"
DESCRIPTION = "Power supply manager which include PSU Cold Redundancy service"
-SRC_URI = "git://git@github.com/Intel-BMC/provingground.git;protocol=ssh;nobranch=1"
-SRCREV = "fe33964c744f871f3e024dd8d0b6ffba67394c30"
+SRC_URI = "git://git@github.com/Intel-BMC/provingground.git;protocol=ssh"
+SRCREV = "30110fe5b18999bddc5721dc5611f542f6feeabd"
S = "${WORKDIR}/git/psu-manager/"
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit cmake
inherit systemd
-SYSTEMD_SERVICE_${PN} += "cold-redundancy.service"
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.coldredundancy.service"
DEPENDS += " \
systemd \
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/smbios/smbios-mdrv1.bb b/meta-openbmc-mods/meta-common/recipes-intel/smbios/smbios-mdrv1.bb
index 0f6893ed6..be97ab43d 100644
--- a/meta-openbmc-mods/meta-common/recipes-intel/smbios/smbios-mdrv1.bb
+++ b/meta-openbmc-mods/meta-common/recipes-intel/smbios/smbios-mdrv1.bb
@@ -2,7 +2,7 @@ SUMMARY = "SMBIOS MDR version 1 service for Intel based platform"
DESCRIPTION = "SMBIOS MDR version 1 service for Intel based platfrom"
SRC_URI = "git://git@github.com/Intel-BMC/provingground.git;protocol=ssh"
-SRCREV = "226ca2842e0a14ad56b4ebeedfd82ac2ea7e145e"
+SRCREV = "30110fe5b18999bddc5721dc5611f542f6feeabd"
S = "${WORKDIR}/git/services/smbios/"
diff --git a/meta-openbmc-mods/meta-common/recipes-intel/smbios/smbios-mdrv2.bb b/meta-openbmc-mods/meta-common/recipes-intel/smbios/smbios-mdrv2.bb
index 71ac31348..0d8da0db1 100644
--- a/meta-openbmc-mods/meta-common/recipes-intel/smbios/smbios-mdrv2.bb
+++ b/meta-openbmc-mods/meta-common/recipes-intel/smbios/smbios-mdrv2.bb
@@ -2,7 +2,7 @@ SUMMARY = "SMBIOS MDR version 2 service for Intel based platform"
DESCRIPTION = "SMBIOS MDR version 2 service for Intel based platfrom"
SRC_URI = "git://git@github.com/Intel-BMC/provingground.git;protocol=ssh"
-SRCREV = "226ca2842e0a14ad56b4ebeedfd82ac2ea7e145e"
+SRCREV = "30110fe5b18999bddc5721dc5611f542f6feeabd"
S = "${WORKDIR}/git/services/smbios-mdrv2/"