summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/flash/phosphor-software-manager/0005-Modified-firmware-activation-to-launch-fwupd.sh-thro.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/flash/phosphor-software-manager/0005-Modified-firmware-activation-to-launch-fwupd.sh-thro.patch')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/flash/phosphor-software-manager/0005-Modified-firmware-activation-to-launch-fwupd.sh-thro.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/flash/phosphor-software-manager/0005-Modified-firmware-activation-to-launch-fwupd.sh-thro.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/flash/phosphor-software-manager/0005-Modified-firmware-activation-to-launch-fwupd.sh-thro.patch
index aa5d900e0..355261e8f 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/flash/phosphor-software-manager/0005-Modified-firmware-activation-to-launch-fwupd.sh-thro.patch
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/flash/phosphor-software-manager/0005-Modified-firmware-activation-to-launch-fwupd.sh-thro.patch
@@ -1,26 +1,27 @@
-From 7f29c255dd2af7fa6d38b02ad63a8b8940fbce84 Mon Sep 17 00:00:00 2001
+From 32d90301c494c1b43f8e1d74ac9e7c1dc2fe486a Mon Sep 17 00:00:00 2001
From: Jennifer Lee <jennifer1.lee@intel.com>
Date: Mon, 10 Dec 2018 10:36:44 -0800
-Subject: [PATCH 5/6] Modified firmware activation to launch fwupd.sh through
+Subject: [PATCH 1/1] Modified firmware activation to launch fwupd.sh through
+
non-ubi fs code path to match more closely to the upstream design -
Added option FWUPD_SCRIPT to saperate intel customized code - Adopted
ActivationProgress from ubi fs activation code mainly for progress indicator
for ipmi update
Signed-off-by: Jennifer Lee <jennifer1.lee@intel.com>
-Change-Id: Id805deea75b21fab86f6bb6edbf50ddb3be42564
+Signed-off-by: James Feist <james.feist@linux.intel.com>
---
- activation.cpp | 44 ++++++++++++++++++++++++++++++++++++++++++++
+ activation.cpp | 43 +++++++++++++++++++++++++++++++++++++++++++
configure.ac | 7 +++++++
static/flash.cpp | 41 +++++++++++++++++++++++++++++++++++++++--
ubi/flash.cpp | 9 +++------
- 4 files changed, 93 insertions(+), 8 deletions(-)
+ 4 files changed, 92 insertions(+), 8 deletions(-)
diff --git a/activation.cpp b/activation.cpp
-index f918221..f2923ae 100644
+index ab76420..91e3a10 100644
--- a/activation.cpp
+++ b/activation.cpp
-@@ -163,6 +163,50 @@ auto Activation::activation(Activations value) -> Activations
+@@ -200,6 +200,49 @@ auto Activation::activation(Activations value) -> Activations
softwareServer::Activation::Activations::Active);
}
}
@@ -48,7 +49,6 @@ index f918221..f2923ae 100644
+ }
+#endif
+ flashWrite();
-+ activationProgress->progress(10);
+ }
+ else if (activationProgress->progress() == 100)
+ {
@@ -72,12 +72,12 @@ index f918221..f2923ae 100644
#ifdef WANT_SIGNATURE_VERIFY
diff --git a/configure.ac b/configure.ac
-index 2da97ad..720e704 100755
+index 5fba420..3b5fdab 100755
--- a/configure.ac
+++ b/configure.ac
-@@ -184,6 +184,13 @@ AS_IF([test "x$enable_ubifs_layout" == "xyes"], \
- [AC_DEFINE([UBIFS_LAYOUT],[],[Enable ubifs support.])])
- AM_CONDITIONAL([UBIFS_LAYOUT], [test "x$enable_ubifs_layout" == "xyes"])
+@@ -194,6 +194,13 @@ AS_IF([test "x$enable_host_bios_upgrade" == "xyes"], \
+ [AC_DEFINE([HOST_BIOS_UPGRADE],[],[Enable host bios upgrade support.])])
+ AM_CONDITIONAL([HOST_BIOS_UPGRADE], [test "x$enable_host_bios_upgrade" == "xyes"])
+# setup fwupd script support
+AC_ARG_ENABLE([fwupd_script],