summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend51
1 files changed, 25 insertions, 26 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend
index d9b32f5ae..7e9d42228 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend
@@ -1,5 +1,5 @@
SRC_URI = "git://github.com/openbmc/bmcweb.git"
-SRCREV = "dab0604af234bdd5010407031a01343d6c242edf"
+SRCREV = "2ebb9683287cf6b1a2f2cc3c077bd99aceefa8dd"
DEPENDS += "boost-url"
RDEPENDS_${PN} += "phosphor-nslcd-authority-cert-config"
@@ -14,20 +14,33 @@ GROUPADD_PARAM_${PN} = "web; redfish "
SRC_URI += "file://0001-Firmware-update-configuration-changes.patch \
file://0002-Use-chip-id-based-UUID-for-Service-Root.patch \
- file://0004-bmcweb-handle-device-or-resource-busy-exception.patch \
- file://0006-Define-Redfish-interface-Registries-Bios.patch \
- file://0007-BIOS-config-Add-support-for-PATCH-operation.patch \
- file://0008-Add-support-to-ResetBios-action.patch \
- file://0009-Add-support-to-ChangePassword-action.patch \
file://0010-managers-add-attributes-for-Manager.CommandShell.patch \
- file://0034-recommended-fixes-by-crypto-review-team.patch \
file://0011-bmcweb-Add-PhysicalContext-to-Thermal-resources.patch \
file://0012-Log-RedFish-event-for-Invalid-login-attempt.patch \
file://0013-Add-UART-routing-logic-into-host-console-connection-.patch \
+ file://0014-recommended-fixes-by-crypto-review-team.patch \
+ file://0015-Add-state-sensor-messages-to-the-registry.patch \
+ file://0016-Fix-bmcweb-crashes-if-socket-directory-not-present.patch \
+ file://0017-Add-msg-registry-for-subscription-related-actions.patch \
"
-# Temporary downstream mirror of upstream patch to enable feature in Intel builds.
-SRC_URI += "file://0037-Add-state-sensor-messages-to-the-registry.patch \
+# OOB Bios Config:
+SRC_URI += "file://biosconfig/0001-Define-Redfish-interface-Registries-Bios.patch \
+ file://biosconfig/0002-BaseBiosTable-Add-support-for-PATCH-operation.patch \
+ file://biosconfig/0003-Add-support-to-ResetBios-action.patch \
+ file://biosconfig/0004-Add-support-to-ChangePassword-action.patch \
+ file://biosconfig/0005-Fix-remove-bios-user-pwd-change-option-via-Redfish.patch \
+"
+
+# Virtual Media: Backend code is not upstreamed so downstream only patches.
+SRC_URI += "file://vm/0001-Revert-Disable-nbd-proxy-from-the-build.patch \
+ file://vm/0002-bmcweb-handle-device-or-resource-busy-exception.patch \
+ file://vm/0003-Add-ConnectedVia-property-to-virtual-media-item-temp.patch \
+ file://vm/0004-Invalid-status-code-from-InsertMedia-REST-methods.patch \
+ file://vm/0005-Set-Inserted-redfish-property-for-not-inserted-resou.patch \
+ file://vm/0006-Bmcweb-handle-permission-denied-exception.patch \
+ file://vm/0007-Fix-unmounting-image-in-proxy-mode.patch \
+ file://vm/0008-Fix-VM-NBDPROXY-build-issue-with-AsyncResp.patch \
"
# EventService: Temporary pulled to downstream. See eventservice\README for details
@@ -36,26 +49,12 @@ SRC_URI += "file://eventservice/0001-EventService-Fix-retry-handling-for-http-cl
file://eventservice/0004-Add-Server-Sent-Events-support.patch \
file://eventservice/0005-Add-SSE-style-subscription-support-to-eventservice.patch \
file://eventservice/0006-Add-EventService-SSE-filter-support.patch \
+ file://eventservice/0007-EventService-Log-events-for-subscription-actions.patch \
"
# Temporary downstream mirror of upstream patches, see telemetry\README for details
-SRC_URI += "file://telemetry/0003-Add-support-for-MetricDefinition-scheme.patch \
- file://telemetry/0004-Sync-Telmetry-service-with-EventService.patch \
-"
-
-SRC_URI += "file://0001-Add-ConnectedVia-property-to-virtual-media-item-temp.patch \
- file://0002-Invalid-status-code-from-InsertMedia-REST-methods.patch \
- file://0003-Set-Inserted-redfish-property-for-not-inserted-resou.patch \
- file://0004-Bmcweb-handle-permission-denied-exception.patch \
- file://0005-Fix-unmounting-image-in-proxy-mode.patch \
-"
-
-SRC_URI += "file://0038-Revert-Disable-nbd-proxy-from-the-build.patch \
- file://0039-Fix-comparison-for-proxy-legacy-mode.patch \
-"
-
-# Fix to avoid bmcweb crash on VM mount
-SRC_URI += "file://0039-Fix-bmcweb-crashes-if-socket-directory-not-present.patch \
+SRC_URI += " file://telemetry/0003-Add-support-for-MetricDefinition-scheme.patch \
+ file://telemetry/0004-Sync-Telmetry-service-with-EventService.patch \
"
# Temporary fix: Move it to service file