summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-gnome/recipes-gnome/evince/evince_40.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-gnome/recipes-gnome/evince/evince_40.1.bb')
-rw-r--r--meta-openembedded/meta-gnome/recipes-gnome/evince/evince_40.1.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/evince/evince_40.1.bb b/meta-openembedded/meta-gnome/recipes-gnome/evince/evince_40.1.bb
new file mode 100644
index 000000000..3b1a978c6
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/evince/evince_40.1.bb
@@ -0,0 +1,54 @@
+SUMMARY = "Evince is a document viewer for document formats like pdf, ps, djvu"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=96f2f8d5ee576a2163977938ea36fa7b"
+SECTION = "x11/office"
+DEPENDS = " \
+ gnome-common-native \
+ yelp-tools-native \
+ appstream-glib \
+ gtk+3 \
+ gspell \
+ libsecret \
+ poppler \
+ gstreamer1.0-plugins-base \
+ orc \
+ adwaita-icon-theme \
+ libhandy \
+ ${@bb.utils.contains('DISTRO_FEATURES','x11','gnome-desktop3','',d)} \
+"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+inherit gnomebase itstool gnome-help pkgconfig gsettings gobject-introspection gettext mime-xdg gtk-doc
+
+def gnome_verdir(v):
+ return oe.utils.trim_version(v, 1)
+
+SRC_URI[archive.sha256sum] = "7a666363c350af2e3bbba7f14b3c1befc5012f9ed3d9d073447f4c59f33dcf2d"
+
+GTKDOC_MESON_OPTION = "gtk_doc"
+
+EXTRA_OEMESON = " \
+ -Dsystemduserunitdir=no \
+"
+
+do_compile_prepend() {
+ export GIR_EXTRA_LIBS_PATH="${B}/libdocument/.libs"
+}
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[nautilus] = "-Dnautilus=true,-Dnautilus=false,nautilus"
+PACKAGECONFIG[browser-plugin] = "-Dbrowser_plugin=true,-Dbrowser_plugin=false"
+
+RDEPENDS_${PN} += "glib-2.0-utils"
+RRECOMMMENDS_${PN} = "adwaita-icon-theme"
+
+PACKAGES =+ "${PN}-nautilus-extension"
+PACKAGES =+ "${PN}-browser-plugin"
+
+FILES_${PN} += "${datadir}/dbus-1 \
+ ${datadir}/metainfo \
+ ${datadir}/thumbnailers \
+"
+FILES_${PN}-nautilus-extension = "${libdir}/nautilus/*/*so"
+FILES_${PN}-browser-plugin = "${libdir}/mozilla/*/*so"