summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-connectivity/netplan
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-connectivity/netplan')
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-Handle-enum-element-override.patch34
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-dbus-Remove-unused-variabes.patch59
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch9
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0002-Makefile-Exclude-.h-files-from-target-rule.patch32
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan_0.102.bb (renamed from meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan_0.101.bb)7
5 files changed, 39 insertions, 102 deletions
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-Handle-enum-element-override.patch b/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-Handle-enum-element-override.patch
new file mode 100644
index 000000000..dfc6f90c4
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-Handle-enum-element-override.patch
@@ -0,0 +1,34 @@
+From 6d284f1ff81494a5fca91a399b92b218ea1a9ea8 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 8 Jun 2021 08:53:30 -0700
+Subject: [PATCH] Handle enum element override
+
+NETPLAN_DEF_TYPE_VIRTUAL and NETPLAN_DEF_TYPE_BRIDGE point
+to same value in enum, however here they are assigned individually
+which results in overriding the initialization of the objects
+
+Fixes
+src/netplan.h:85:33: error: initializer overrides prior initialization of this subobject [-Werror,-Winitializer-overrides]
+ [NETPLAN_DEF_TYPE_BRIDGE] = "bridges",
+ ^~~~~~~~~
+Upstream-Status: Submitted [https://github.com/canonical/netplan/pull/213]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/netplan.h | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/netplan.h b/src/netplan.h
+index d2c538b..26574f8 100644
+--- a/src/netplan.h
++++ b/src/netplan.h
+@@ -81,7 +81,6 @@ static const char* const netplan_def_type_to_str[NETPLAN_DEF_TYPE_MAX_] = {
+ [NETPLAN_DEF_TYPE_ETHERNET] = "ethernets",
+ [NETPLAN_DEF_TYPE_WIFI] = "wifis",
+ [NETPLAN_DEF_TYPE_MODEM] = "modems",
+- [NETPLAN_DEF_TYPE_VIRTUAL] = NULL,
+ [NETPLAN_DEF_TYPE_BRIDGE] = "bridges",
+ [NETPLAN_DEF_TYPE_BOND] = "bonds",
+ [NETPLAN_DEF_TYPE_VLAN] = "vlans",
+--
+2.32.0
+
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-dbus-Remove-unused-variabes.patch b/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-dbus-Remove-unused-variabes.patch
deleted file mode 100644
index 407e24ca0..000000000
--- a/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-dbus-Remove-unused-variabes.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-Subject: [PATCH 1/2] dbus: Remove unused variabes
-
-This issue is seen when using clang to compile it
-
-Same fix is needed for parse.c and networkd.c,
-
-Fixes
-src/dbus.c:49:23: error: unused variable 'stdout' [-Werror,-Wunused-variable]
-g_autofree gchar *stdout = NULL;
-^
-Upstream-Status: Submitted [https://github.com/CanonicalLtd/netplan/pull/175]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/dbus.c | 3 ---
- src/networkd.c | 1 -
- src/parse.c | 1 -
- 3 files changed, 5 deletions(-)
-
-diff --git a/src/dbus.c b/src/dbus.c
-index 9606fea..8e1ed9d 100644
---- a/src/dbus.c
-+++ b/src/dbus.c
-@@ -242,9 +242,6 @@ static int
- method_info(sd_bus_message *m, void *userdata, sd_bus_error *ret_error)
- {
- sd_bus_message *reply = NULL;
-- g_autoptr(GError) err = NULL;
-- g_autofree gchar *stdout = NULL;
-- g_autofree gchar *stderr = NULL;
- gint exit_status = 0;
-
- exit_status = sd_bus_message_new_method_return(m, &reply);
-diff --git a/src/networkd.c b/src/networkd.c
-index 7c86cd6..7200740 100644
---- a/src/networkd.c
-+++ b/src/networkd.c
-@@ -897,7 +897,6 @@ append_wpa_auth_conf(GString* s, const NetplanAuthenticationSettings* auth, cons
- static void
- write_wpa_unit(const NetplanNetDefinition* def, const char* rootdir)
- {
-- g_autoptr(GError) err = NULL;
- g_autofree gchar *stdouth = NULL;
-
- stdouth = systemd_escape(def->id);
-diff --git a/src/parse.c b/src/parse.c
-index 033c657..faca27f 100644
---- a/src/parse.c
-+++ b/src/parse.c
-@@ -1899,7 +1899,6 @@ handle_wireguard_peers(yaml_document_t* doc, yaml_node_t* node, const void* _, G
- }
-
- for (yaml_node_item_t *i = node->data.sequence.items.start; i < node->data.sequence.items.top; i++) {
-- g_autofree char* addr = NULL;
- yaml_node_t *entry = yaml_document_get_node(doc, *i);
- assert_type(entry, YAML_MAPPING_NODE);
-
---
-2.25.1
-
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch b/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch
index dab8693c7..0fa6ba48a 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch
+++ b/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch
@@ -8,13 +8,11 @@ Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
src/util.c | 6 ++++++
1 file changed, 6 insertions(+)
-diff --git a/src/util.c b/src/util.c
-index 7e59985..eb8e573 100644
--- a/src/util.c
+++ b/src/util.c
-@@ -23,6 +23,12 @@
-
+@@ -24,6 +24,12 @@
#include "util.h"
+ #include "netplan.h"
+/* Don't fail if the standard library
+ * doesn't provide brace expansion */
@@ -25,6 +23,3 @@ index 7e59985..eb8e573 100644
GHashTable* wifi_frequency_24;
GHashTable* wifi_frequency_5;
---
-2.25.1
-
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0002-Makefile-Exclude-.h-files-from-target-rule.patch b/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0002-Makefile-Exclude-.h-files-from-target-rule.patch
deleted file mode 100644
index 68aabd6a4..000000000
--- a/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan/0002-Makefile-Exclude-.h-files-from-target-rule.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Subject: [PATCH 2/2] Makefile: Exclude .h files from target rule
-
-This ensures that src/_features.h is not added to compiler cmdline which
-can confuse the compilers e.g. clang as it may not like .h as valid input
-and complain
-
-| clang-11: error: cannot specify -o when generating multiple output files
-| make: *** [Makefile:50: netplan-dbus] Error 1
-| make: *** Waiting for unfinished jobs....
-
-Upstream-Status: Submitted [https://github.com/CanonicalLtd/netplan/pull/175]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index 4fa6bd8..567d326 100644
---- a/Makefile
-+++ b/Makefile
-@@ -46,7 +46,7 @@ generate: libnetplan.so.$(NETPLAN_SOVER) nm.o networkd.o openvswitch.o generate.
- $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $^ -L. -lnetplan `pkg-config --cflags --libs glib-2.0 gio-2.0 yaml-0.1 uuid`
-
- netplan-dbus: src/dbus.c src/_features.h util.o
-- $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $^ `pkg-config --cflags --libs libsystemd glib-2.0 gio-2.0`
-+ $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(patsubst %.h,,$^) `pkg-config --cflags --libs libsystemd glib-2.0 gio-2.0`
-
- src/_features.h: src/[^_]*.[hc]
- printf "#include <stddef.h>\nstatic const char *feature_flags[] __attribute__((__unused__)) = {\n" > $@
---
-2.25.1
-
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan_0.101.bb b/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan_0.102.bb
index a3afcd2d5..3328dfbbb 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan_0.101.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/netplan/netplan_0.102.bb
@@ -11,13 +11,12 @@ LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
S = "${WORKDIR}/git"
-SRCREV = "e445b87b9dff439ec564c245d030b03d61eb0f24"
-PV = "0.101+git${SRCPV}"
+SRCREV = "62701436991e42606c4e9e8dbdcdc5067d64f69b"
+PV = "0.102+git${SRCPV}"
SRC_URI = " \
git://github.com/CanonicalLtd/netplan.git \
- file://0001-dbus-Remove-unused-variabes.patch \
- file://0002-Makefile-Exclude-.h-files-from-target-rule.patch \
+ file://0001-Handle-enum-element-override.patch \
"
SRC_URI_append_libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch"