summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools/musl
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools/musl')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/musl/musl-nscd/0001-nsswitch.y-Replace-empty-bison-extension.patch50
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/musl/musl-nscd_git.bb1
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/musl/musl-nscd/0001-nsswitch.y-Replace-empty-bison-extension.patch b/meta-openembedded/meta-oe/recipes-devtools/musl/musl-nscd/0001-nsswitch.y-Replace-empty-bison-extension.patch
new file mode 100644
index 000000000..67c8b1bcf
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/musl/musl-nscd/0001-nsswitch.y-Replace-empty-bison-extension.patch
@@ -0,0 +1,50 @@
+From 82e51fb8ba2640b318826ef4e17b0f5c09c8dded Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 8 Mar 2021 20:10:18 -0800
+Subject: [PATCH] nsswitch.y: Replace %empty bison extension
+
+POSIX compliant yacc do not understand %empty therefore replace it with
+/* empty */
+
+https://github.com/pikhq/musl-nscd/issues/13
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/nsswitch.y | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/nsswitch.y b/src/nsswitch.y
+index 107073b..0b7c71e 100644
+--- a/src/nsswitch.y
++++ b/src/nsswitch.y
+@@ -38,7 +38,7 @@ top:
+ ;
+
+ file:
+- %empty {
++ /* empty */ {
+ list_init(&$$);
+ }
+ | file line {
+@@ -88,7 +88,7 @@ modifier:
+ ;
+
+ modifiers:
+- %empty {
++ /* empty */ {
+ memcpy($$, default_actions, sizeof($$));
+ }
+ | modifiers modifier {
+@@ -112,7 +112,7 @@ item:
+ ;
+
+ list:
+- %empty {
++ /* empty */ {
+ list_init(&$$);
+ }
+ | list item {
+--
+2.30.1
+
diff --git a/meta-openembedded/meta-oe/recipes-devtools/musl/musl-nscd_git.bb b/meta-openembedded/meta-oe/recipes-devtools/musl/musl-nscd_git.bb
index 83125a1ba..6af7ab9cd 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/musl/musl-nscd_git.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/musl/musl-nscd_git.bb
@@ -15,6 +15,7 @@ SRCREV = "af581482a3e1059458f3c8b20a56f82807ca3bd4"
SRC_URI = "git://github.com/pikhq/musl-nscd \
file://0001-Fix-build-under-GCC-fno-common.patch \
file://0001-configure-Check-for-flex-if-lex-is-not-found.patch \
+ file://0001-nsswitch.y-Replace-empty-bison-extension.patch \
"
UPSTREAM_CHECK_COMMITS = "1"